summaryrefslogtreecommitdiff
path: root/games-roguelike/stone-soup/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /games-roguelike/stone-soup/files
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'games-roguelike/stone-soup/files')
-rw-r--r--games-roguelike/stone-soup/files/gitless.patch13
-rw-r--r--games-roguelike/stone-soup/files/pyyaml-safe-load.patch11
2 files changed, 24 insertions, 0 deletions
diff --git a/games-roguelike/stone-soup/files/gitless.patch b/games-roguelike/stone-soup/files/gitless.patch
new file mode 100644
index 000000000000..3aaeb7470095
--- /dev/null
+++ b/games-roguelike/stone-soup/files/gitless.patch
@@ -0,0 +1,13 @@
+--- /Makefile 2019-04-15 19:34:40.604288477 -0500
++++ /Makefile 2019-04-15 19:36:25.249286603 -0500
+@@ -1149,9 +1149,8 @@
+
+ LANGUAGES = $(filter-out en, $(notdir $(wildcard dat/descript/??)))
+ SRC_PKG_BASE := stone_soup
+-SRC_VERSION := $(shell git describe --tags $(MERGE_BASE) 2>/dev/null || cat util/release_ver)
++SRC_VERSION := $(shell cat util/release_ver)
+ MAJOR_VERSION = $(shell echo "$(SRC_VERSION)"|sed -r 's/-.*//;s/^([^.]+\.[^.]+).*/\1/')
+-RECENT_TAG := $(shell git describe --abbrev=0 --tags $(MERGE_BASE))
+
+ export SRC_VERSION
+
diff --git a/games-roguelike/stone-soup/files/pyyaml-safe-load.patch b/games-roguelike/stone-soup/files/pyyaml-safe-load.patch
new file mode 100644
index 000000000000..dfbcdc96e1ad
--- /dev/null
+++ b/games-roguelike/stone-soup/files/pyyaml-safe-load.patch
@@ -0,0 +1,11 @@
+--- /util/species-gen.py 2019-04-18 23:19:07.444170831 -0500
++++ /util/species-gen.py 2019-04-18 23:20:19.958169533 -0500
+@@ -417,7 +417,7 @@
+ continue
+ f_path = os.path.join(args.datadir, f_name)
+ try:
+- species_spec = yaml.load(open(f_path))
++ species_spec = yaml.safe_load(open(f_path))
+ except yaml.YAMLError as e:
+ print("Failed to load %s: %s" % (f_name, e))
+ sys.exit(1)