summaryrefslogtreecommitdiff
path: root/games-roguelike/stone-soup/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-roguelike/stone-soup/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-roguelike/stone-soup/files')
-rw-r--r--games-roguelike/stone-soup/files/stone-soup-0.16.2-Use-pkg-config-for-linking-to-ncurses.patch49
-rw-r--r--games-roguelike/stone-soup/files/stone-soup-0.16.2-perl526.patch48
-rw-r--r--games-roguelike/stone-soup/files/stone-soup-0.16.2-respect-flags-and-compiler.patch110
3 files changed, 207 insertions, 0 deletions
diff --git a/games-roguelike/stone-soup/files/stone-soup-0.16.2-Use-pkg-config-for-linking-to-ncurses.patch b/games-roguelike/stone-soup/files/stone-soup-0.16.2-Use-pkg-config-for-linking-to-ncurses.patch
new file mode 100644
index 000000000000..0c029c9f0966
--- /dev/null
+++ b/games-roguelike/stone-soup/files/stone-soup-0.16.2-Use-pkg-config-for-linking-to-ncurses.patch
@@ -0,0 +1,49 @@
+From 88579f929f0fc777762de1ad0895264ad077e0ee Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Mon, 27 Oct 2014 20:48:03 +0100
+Subject: [PATCH 2/2] Use pkg-config for linking to ncurses
+
+Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=527034
+---
+ source/Makefile | 14 ++++++--------
+ 1 file changed, 6 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index df51e70..2db2781 100644
+--- a/Makefile
++++ b/Makefile
+@@ -956,17 +956,15 @@ endif
+ # Your ncurses library may include Unicode support, and you may not have a
+ # separate libncursesw; this is the case on Mac OS/Darwin.
+ ifdef LIBNCURSES_IS_UNICODE
+-NC_LIB = ncurses
+-NC_INCLUDE = $(NC_PREFIX)/include/ncurses
++NC_LIBS = $(shell $(PKGCONFIG) --lib ncurses 2>/dev/null || echo "-L$(NC_PREFIX)/lib -lncurses")
++NC_CFLAGS = $(shell $(PKGCONFIG) --cflags ncurses 2>/dev/null || echo "-isystem $(NC_PREFIX)/include/ncurses")
+ else
+-NC_LIB = ncursesw
+-NC_INCLUDE = $(NC_PREFIX)/include/ncursesw
++NC_LIBS = $(shell $(PKGCONFIG) --lib ncursesw || echo "-L$(NC_PREFIX)/lib -lncursesw")
++NC_CFLAGS = $(shell $(PKGCONFIG) --cflags ncursesw 2>/dev/null || echo "-isystem $(NC_PREFIX)/include/ncursesw")
+ endif
+
+-INCLUDES_L += -isystem $(NC_INCLUDE)
+-
+ ifndef TILES
+-LIBS += -L$(NC_PREFIX)/lib -l$(NC_LIB)
++LIBS += $(NC_LIBS)
+ endif
+
+ endif
+@@ -1111,7 +1109,7 @@ CFLAGS := $(CFOPTIMIZE) $(CFOTHERS) $(CFWARN) $(CFLAGS)
+ else
+ CFLAGS := $(CFOPTIMIZE) $(CFOTHERS) $(CFWARN)
+ endif
+-CFLAGS_L := $(CFOPTIMIZE_L) $(DEFINES_L) $(CFWARN_L) $(INCLUDES_L) $(CFOTHERS_L)
++CFLAGS_L := $(CFOPTIMIZE_L) $(DEFINES_L) $(CFWARN_L) $(INCLUDES_L) $(CFOTHERS_L) $(NC_CFLAGS)
+ ALL_CFLAGS := $(CFLAGS) $(CFLAGS_L)
+ YACC_CFLAGS := $(ALL_CFLAGS) -Wno-unused-function -Wno-sign-compare -DYYENABLE_NLS=0 -DYYLTYPE_IS_TRIVIAL=0
+
+--
+2.1.2
+
diff --git a/games-roguelike/stone-soup/files/stone-soup-0.16.2-perl526.patch b/games-roguelike/stone-soup/files/stone-soup-0.16.2-perl526.patch
new file mode 100644
index 000000000000..a450a635153f
--- /dev/null
+++ b/games-roguelike/stone-soup/files/stone-soup-0.16.2-perl526.patch
@@ -0,0 +1,48 @@
+diff -ruN stone_soup-0.16.2.orig/source/util/gather_abilities stone_soup-0.16.2/source/util/gather_abilities
+--- source.orig/util/gather_abilities 2015-08-10 03:32:30.000000000 +0200
++++ source/util/gather_abilities 2017-07-08 20:46:16.112231100 +0200
+@@ -5,7 +5,7 @@
+ $_ = <IN>;
+ close IN;
+
+-s/.*Ability_List\[\] =\n{\n(.*?)};.*/$1/s
++s/.*Ability_List\[\] =\n\{\n(.*?)};.*/$1/s
+ or die "Can't find Ability_List[] in ability.cc\n";
+
+ print join("\n", sort /ABIL_[A-Z0-9_]+\s*,\s*"([*-Za-z0-9 '-]+)"/sg), "\n";
+diff -ruN stone_soup-0.16.2.orig/source/util/gather_cards stone_soup-0.16.2/source/util/gather_cards
+--- source.orig/util/gather_cards 2015-08-10 03:32:30.000000000 +0200
++++ source/util/gather_cards 2017-07-08 20:46:45.113232307 +0200
+@@ -5,7 +5,7 @@
+ $_ = <IN>;
+ close IN;
+
+-s/.*card_name\(card_type card\)\n{\n\s+switch(.*?)\n}\n.*/$1/s
++s/.*card_name\(card_type card\)\n\{\n\s+switch(.*?)\n}\n.*/$1/s
+ or die "Can't find card_name() in decks.cc\n";
+
+ @cards = map { /case CARD_[A-Z_]+:\s+return "([^"]+)";$/ ? ("$1") : () } split /\n/;
+diff -ruN stone_soup-0.16.2.orig/source/util/gather_mons stone_soup-0.16.2/source/util/gather_mons
+--- source.orig/util/gather_mons 2014-07-28 17:19:20.000000000 +0200
++++ source/util/gather_mons 2017-07-08 20:47:10.378233358 +0200
+@@ -99,7 +99,7 @@
+ open IN, "util/cpp_version spl-summoning.cc|" or die "Can't read spl-summoning.cc\n";
+ while (<IN>)
+ {
+- $mons{$1} = 1 if (/^ { MONS_[A-Z0-9_]+, "([A-Za-z0-9 ']+)" },$/);
++ $mons{$1} = 1 if (/^ \{ MONS_[A-Z0-9_]+, "([A-Za-z0-9 ']+)" },$/);
+ }
+ close IN;
+ }
+diff -ruN stone_soup-0.16.2.orig/source/util/gen-mi-enum stone_soup-0.16.2/source/util/gen-mi-enum
+--- source.orig/util/gen-mi-enum 2014-07-28 17:19:20.000000000 +0200
++++ source/util/gen-mi-enum 2017-07-08 20:47:28.491234111 +0200
+@@ -5,7 +5,7 @@
+ $_=<IN>;
+ s/\r//g;
+
+-s/^enum monster_info_flags\n{\n//m && s/^\s*NUM_MB_FLAGS.*//ms
++s/^enum monster_info_flags\n\{\n//m && s/^\s*NUM_MB_FLAGS.*//ms
+ or die "Can't find monster_info_flags in mon-info.h\n";
+ open OUT, ">mi-enum.h" or die "Can't create mi-enum.h\n";
+ print OUT "// Generated by gen-mi-enum, do not edit.\n\n";
diff --git a/games-roguelike/stone-soup/files/stone-soup-0.16.2-respect-flags-and-compiler.patch b/games-roguelike/stone-soup/files/stone-soup-0.16.2-respect-flags-and-compiler.patch
new file mode 100644
index 000000000000..bf07f4e07edf
--- /dev/null
+++ b/games-roguelike/stone-soup/files/stone-soup-0.16.2-respect-flags-and-compiler.patch
@@ -0,0 +1,110 @@
+From aaa7cde91e4b086164f0c7f46569a34bfbb4e479 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Sun, 3 May 2015 15:05:43 +0200
+Subject: [PATCH] Respect flags and compiler
+
+---
+ Makefile | 5 ++---
+ rltiles/Makefile | 22 +++++++++++-----------
+ 2 files changed, 13 insertions(+), 14 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8b9efd9..0f37edf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -103,7 +103,7 @@ include Makefile.obj
+ #
+
+
+-CFOTHERS := -pipe $(EXTERNAL_FLAGS)
++CFOTHERS := $(EXTERNAL_FLAGS)
+ CFWARN :=
+ CFWARN_L := -Wall -Wformat-security -Wundef
+
+@@ -809,7 +809,6 @@ ifdef FULLDEBUG
+ DEFINES += -DFULLDEBUG
+ endif
+ ifdef DEBUG
+-CFOTHERS := -ggdb $(CFOTHERS)
+ DEFINES += -DDEBUG
+ endif
+ ifndef NOWIZARD
+@@ -1627,7 +1626,7 @@ ifdef ANDROID
+ # prove that tiles were generated properly
+ grep tile_info rltiles/*.cc| head
+ else
+- +$(MAKE) -C $(RLTILES) all ARCH=$(ARCH) TILES=$(TILES)$(WEBTILES)
++ $(MAKE) -C $(RLTILES) all V=$(V) ARCH=$(ARCH) DEBUG=$(DEBUG) TILES=$(TILES)$(WEBTILES)
+ endif
+
+ $(TILEDEFSRCS) $(TILEDEFHDRS) $(ORIGTILEFILES): build-rltiles
+diff --git a/rltiles/Makefile b/rltiles/Makefile
+index ae11f43..464424f 100644
+--- a/rltiles/Makefile
++++ b/rltiles/Makefile
+@@ -1,7 +1,7 @@
+ uname_S := $(shell uname -s)
+
+ ifneq (,$(findstring MINGW,$(uname_S)))
+-LDFLAGS += -lmingw32
++LIBS += -lmingw32
+ endif
+
+ # Note: since generation of tiles is done on the host, we don't care about
+@@ -10,7 +10,7 @@ endif
+ # Also, cross-compilation with no system libraries for host rather than target
+ # is not supported. If host=target, contribs are enough.
+
+-CFLAGS := -O2 -g -Wall -Wextra -Wno-parentheses -Wno-unused-parameter
++CXXFLAGS := -Wall -Wextra -Wno-parentheses -Wno-unused-parameter
+
+ ifdef ANDROID
+ CXXFLAGS :=
+@@ -27,24 +27,24 @@ ifdef TILES
+ PNG_LIB := ../contrib/install/$(ARCH)/lib/libpng.a ../contrib/install/$(ARCH)/lib/libz.a
+ endif
+
+- CFLAGS += $(PNG_INCLUDE)
+- LDFLAGS += $(PNG_LIB)
++ CXXFLAGS += $(PNG_INCLUDE)
++ LIBS += $(PNG_LIB)
+
+- CFLAGS += -DUSE_TILE
++ CXXFLAGS += -DUSE_TILE
+ endif
+
+ ifdef DEBUG
+-CFLAGS += -O0 -DDEBUG -ggdb
++CXXFLAGS += -DDEBUG
+ endif
+
+ ifneq (,$(findstring MINGW,$(uname_S)))
+-LDFLAGS += -lgdi32 -lwinmm -lole32 -loleaut32 -limm32 -lshell32 -lversion -luuid
++LIBS += -lgdi32 -lwinmm -lole32 -loleaut32 -limm32 -lshell32 -lversion -luuid
+ endif
+ ifeq ($(uname_S),Darwin)
+ LDFLAGS += -framework AppKit -framework AudioUnit -framework CoreAudio -framework ForceFeedback -framework Carbon -framework IOKit -framework OpenGL
+ endif
+ ifeq ($(uname_S),Linux)
+-LDFLAGS += -ldl -lpthread
++LIBS += -ldl -lpthread
+ endif
+
+ # Attempt to use a full compiler name, to make
+@@ -129,10 +129,10 @@ clean:
+
+ distclean: clean
+
+-%.o: %.cc .cflags
+- $(QUIET_HOSTCXX)$(HOSTCXX) $(CFLAGS) -MMD -c $< -o $@
++%.o: %.cc
++ $(QUIET_HOSTLINK)$(HOSTCXX) $(CXXFLAGS) -c $< -o $@
+
+ $(TILEGEN): $(OBJECTS)
+- $(QUIET_HOSTLINK)$(HOSTCXX) $(OBJECTS) -o $@ $(LDFLAGS)
++ $(QUIET_HOSTLINK)$(HOSTCXX) $(CXXFLAGS) $(OBJECTS) -o $@ $(LDFLAGS) $(LIBS)
+
+ .PHONY: all clean distclean
+--
+2.3.5
+