summaryrefslogtreecommitdiff
path: root/games-roguelike/scourge/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-roguelike/scourge/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-roguelike/scourge/files')
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch11
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch34
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch12
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-gcc6.patch34
4 files changed, 91 insertions, 0 deletions
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch b/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch
new file mode 100644
index 000000000000..5c2bc202f384
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -4,7 +4,7 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(src/scourge.h)
+ AM_INIT_AUTOMAKE(scourge, "0.21")
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ dnl internationalization macros
+ AC_GNU_SOURCE
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch b/games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..d41ee1a44439
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-freetype_pkgconfig.patch
@@ -0,0 +1,34 @@
+Index: scourge/configure.in
+===================================================================
+--- scourge/configure.in (revision 3411)
++++ scourge/configure.in (working copy)
+@@ -56,6 +56,7 @@
+ # Set up binreloc (for a relocatable autopackage file)
+ AM_BINRELOC
+
++PKG_PROG_PKG_CONFIG
+ dnl --------------------------------------------------------------------------
+ dnl General options
+ dnl --------------------------------------------------------------------------
+@@ -413,19 +414,9 @@
+ FREETYPE_LIBS=`/sw/lib/freetype2/bin/freetype-config --libs`
+ have_FREETYPE=yes
+ else
+-AC_MSG_CHECKING([for freetype-config library])
+-
+-AC_PATH_PROG(FREETYPE, freetype-config, no)
+-
+-if test "$FREETYPE" = "no"; then
+- AC_MSG_ERROR(Cannot find freetype2: Is freetype-config in path?)
+- have_FREETYPE=no
+-else
+- FREETYPE_CFLAGS=`freetype-config --cflags`
+- FREETYPE_LIBS=`freetype-config --libs`
+- have_FREETYPE=yes
++ PKG_CHECK_MODULES(FREETYPE, freetype2, have_FREETYPE=yes,
++ AC_MSG_ERROR(Cannot find freetype2))
+ fi
+-fi
+
+ LIBS="$saved_LIBS"
+ TR_LIBS="$TR_LIBS $FREETYPE_LIBS"
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch b/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch
new file mode 100644
index 000000000000..6f3f7b3e2a65
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch
@@ -0,0 +1,12 @@
+--- a/src/squirrel/squtils.h 2012-08-30 18:06:43.474037926 +0200
++++ b/src/squirrel/squtils.h 2012-08-30 18:14:13.300261523 +0200
+@@ -8,6 +8,9 @@
+ #define SQ_FREE(__ptr,__size) sq_vm_free(__ptr,__size);
+ #define SQ_REALLOC(__ptr,__oldsize,__size) sq_vm_realloc(__ptr,__oldsize,__size);
+
++void *sq_vm_realloc(void *p,SQUnsignedInteger oldsize,SQUnsignedInteger size);
++void sq_vm_free(void *p,SQUnsignedInteger size);
++
+ //sqvector mini vector class, supports objects by value
+ template<typename T> class sqvector
+ {
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-gcc6.patch b/games-roguelike/scourge/files/scourge-0.21.1-gcc6.patch
new file mode 100644
index 000000000000..fed15f45ed7e
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-gcc6.patch
@@ -0,0 +1,34 @@
+Bug: https://bugs.gentoo.org/610492
+Upstream ticket: https://sourceforge.net/p/scourge/patches/3/
+
+--- a/src/equip.cpp
++++ b/src/equip.cpp
+@@ -595,7 +595,7 @@
+ }
+ }
+ if ( !found ) {
+- specialSkill = false;
++ specialSkill = NULL;
+ canvas->setTooltip( "" );
+ }
+ glDisable( GL_BLEND );
+--- a/src/render/map.cpp
++++ b/src/render/map.cpp
+@@ -3154,7 +3154,7 @@
+ if ( shape )
+ return shape;
+ }
+- return false;
++ return NULL;
+ }
+ if ( y1 == y2 ) {
+ if ( x1 > x2 ) SWAP( x1, x2 );
+@@ -3163,7 +3163,7 @@
+ if ( shape )
+ return shape;
+ }
+- return false;
++ return NULL;
+ }
+
+