summaryrefslogtreecommitdiff
path: root/games-roguelike/moria/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /games-roguelike/moria/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'games-roguelike/moria/files')
-rw-r--r--games-roguelike/moria/files/moria-5.7.10-tinfo.patch24
-rw-r--r--games-roguelike/moria/files/moria-5.7.12-gentoo-paths.patch (renamed from games-roguelike/moria/files/moria-5.7.10-gentoo-paths.patch)8
2 files changed, 4 insertions, 28 deletions
diff --git a/games-roguelike/moria/files/moria-5.7.10-tinfo.patch b/games-roguelike/moria/files/moria-5.7.10-tinfo.patch
deleted file mode 100644
index 5173a7d00f4e..000000000000
--- a/games-roguelike/moria/files/moria-5.7.10-tinfo.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From aa3ebbd2eb4b4a6ab92833060c212255d90c68b4 Mon Sep 17 00:00:00 2001
-From: Stefan Strogin <stefan.strogin@gmail.com>
-Date: Mon, 11 Feb 2019 01:53:10 +0200
-Subject: [PATCH] Find NCurses library on Linux/Mac
-
----
- CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 372d838..f39ebcd 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -261,6 +261,7 @@ elseif ((MSYS OR MINGW) AND NOT "$ENV{MINGW}" STREQUAL "")
- set(CURSES_LIBRARIES "/$ENV{MINGW}/lib/libncurses.a")
- else ()
- message(STATUS "NOTE: Configuring build for macOS/Linux release...")
-+ set(CURSES_NEED_NCURSES TRUE)
- find_package(Curses REQUIRED)
- endif ()
-
---
-2.20.1
-
diff --git a/games-roguelike/moria/files/moria-5.7.10-gentoo-paths.patch b/games-roguelike/moria/files/moria-5.7.12-gentoo-paths.patch
index 0d17c549e773..a5ae834413d7 100644
--- a/games-roguelike/moria/files/moria-5.7.10-gentoo-paths.patch
+++ b/games-roguelike/moria/files/moria-5.7.12-gentoo-paths.patch
@@ -1,8 +1,8 @@
diff --git a/src/config.cpp b/src/config.cpp
-index 09528f7..1c299ed 100644
+index 36f565b..bfe1b18 100644
--- a/src/config.cpp
+++ b/src/config.cpp
-@@ -12,17 +12,17 @@ namespace config {
+@@ -13,17 +13,17 @@ namespace config {
// Data files used by Umoria
// NOTE: use relative paths to the executable binary.
namespace files {
@@ -19,7 +19,7 @@ index 09528f7..1c299ed 100644
- const std::string scores = "scores.dat";
+ const std::string splash_screen = "/usr/share/moria/splash.txt";
+ const std::string welcome_screen = "/usr/share/moria/welcome.txt";
-+ const std::string license = "/usr/share/doc/@PF@/LICENSE";
++ const std::string license = "/usr/portage/licenses/GPL-2";
+ const std::string versions_history = "/usr/share/moria/versions.txt";
+ const std::string help = "/usr/share/moria/help.txt";
+ const std::string help_wizard = "/usr/share/moria/help_wizard.txt";
@@ -29,5 +29,5 @@ index 09528f7..1c299ed 100644
+ const std::string death_royal = "/usr/share/moria/death_royal.txt";
+ const std::string scores = "/var/lib/moria/scores.dat";
std::string save_game = "game.sav";
- }
+ } // namespace files