summaryrefslogtreecommitdiff
path: root/games-roguelike/mazesofmonad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-roguelike/mazesofmonad
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-roguelike/mazesofmonad')
-rw-r--r--games-roguelike/mazesofmonad/Manifest4
-rw-r--r--games-roguelike/mazesofmonad/files/mazesofmonad-1.0.9-time-1.5.patch22
-rw-r--r--games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild37
-rw-r--r--games-roguelike/mazesofmonad/metadata.xml25
4 files changed, 88 insertions, 0 deletions
diff --git a/games-roguelike/mazesofmonad/Manifest b/games-roguelike/mazesofmonad/Manifest
new file mode 100644
index 000000000000..79e4723cb414
--- /dev/null
+++ b/games-roguelike/mazesofmonad/Manifest
@@ -0,0 +1,4 @@
+AUX mazesofmonad-1.0.9-time-1.5.patch 968 BLAKE2B 936e9539cd25ff08670c21032320d7eebff85a3aab76bb6774a66363770f5582cd627072d467043adea485a39e139d8bcb6cc7b30e65b62118227866f7d1d5ac SHA512 e93813f3cfd1966fc6ac20d8d651242c0ae3b881ea339de07ebb815db5f7d32f7ca5263c72d68fe2281997abc1a77893a26882e75bed09dd9e3a4a64d012116f
+DIST MazesOfMonad-1.0.9.tar.gz 56342 BLAKE2B 93e2466d76804538b87b601af39916e8c39a853d11added65dc5b3408dcb19b75e50edbb3bc484de1cb6ef01de46814cd95886738025c31d271c5c2d81b80e00 SHA512 a537672907f0bf356574b5c16b9b354cc73133958873e3dfc064f9de2ad7c18bed011f811887edc37c9b40de5529f7954889953946a79da29a255637e81d9612
+EBUILD mazesofmonad-1.0.9-r3.ebuild 822 BLAKE2B 3a4b7eca0fbca1ed23151c008f412d175202755d6045f8711f50d2dd113c91c9a09e6eaa7b099897edf014b0d51e90fd299d18cdea99cab3517b79abd8321ec6 SHA512 3fa0ed0b1a089c86215e956ad305dbd72b8167de81aa79edf79829b68090fcbc87188533c1d87a81127c2545fe3e8ef1ca9da95d07694870ea63cbb3c146ffba
+MISC metadata.xml 971 BLAKE2B 05b96c3bf5c2ac7c39e93b35cb7dd7c949bfcd4ba550100ca6e2d4cf084506c538f595e03a9b427a4a0f006cd0cdeeaf923d2a874036ee741220af26c9a3ba22 SHA512 fc715d7961b2b6421e8dba76a8f81a2f0ce814fdcf9eaae45c5c4a6509e253193f440924c56786f8e291cebaf1bfd5d3dbb6675f0d016c14ea17b97beec12eab
diff --git a/games-roguelike/mazesofmonad/files/mazesofmonad-1.0.9-time-1.5.patch b/games-roguelike/mazesofmonad/files/mazesofmonad-1.0.9-time-1.5.patch
new file mode 100644
index 000000000000..11ef34ef45f9
--- /dev/null
+++ b/games-roguelike/mazesofmonad/files/mazesofmonad-1.0.9-time-1.5.patch
@@ -0,0 +1,22 @@
+diff --git a/MazesOfMonad.cabal b/MazesOfMonad.cabal
+index db5e5bf..c3b427b 100644
+--- a/MazesOfMonad.cabal
++++ b/MazesOfMonad.cabal
+@@ -34,3 +34,3 @@ Executable mazesofmonad
+ regex-posix, containers, filepath, directory, pretty,
+- array, mtl, old-locale, time
++ array, mtl, old-locale, time, time-locale-compat
+
+diff --git a/src/MoresmauJP/Rpg/Save.hs b/src/MoresmauJP/Rpg/Save.hs
+index 12965b7..238b9b9 100644
+--- a/src/MoresmauJP/Rpg/Save.hs
++++ b/src/MoresmauJP/Rpg/Save.hs
+@@ -10,2 +10,3 @@ import Data.Maybe
+ import Data.Time
++import qualified Data.Time.Locale.Compat as DTLC
+
+@@ -112,3 +113,3 @@ listGames rs name= do
+ if isJust $ bckGame bs
+- then return $ Just (dropExtension x,formatTime defaultTimeLocale (iso8601DateFormat $ Just "%R") $ bckDate bs)
++ then return $ Just (dropExtension x,formatTime DTLC.defaultTimeLocale (DTLC.iso8601DateFormat $ Just "%R") $ bckDate bs)
+ else return Nothing
diff --git a/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild b/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild
new file mode 100644
index 000000000000..b2576b4387b0
--- /dev/null
+++ b/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+CABAL_FEATURES="bin"
+inherit eutils haskell-cabal
+
+MY_PN=MazesOfMonad
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Console-based roguelike Role Playing Game similar to nethack"
+HOMEPAGE="https://github.com/JPMoresmau/MazesOfMonad
+ http://hackage.haskell.org/package/MazesOfMonad"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/gmp-5:0=
+ virtual/libffi:="
+DEPEND="${RDEPEND}
+ >=dev-lang/ghc-7.4.1
+ >=dev-haskell/cabal-1.6
+ dev-haskell/hunit
+ dev-haskell/mtl
+ dev-haskell/random
+ dev-haskell/regex-posix
+ dev-haskell/time-locale-compat
+"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9-time-1.5.patch
+)
diff --git a/games-roguelike/mazesofmonad/metadata.xml b/games-roguelike/mazesofmonad/metadata.xml
new file mode 100644
index 000000000000..c264aaf1de4f
--- /dev/null
+++ b/games-roguelike/mazesofmonad/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ MazesOfMonad is a console-based Role Playing Game. You create
+ characters with their strong and weak points, and try to complete
+ mazes that are randomly generated. You can pick up gold and items
+ on the way, meet monsters, and deal with them as you want. You can
+ fight, use magic, bribe, trade, steal... This is only a simple game
+ that I did to see what building a full blown Haskell application
+ is like to develop. Versions 1.0.5 and above are complete
+ and working.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">JPMoresmau/MazesOfMonad</remote-id>
+ </upstream>
+</pkgmetadata>