summaryrefslogtreecommitdiff
path: root/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild')
-rw-r--r--games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild b/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild
new file mode 100644
index 000000000000..b2576b4387b0
--- /dev/null
+++ b/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+CABAL_FEATURES="bin"
+inherit eutils haskell-cabal
+
+MY_PN=MazesOfMonad
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Console-based roguelike Role Playing Game similar to nethack"
+HOMEPAGE="https://github.com/JPMoresmau/MazesOfMonad
+ http://hackage.haskell.org/package/MazesOfMonad"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/gmp-5:0=
+ virtual/libffi:="
+DEPEND="${RDEPEND}
+ >=dev-lang/ghc-7.4.1
+ >=dev-haskell/cabal-1.6
+ dev-haskell/hunit
+ dev-haskell/mtl
+ dev-haskell/random
+ dev-haskell/regex-posix
+ dev-haskell/time-locale-compat
+"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9-time-1.5.patch
+)