summaryrefslogtreecommitdiff
path: root/games-roguelike/hengband/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-roguelike/hengband/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-roguelike/hengband/files')
-rw-r--r--games-roguelike/hengband/files/hengband-1.6.2-autoconf-ncurses.patch26
-rw-r--r--games-roguelike/hengband/files/hengband-1.6.2-ovflfix.patch8
2 files changed, 31 insertions, 3 deletions
diff --git a/games-roguelike/hengband/files/hengband-1.6.2-autoconf-ncurses.patch b/games-roguelike/hengband/files/hengband-1.6.2-autoconf-ncurses.patch
new file mode 100644
index 000000000000..3fabd8e1891e
--- /dev/null
+++ b/games-roguelike/hengband/files/hengband-1.6.2-autoconf-ncurses.patch
@@ -0,0 +1,26 @@
+diff --git a/configure.in b/configure.in
+index 0df0e76..d8ea587 100644
+--- a/configure.in
++++ b/configure.in
+@@ -56,13 +56,14 @@ fi
+
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -lncurses:
+-AC_CHECK_LIB(ncurses, initscr, [AC_DEFINE(USE_GCU, 1, [Allow -mGCU environment]) AC_DEFINE(USE_NCURSES, 1, [Use ncurses]) LIBS="$LIBS -lncurses"])
+-if test "$ac_cv_lib_ncurses_initscr" != yes; then
+- AC_CHECK_LIB(curses, initscr, [AC_DEFINE(USE_GCU, 1, [Allow -mGCU environment]) LIBS="$LIBS -lcurses"])
+- if test "$ac_cv_lib_curses_initscr" != yes; then
+- AC_CHECK_LIB(termcap, tgetent, [AC_DEFINE(USE_CAP, 1, [Allow -mCAP environment]) LIBS="$LIBS -ltermcap"])
+- fi
+-fi
++PKG_CHECK_MODULES(
++ [NCURSES],
++ [ncurses],
++ [AC_DEFINE(USE_GCU, 1, [Allow -mGCU environment])
++ AC_DEFINE(USE_NCURSES, 1, [Use ncurses])
++ [LIBS="${LIBS} ${NCURSES_LIBS}"]
++ ]
++)
+
+ dnl Checks for header files.
+ AC_PATH_XTRA
diff --git a/games-roguelike/hengband/files/hengband-1.6.2-ovflfix.patch b/games-roguelike/hengband/files/hengband-1.6.2-ovflfix.patch
index 47bb53cf771a..ec8e1273893f 100644
--- a/games-roguelike/hengband/files/hengband-1.6.2-ovflfix.patch
+++ b/games-roguelike/hengband/files/hengband-1.6.2-ovflfix.patch
@@ -1,6 +1,8 @@
---- src/effects.c.old 2010-10-28 11:51:31.000000000 +0200
-+++ src/effects.c 2010-10-28 11:51:59.000000000 +0200
-@@ -5191,7 +5191,7 @@
+diff --git a/src/effects.c b/src/effects.c
+index a97a2ec..3988b04 100644
+--- a/src/effects.c
++++ b/src/effects.c
+@@ -5191,7 +5191,7 @@ int take_hit(int damage_type, int damage, cptr hit_from, int monspell)
}
else
{