summaryrefslogtreecommitdiff
path: root/games-puzzle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /games-puzzle
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/Manifest.gzbin17297 -> 17299 bytes
-rw-r--r--games-puzzle/freesweep/Manifest2
-rw-r--r--games-puzzle/freesweep/freesweep-1.0.2-r1.ebuild (renamed from games-puzzle/freesweep/freesweep-1.0.2.ebuild)12
-rw-r--r--games-puzzle/xblockout/Manifest3
-rw-r--r--games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch19
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.6-r3.ebuild (renamed from games-puzzle/xblockout/xblockout-1.1.6-r2.ebuild)8
-rw-r--r--games-puzzle/xwelltris/Manifest4
-rw-r--r--games-puzzle/xwelltris/files/xwelltris-1.0.1-c++17.patch106
-rw-r--r--games-puzzle/xwelltris/files/xwelltris-1.0.1-configure-autoconf-2.72.patch106
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1-r2.ebuild (renamed from games-puzzle/xwelltris/xwelltris-1.0.1-r1.ebuild)11
10 files changed, 259 insertions, 12 deletions
diff --git a/games-puzzle/Manifest.gz b/games-puzzle/Manifest.gz
index 4abcd9411790..6dfcc570303a 100644
--- a/games-puzzle/Manifest.gz
+++ b/games-puzzle/Manifest.gz
Binary files differ
diff --git a/games-puzzle/freesweep/Manifest b/games-puzzle/freesweep/Manifest
index 7f51b69e4a8b..c127cf9afe84 100644
--- a/games-puzzle/freesweep/Manifest
+++ b/games-puzzle/freesweep/Manifest
@@ -1,3 +1,3 @@
DIST freesweep-1.0.2.tar.gz 93986 BLAKE2B 306c0e87448534c23c7754f9bedbaf9d72ee705bfdb3cc08a004076bd56a117f4bbb19f4676282edccc57286b5135d6714d6ad2e94a903235c8f4bb9a305ad77 SHA512 1695bb29efbaed5e6baf5faadcbd685e8e6b4ccb5d52567a833b5f5eeb69200fc220579fea7d6907bffc92a06e9b220bca494e8597394820a421f81f0af1d3aa
-EBUILD freesweep-1.0.2.ebuild 594 BLAKE2B 82eb1012fe39bb870aa1019d9a499740eb69443f3e4f62e1bd2c3cf963ea2e6f9d329426e8479b19ee50c6daafb9b069f752a0006c9b05e4c8531904be385543 SHA512 9d337152160815f391343763391d0aaa0a19eb71d3f51b873c75ef6763cfa9756d46add5e2900540efcede45d35eef35cea85e7f90f633a1831c28d03e7ff97c
+EBUILD freesweep-1.0.2-r1.ebuild 732 BLAKE2B 09d2039b1fa4329e8d700b55341d709fbf53da457a792571d563eb4ef3768a63405dd049c0fde73ef56eb7bf2880cb950b9f024a7509c5a9025618d3dca208c0 SHA512 5e8c2384c15aafefd2fe50c0d767a63b97d83dabd925db769294e4c7f858445a69469382a801bce911d1e6e5896e4a4ae168aab69e71749485e9c41dd8bda016
MISC metadata.xml 338 BLAKE2B a77722d450cf98aefc1863f0ae843136c7d0846947422884bbe565033566bd17fecdbe67fde708c624a3989c2082e9b07797d3ddf87c4ad01c579ba896d970cb SHA512 5cf55926ac66e6476db9ffde0ca7370f11348bd3785913794c2226706e42de3e045a8d33b39f68598f47b4e9f59885751dced131e9389c12a0db16908eb8bf38
diff --git a/games-puzzle/freesweep/freesweep-1.0.2.ebuild b/games-puzzle/freesweep/freesweep-1.0.2-r1.ebuild
index abe5e0cb0e2b..b2a002295f08 100644
--- a/games-puzzle/freesweep/freesweep-1.0.2.ebuild
+++ b/games-puzzle/freesweep/freesweep-1.0.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Console Minesweeper"
HOMEPAGE="https://github.com/rwestlund/freesweep"
@@ -17,6 +17,14 @@ RDEPEND="sys-libs/ncurses:="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+src_prepare() {
+ default
+
+ sed -i -e "s:configure.in:configure.ac:" Makefile.in || die
+ # Clang 16, bug #899002
+ eautoreconf
+}
+
src_compile() {
emake LIBS="$($(tc-getPKG_CONFIG) --libs ncurses || die)"
}
diff --git a/games-puzzle/xblockout/Manifest b/games-puzzle/xblockout/Manifest
index a70d2e41558e..55782453e72a 100644
--- a/games-puzzle/xblockout/Manifest
+++ b/games-puzzle/xblockout/Manifest
@@ -1,4 +1,5 @@
+AUX xblockout-1.1.6-configure-clang16.patch 465 BLAKE2B 8f1ed90b83dd9ec1d5e558f4a10987dce5eb574607b5d3c13d7d27f100db434f5e1d581cc31fd790342f3beeb8815c8e14772af0a6ac4f9b2d183893bd23c750 SHA512 37b811669fc5cc15fd2434c06180b5908a71ec1ef3523302fde25e50dfc5ca8b7716324055ba8fa53ba122ceccb2c32915968574575e493a3ef50c9f0c0fc285
AUX xblockout-1.1.6-font.patch 1535 BLAKE2B 5ae0fffb0d04c69123bb0c1098bcbaf2053551530d9f7f6f001ae693d4826148d16f4793009c83b286a7c9df8669e507145e39f2c7aa6bf4638ddc1e97bab15b SHA512 f74245e8d97859fa692c82f69657a77d31e84f249b5d29e23b16f072d596e85a51800f4af4578ba194151a6d0c5b577bad7a40a95d0477f31d2ae8147bec585d
DIST xbl-1.1.6.tar.gz 136504 BLAKE2B 253c4a950def66abaef3547596b569542ea0dcd180fa5e81a7cb581d9dc23b2038b39c1059ddd36cfc89275ef3fb2a25d174ada71ab1818e408818613559a33e SHA512 96bf0460863698136a61b43260feed0e90e7ca5b6613d54c8ca98f51557a3d235597eeab46141cd6771aa0bf4fe019c5e4291dd826338e186cc905e3837531e0
-EBUILD xblockout-1.1.6-r2.ebuild 1306 BLAKE2B 9ab7a3c65fca5b98d06b8db03e2ab2d957e3253de6a0e916782eb94d808b4e4a778aef4250ee93b3900456fecdf421f872a96fd8fb0d2897d7a663e6e41ba2f9 SHA512 43b4d8c77cfa59d6af9b811b256d931d87adcf9628e1ca01f088cc9fd797e53d173c191f33a06286baab360bbd3792a1ef644ab3cf28dcd1de44de0860f1bf44
+EBUILD xblockout-1.1.6-r3.ebuild 1349 BLAKE2B b6008030de4f480e08f227bc21b06193454a601b6ce3c8ddd1cad6aa2e9798b4d56c148b4328833a0fe122cd9b3b1f5e8643a3551bea283ab4e95ea431d2740f SHA512 041ac373b5b12c3794051a2feeb20ef0b0f674e2879b06858a54193c32acda156b87ece176358489df442825378fc5e65cf9b0c9eaab2fa8850b206756703b2f
MISC metadata.xml 250 BLAKE2B 8d44bd4c6e7d6491273e2015e36ddac74af7b94a124fd240ff030e16430f5c85e53ab812f0e3e94bb2e6d138f39b512bbe01ff98b0081cacc21a02d648ec7643 SHA512 80ac07a3cac10ad2e72e9989a130b7d2073934fe92914a9db2af4d0e769d4bf537770f8faba0654bbd64a7e85ee38cf1f9d03b4b9cd322864b1b2bb35087d610
diff --git a/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch b/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch
new file mode 100644
index 000000000000..af322fedd337
--- /dev/null
+++ b/games-puzzle/xblockout/files/xblockout-1.1.6-configure-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/899012
+--- a/configure.in
++++ b/configure.in
+@@ -127,6 +127,7 @@ dnl AC_TRY_COMPILE("Prototypes",,extern int y(int z);y(5);}y(z)int z;{,CFLA="$CF
+
+ AC_TEST_PROGRAM([
+ #include <sys/time.h>
++#include <time.h>
+ int main()
+ {
+ fd_set i,j,k ;
+@@ -151,6 +152,7 @@ AC_TEST_PROGRAM([
+ #include <signal.h>
+ #include <stdio.h>
+ #include <sys/time.h>
++#include <unistd.h>
+
+ volatile int c = 0 ;
+ void fct(i) int i ; { c++ ; signal(SIGALRM, fct) ; }
diff --git a/games-puzzle/xblockout/xblockout-1.1.6-r2.ebuild b/games-puzzle/xblockout/xblockout-1.1.6-r3.ebuild
index 914ab6d1ac1c..f433fd8aaccd 100644
--- a/games-puzzle/xblockout/xblockout-1.1.6-r2.ebuild
+++ b/games-puzzle/xblockout/xblockout-1.1.6-r3.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools desktop flag-o-matic toolchain-funcs
DESCRIPTION="X Window block dropping game in 3 Dimension"
HOMEPAGE="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/"
SRC_URI="http://perso.univ-lyon1.fr/thierry.excoffier/XBL/xbl-${PV}.tar.gz"
+S="${WORKDIR}/xbl-${PV}"
LICENSE="GPL-1"
SLOT="0"
@@ -19,10 +20,9 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/xbl-${PV}"
-
PATCHES=(
"${FILESDIR}"/${P}-font.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
)
src_prepare() {
diff --git a/games-puzzle/xwelltris/Manifest b/games-puzzle/xwelltris/Manifest
index cb37ef85d737..f9673f20f206 100644
--- a/games-puzzle/xwelltris/Manifest
+++ b/games-puzzle/xwelltris/Manifest
@@ -1,5 +1,7 @@
+AUX xwelltris-1.0.1-c++17.patch 4539 BLAKE2B ee72d6780104be6397646168b67dee6cc22ea70c9d502c83ad7d638a6e5a2068753ddf77c5dc52bf9a22196ae3c14db04e5a2d5c5bcd758ffa5ccbec625ff560 SHA512 2606178327a5d596ae908b4651ec0e1560a34ca7460cb7f77cab4facb53e10008abeb70ac2f33d1878736d19781efdf5df4052e7ccbbcc3d241b2033633602e5
+AUX xwelltris-1.0.1-configure-autoconf-2.72.patch 2509 BLAKE2B a690b29d1d15987bff53eff700ff5892b610bb2b9da7f17b19ce6e5d4b90611a3994ce053566756e7d96fd831f53d8c88aa9485203c103282ac5bc94ddcf6afd SHA512 96fc7aa38eba37420513cb49cccc15f47710ac9741f8ef89acf77705677c1be75adf8151e4ea283d9fffacadb66f5fec9b18a6d08d0b12be43bd1aaf23c18b4a
AUX xwelltris-1.0.1-gcc-11.patch 317 BLAKE2B d8de25ff359ab2dbf15f953b1689df4f056e4ef4991da1e98935ca1c51d7c46ea3321827702eb0b92c595cfed85c52c156d23c9d700e51f03c681b50f6c25b1e SHA512 3afd9b2f5c6bd684a4392d72a9a482b0bde6ff86a4027cc749aaf452add5d2ff59a242c39d198c0e0625f90d0d14c4b6d319f397b7f7b65742b3320cc8712250
AUX xwelltris-1.0.1-scorefile-dir.patch 615 BLAKE2B 77dd21fa7650bb2d940422aebf80bd9c82188c577bf7a498e7537b88218dbbfae3be8309588798b03e7590a002a317a8171202b9b0aa411421160d776109a7c1 SHA512 3bc2e6ef0b44ead08103441e9e4e13263b108986461d263a30fc0125b25d687e74e7e49d3610fc2207a370125aaf79c839e41584e97e989b2e6dceb1478a4919
DIST xwelltris-1.0.1.src.tar.gz 422822 BLAKE2B c6eda0d294e79c5715bcaa593776ecfb0cdc734386fc4e9a6825dd090340c2744a251ad1e753421865151928608e4aebdd5050b0091a0799b7d1da5a0b3bdd60 SHA512 6b1080c6e6d1b579c441d1f42bb6454dafed62a63790d5798e83cf137db7ff2ddc07db7e89b34402a5249770697cc3f8ad5e6222266142c7b43f6936828f2536
-EBUILD xwelltris-1.0.1-r1.ebuild 1513 BLAKE2B d03090d50bb7244ac69e16130ba6969c2effc15c41f58c59e3ffcff1641215b14a98496a733e721ae507b5f14ab4588beed33e079cce0463149253cf01a3a707 SHA512 5174af72f10786b2e072e90c936bd4bcd7838fba0b9e190e10ec95023100f998492b904622055e2313311eb46182c0b0ae7bdc76add0a5a2ca9bf8acd66d4858
+EBUILD xwelltris-1.0.1-r2.ebuild 1693 BLAKE2B a077084f16ac9fb5e15b05aea5a8b1c635a7a72a7aed183b1de87bd64737ca7e17a25af58ba2ae6a60253a7584695238ea8f726c1258badac36fd58cd000e6ed SHA512 eaad67fcd9482f1479fe3c214b9e22c08dda31b1a6d68bd889d264db6b4e2a48f7cf814ad0a6dcc8235de1f978c6ca4415150640da5108cbb4fbafe7251bc0af
MISC metadata.xml 250 BLAKE2B 8d44bd4c6e7d6491273e2015e36ddac74af7b94a124fd240ff030e16430f5c85e53ab812f0e3e94bb2e6d138f39b512bbe01ff98b0081cacc21a02d648ec7643 SHA512 80ac07a3cac10ad2e72e9989a130b7d2073934fe92914a9db2af4d0e769d4bf537770f8faba0654bbd64a7e85ee38cf1f9d03b4b9cd322864b1b2bb35087d610
diff --git a/games-puzzle/xwelltris/files/xwelltris-1.0.1-c++17.patch b/games-puzzle/xwelltris/files/xwelltris-1.0.1-c++17.patch
new file mode 100644
index 000000000000..2c62d4752975
--- /dev/null
+++ b/games-puzzle/xwelltris/files/xwelltris-1.0.1-c++17.patch
@@ -0,0 +1,106 @@
+--- a/src/image/convert.cxx
++++ b/src/image/convert.cxx
+@@ -273,9 +273,9 @@ static void slow_fill_histogram (byte* pic24,int numpixels)
+
+ static boxptr find_biggest_color_pop (boxptr boxlist, int numboxes)
+ {
+- register boxptr boxp;
+- register int i;
+- register long maxc = 0;
++ boxptr boxp;
++ int i;
++ long maxc = 0;
+ boxptr which = NULL;
+
+ for (i = 0, boxp = boxlist; i < numboxes; i++, boxp++) {
+@@ -290,9 +290,9 @@ static boxptr find_biggest_color_pop (boxptr boxlist, int numboxes)
+
+ static boxptr find_biggest_volume (boxptr boxlist, int numboxes)
+ {
+- register boxptr boxp;
+- register int i;
+- register INT32 maxv = 0;
++ boxptr boxp;
++ int i;
++ INT32 maxv = 0;
+ boxptr which = NULL;
+
+ for (i = 0, boxp = boxlist; i < numboxes; i++, boxp++) {
+@@ -407,7 +407,7 @@ static int median_cut (boxptr boxlist, int numboxes, int desired_colors)
+ {
+ int n,lb;
+ int c0,c1,c2,cmax;
+- register boxptr b1,b2;
++ boxptr b1,b2;
+
+ while (numboxes < desired_colors) {
+ /* Select box to split.
+@@ -642,12 +642,12 @@ static void find_best_colors (int minc0,int minc1,int minc2,int numcolors,
+ {
+ int ic0, ic1, ic2;
+ int i, icolor;
+- register INT32 * bptr; /* pointer into bestdist[] array */
++ INT32 * bptr; /* pointer into bestdist[] array */
+ JSAMPLE * cptr; /* pointer into bestcolor[] array */
+ INT32 dist0, dist1; /* initial distance values */
+- register INT32 dist2; /* current distance in inner loop */
++ INT32 dist2; /* current distance in inner loop */
+ INT32 xx0, xx1; /* distance increments */
+- register INT32 xx2;
++ INT32 xx2;
+ INT32 inc0, inc1, inc2; /* initial values for increments */
+ /* This array holds the distance to the nearest-so-far color for each cell */
+ INT32 bestdist[BOX_C0_ELEMS * BOX_C1_ELEMS * BOX_C2_ELEMS];
+@@ -710,8 +710,8 @@ static void fill_inverse_cmap (int c0, int c1, int c2)
+ hist2d * histogram = sl_histogram;
+ int minc0, minc1, minc2; /* lower left corner of update box */
+ int ic0, ic1, ic2;
+- register JSAMPLE * cptr; /* pointer into bestcolor[] array */
+- register histptr cachep; /* pointer into main cache array */
++ JSAMPLE * cptr; /* pointer into bestcolor[] array */
++ histptr cachep; /* pointer into main cache array */
+ /* This array lists the candidate colormap indexes. */
+ JSAMPLE colorlist[MAXNUMCOLORS];
+ int numcolors; /* number of candidate colors */
+@@ -749,10 +749,10 @@ static void fill_inverse_cmap (int c0, int c1, int c2)
+
+ static void slow_map_pixels (byte *pic24,int width,int height, byte* pic8)
+ {
+- register LOCFSERROR cur0, cur1, cur2; /* current error or pixel value */
++ LOCFSERROR cur0, cur1, cur2; /* current error or pixel value */
+ LOCFSERROR belowerr0, belowerr1, belowerr2; /* error for pixel below cur */
+ LOCFSERROR bpreverr0, bpreverr1, bpreverr2; /* error for below/prev col */
+- register FSERRPTR errorptr; /* => fserrors[] at column before current */
++ FSERRPTR errorptr; /* => fserrors[] at column before current */
+ JSAMPROW inptr; /* => current input pixel */
+ JSAMPROW outptr; /* => current output pixel */
+ histptr cachep;
+@@ -814,7 +814,7 @@ static void slow_map_pixels (byte *pic24,int width,int height, byte* pic8)
+ if (*cachep == 0)
+ fill_inverse_cmap(cur0>>C0_SHIFT, cur1>>C1_SHIFT, cur2>>C2_SHIFT);
+ /* Now emit the colormap index for this cell */
+- { register int pixcode = *cachep - 1;
++ { int pixcode = *cachep - 1;
+ *outptr = (JSAMPLE) pixcode;
+ /* Compute representation error for this pixel */
+ cur0 -= (int) colormap0[pixcode];
+@@ -825,7 +825,7 @@ static void slow_map_pixels (byte *pic24,int width,int height, byte* pic8)
+ * Add these into the running sums, and simultaneously shift the
+ * next-line error sums left by 1 column.
+ */
+- { register LOCFSERROR bnexterr, delta;
++ { LOCFSERROR bnexterr, delta;
+
+ bnexterr = cur0; /* Process component 0 */
+ delta = cur0 * 2;
+--- a/src/image/sublib/IMG_gif.c
++++ b/src/image/sublib/IMG_gif.c
+@@ -406,7 +406,7 @@ LWZReadByte(SDL_RWops *src, int flag, int input_code_size)
+ static int clear_code, end_code;
+ static int table[2][(1 << MAX_LWZ_BITS)];
+ static int stack[(1 << (MAX_LWZ_BITS)) * 2], *sp;
+- register int i;
++ int i;
+
+ if (flag) {
+ set_code_size = input_code_size;
diff --git a/games-puzzle/xwelltris/files/xwelltris-1.0.1-configure-autoconf-2.72.patch b/games-puzzle/xwelltris/files/xwelltris-1.0.1-configure-autoconf-2.72.patch
new file mode 100644
index 000000000000..bfcfd9ddd3c3
--- /dev/null
+++ b/games-puzzle/xwelltris/files/xwelltris-1.0.1-configure-autoconf-2.72.patch
@@ -0,0 +1,106 @@
+Drop incorrectly quoted chunks which aren't relevant for remotely modern
+systems. Breaks with autoconf-2.72/9999.
+--- a/configure.in
++++ b/configure.in
+@@ -48,24 +48,6 @@ dnl On SCO Unix, there are ELF and COFF binaries. We want elf to
+ dnl provide for dlopen() and friends. With help from Tamas Laufer!
+ dnl ****************************************************************
+
+-case "$ARCH" in
+- *sco*|*SCO*)
+- AC_MSG_CHECKING("SCO-Unix. See if we need -belf")
+- old_cflags="$CFLAGS"
+- CFLAGS="$CFLAGS -belf"
+- AC_TRY_COMPILE(
+- [
+- ],
+- [
+- ],
+- CMFLAGS="$CMFLAGS -belf"
+- AC_MSG_RESULT(yes),
+- AC_MSG_RESULT(no)
+- CFLAGS="$old_cflags")
+- ;;
+-esac
+-
+-
+ dnl Checks for header files.
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+@@ -105,23 +87,22 @@ fi
+
+
+ AC_ARG_WITH(sdl, [ --with-sdl Turn on SDL support instead of X11],
+- sdl_support=yes,
+- sdl_support=no)
++ [sdl_support=yes],
++ [sdl_support=no])
+
+-if test "x$sdl_support" = "xyes"; then
++AS_IF([test "x$sdl_support" = "xyes"], [
+ echo "SDL is ENABLED *******************"
+ IFACEOBJS='$(SDLOBJS)'
+ IFACELIBS='`sdl-config --libs` -lSDL_image'
+ IFACEINC='`sdl-config --cflags` -I./sdl'
+-else
++], [
+ echo "X11 is ENABLED *******************"
+ AC_PATH_X
+ AC_PATH_XTRA
+ IFACEOBJS='$(X11OBJS) $(X11IMAGE)'
+ IFACELIBS='$(XLIBS)'
+ IFACEINC='$(XINC) -I./x11'
+-fi
+-
++])
+
+ out_lib=${LIBS}
+
+@@ -169,47 +150,6 @@ MCOMMON=./src/Make.common
+ AC_SUBST_FILE(MCOMMON)
+
+
+-dnl Some specific OS stuff
+-
+-case "$ARCH" in
+- *hppa*|*hpux*)
+- # do nothing
+- ;;
+- *solaris*)
+- if test "$GCC" = "yes"; then
+- AC_MSG_CHECKING("whether we need -fpermissive")
+- old_cflags="$CFLAGS"
+- CFLAGS="-fpermissive $CFLAGS"
+- AC_TRY_RUN(
+- main()
+- { exit(0);
+- },
+- if grep 'option `-fpermissive'"'" config.log >/dev/null; then
+- AC_MSG_RESULT(no)
+- CFLAGS="$old_cflags"
+- else
+- CFLAGS="$old_cflags -fpermissive"
+- AC_MSG_RESULT(yes)
+- fi,
+- AC_MSG_RESULT(no)
+- CFLAGS="$old_cflags",
+- AC_MSG_RESULT(no)
+- CFLAGS="$old_cflags")
+- fi
+- ;;
+- *aix*)
+- # do nothing
+- ;;
+- *darwin*)
+- # do nothing
+- ;;
+- *)
+- # do nothing
+- ;;
+-esac
+-
+-
+-
+ AC_CONFIG_HEADER(src/include/config.h)
+ AC_OUTPUT( \
+ src/Make.common \
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1-r1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1-r2.ebuild
index 6d69ef032900..8f50a97e4b6a 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1-r1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs prefix
+inherit autotools toolchain-funcs prefix
DESCRIPTION="2.5D tetris like game"
HOMEPAGE="http://xnc.jinr.ru/xwelltris/"
@@ -26,6 +26,8 @@ PATCHES=(
# Look in ${EPREFIX}/var/lib/xwelltris for score file
"${FILESDIR}"/${PN}-1.0.1-scorefile-dir.patch
"${FILESDIR}"/${PN}-1.0.1-gcc-11.patch
+ "${FILESDIR}"/${PN}-1.0.1-c++17.patch
+ "${FILESDIR}"/${PN}-1.0.1-configure-autoconf-2.72.patch
)
src_prepare() {
@@ -41,6 +43,9 @@ src_prepare() {
# Ensure we look in ${EPREFIX}/var/lib/${PN} for score file
eprefixify src/commonfuncs.cxx
+
+ # Needed for autotools-2.72 patch + clang 16 (bug #899014)
+ eautoreconf
}
src_configure() {