summaryrefslogtreecommitdiff
path: root/games-puzzle/world-of-goo-hb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /games-puzzle/world-of-goo-hb
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'games-puzzle/world-of-goo-hb')
-rw-r--r--games-puzzle/world-of-goo-hb/Manifest3
-rw-r--r--games-puzzle/world-of-goo-hb/metadata.xml11
-rw-r--r--games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild66
3 files changed, 80 insertions, 0 deletions
diff --git a/games-puzzle/world-of-goo-hb/Manifest b/games-puzzle/world-of-goo-hb/Manifest
new file mode 100644
index 000000000000..b80393878462
--- /dev/null
+++ b/games-puzzle/world-of-goo-hb/Manifest
@@ -0,0 +1,3 @@
+DIST WorldOfGoo.Linux.1.53.sh 196695812 BLAKE2B a357a5a25bece4cb93735881f345ff64d1f89c8a17aa9550edab29815f2187cad29eab9bae21c4c8aff06a4dd3fde64bddfb54fe96a7c94a04e82be6d8ed5129 SHA512 3f0e9122f7cf043d7a7ceabfe221b03d32d3c6627e022551917137f0d13fccf21d218d028a3765eaa93e0e65d41110be8091189c46a5bad1616505500ce4f6e6
+EBUILD world-of-goo-hb-1.53.ebuild 1578 BLAKE2B c988f49e2cda6ccc1efeaaaa0d17a3e87e88b2d864a5d3584a40f07cc862cff152c097b152c9855f0148cbdc6fa5cc879750ec984c2ac281dce0b972655b9b7e SHA512 14a471c7bb9b730eff25389d86bfb1f1aaaa560bbee8df0559455622d9a9884c46783e04ce7e944e3a90257e195e16a22d407d555ed647ebb242d3f0b4d5507f
+MISC metadata.xml 320 BLAKE2B 620827afdb5f529d62131bf765bbe3e6ed33e2815c52e12ea527416e6638a4f1d0c66209b4e2a842bee844947a51bdf5b58b63960bbfa91063fcc5ee44d202a6 SHA512 57d0745c0a70b61b8df224a8de45ebe8ae6a952d5601d606c957bdea0690263d54e02a851750445afe1716e2c1a1c8c27881c8b1e7d2a79ba4c23939e4cc5d21
diff --git a/games-puzzle/world-of-goo-hb/metadata.xml b/games-puzzle/world-of-goo-hb/metadata.xml
new file mode 100644
index 000000000000..b010f5d66be9
--- /dev/null
+++ b/games-puzzle/world-of-goo-hb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">Use bundled libs</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild b/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild
new file mode 100644
index 000000000000..01269cea5750
--- /dev/null
+++ b/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop unpacker xdg
+
+MY_PN="WorldOfGoo"
+
+DESCRIPTION="A puzzle game with a strong emphasis on physics (Humble Bundle edition)"
+HOMEPAGE="https://2dboy.com/"
+SRC_URI="${MY_PN}.Linux.${PV}.sh"
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch strip bundled-libs? ( splitdebug )"
+
+BDEPEND="app-arch/unzip"
+
+RDEPEND="
+ !bundled-libs? (
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/sdl2-mixer[vorbis]
+ )
+ >=sys-devel/gcc-3.4
+ sys-libs/glibc
+ virtual/opengl
+ !games-puzzle/world-of-goo
+ !games-puzzle/world-of-goo-gog
+"
+
+dir="/opt/${PN%-*}"
+S="${WORKDIR}"
+QA_PREBUILT="${dir#/}/*"
+
+pkg_nofetch() {
+ elog "If you bought directly from 2DBOY then download ${A} from:"
+ elog " https://2dboy.com/ReceptionistBot/orderLookup.php"
+ elog
+ elog "Otherwise please buy and download ${A} from:"
+ elog " https://www.humblebundle.com/store/product/worldofgoo"
+ elog
+ elog "Then move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${dir}"
+ newexe data/x86$(usex amd64 _64 "")/${MY_PN}.bin.x86$(usex amd64 _64 "") ${MY_PN}.bin
+ dosym "../..${dir}"/${MY_PN}.bin /usr/bin/${PN%-*}
+
+ insinto "${dir}"
+ doins -r data/noarch/game/
+ use bundled-libs && doins -r data/x86$(usex amd64 _64 "")/lib$(usex amd64 64 "")/
+
+ newicon -s 256 data/noarch/game/gooicon.png ${PN%-*}.png
+ make_desktop_entry ${PN%-*} "World of Goo" ${PN%-*}
+
+ docinto html
+ dodoc data/noarch/readme.html
+}