summaryrefslogtreecommitdiff
path: root/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild')
-rw-r--r--games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild b/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild
new file mode 100644
index 000000000000..c25a8830d831
--- /dev/null
+++ b/games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg
+
+MY_PN="WorldOfGooDemo"
+
+DESCRIPTION="A puzzle game with a strong emphasis on physics (demo version)"
+HOMEPAGE="https://2dboy.com/"
+SRC_URI="mirror://sourceforge/slackbuildsdirectlinks/worldofgoo/${MY_PN}.${PV}.tar.gz"
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ media-libs/libsdl[opengl,sound,video]
+ media-libs/sdl-mixer[vorbis]
+ >=sys-devel/gcc-3.4
+ sys-libs/glibc
+ virtual/opengl
+ virtual/glu
+"
+
+dir="/opt/${PN}"
+S="${WORKDIR}/${MY_PN}"
+QA_PREBUILT="${dir#/}/*"
+
+src_install() {
+ exeinto "${dir}"
+ newexe ${MY_PN%Demo}.bin$(usex amd64 64 32) ${MY_PN%Demo}.bin
+ make_wrapper ${PN} ./${MY_PN%Demo}.bin "${dir}"
+
+ insinto "${dir}"
+ doins -r icons/ properties/ res/
+
+ local icon size
+ for icon in icons/*.{png,svg}; do
+ size=${icon##*/}
+ size=${size%%[x.]*}
+ newicon -s "${size}" "${icon}" "${PN}.${icon##*.}"
+ done
+
+ make_desktop_entry ${PN} "World of Goo (Demo)"
+
+ dodoc linux-issues.txt
+ docinto html
+ dodoc readme.html
+}