summaryrefslogtreecommitdiff
path: root/games-puzzle/torrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/torrent
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/torrent')
-rw-r--r--games-puzzle/torrent/Manifest5
-rw-r--r--games-puzzle/torrent/metadata.xml8
-rw-r--r--games-puzzle/torrent/torrent-0.8.2.ebuild32
3 files changed, 45 insertions, 0 deletions
diff --git a/games-puzzle/torrent/Manifest b/games-puzzle/torrent/Manifest
new file mode 100644
index 000000000000..bab02eb018af
--- /dev/null
+++ b/games-puzzle/torrent/Manifest
@@ -0,0 +1,5 @@
+DIST torrent-0.8.2.tar.gz 555686 SHA256 93890ed9287061f6b8d63993962c188013388fe7cf4d3d334ca7e72cc3209a67 SHA512 da7fbb21252a76fcd41c0b22ae4c0835e2fcabc4da5ce60ad04880c3fb633b6aaa951532ac0ce69d93f03b7608e4b110a23ed6f9f8839d053cd4a0d9500d1692 WHIRLPOOL b2a360bc6a20d8de67cbeec9808c914f4b1120b029e5367658ebf9ee46195fa63c9ca70fa41f5ec4adf3da744175aa31ea720564a5ed4ccb01e464ab274fc423
+EBUILD torrent-0.8.2.ebuild 717 SHA256 6e67fa6033c843c6bacbd1b45080292ae90404937da502a8b4890c6bc39a76f9 SHA512 d23b090b3aaf70e0a2c2d91ce849a7edd78bcb72a1814967cbf039e2334b8cb1239062b0692dd286cd793bd61e2b394b82a6e7b15487f758174178e90f1f55b4 WHIRLPOOL 71b13ec2a2280a4eadbfd7e684894de8d9683210ee512837ebf0035b2daa721b47feb46c0bbad229550c9e281c6bfae99dfd0bd043de8fc92b8a4f49326a0a73
+MISC ChangeLog 2431 SHA256 1f658bf2e36f42716d45748c393fa69aa40fd127a7bbb38d261512a045d28086 SHA512 a7243e57dcf201a3db91a732240ced07937b59321d5d7af3c9d610ce6b7e503fd1b5f330baed332024f9fcb375e45d3cdc1d0531e42dd7c64b550af5de9ea752 WHIRLPOOL 72fa86b1b6e89353451e8b6d08352ec50ff8cdc59bad3ece577b3ea4faa3ac1428cf3946c12e4785d3fce84d4d6e0fbf44204466a78d385839490422694f182e
+MISC ChangeLog-2015 1063 SHA256 bbb3de4bc3f58117769bb11f53e2043f43e3d46bddf073f388ce35a65074828a SHA512 7f7038dbb8ded68f4cd73b18e8ac9ba49b221e73ec922730a42c08813ea47a3c8369bf00873c8db4416d0872442a61825d68ccefdeaf811321be48b64eb2c462 WHIRLPOOL efc6b90549faa141b0cb0a7b045317a5fea61db0a507953640b3307e770ec816948d69a76f3e4c4d1eb221570e2df3b594d257e48c72a4187e4cd9bc23a93fbe
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-puzzle/torrent/metadata.xml b/games-puzzle/torrent/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/torrent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-puzzle/torrent/torrent-0.8.2.ebuild b/games-puzzle/torrent/torrent-0.8.2.ebuild
new file mode 100644
index 000000000000..ca645a95b595
--- /dev/null
+++ b/games-puzzle/torrent/torrent-0.8.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Match rising tiles to score as many points as possible before the tiles touch the top of the board"
+HOMEPAGE="http://www.shiftygames.com/torrent/torrent.html"
+SRC_URI="http://www.shiftygames.com/torrent/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/torrent.c \
+ || die "sed failed"
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}