summaryrefslogtreecommitdiff
path: root/games-puzzle/tetrinet/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-puzzle/tetrinet/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/tetrinet/files')
-rw-r--r--games-puzzle/tetrinet/files/tetrinet-0.11-build.patch84
-rw-r--r--games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch11
2 files changed, 0 insertions, 95 deletions
diff --git a/games-puzzle/tetrinet/files/tetrinet-0.11-build.patch b/games-puzzle/tetrinet/files/tetrinet-0.11-build.patch
deleted file mode 100644
index 0540b7bc8ce9..000000000000
--- a/games-puzzle/tetrinet/files/tetrinet-0.11-build.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,6 +1,4 @@
--CC = cc
--
--CFLAGS = -O2 -I/usr/include/ncurses -DHAVE_IPV6 -g -Wall
-+CFLAGS += -I/usr/include/ncurses -g -Wall
- OBJS = sockets.o tetrinet.o tetris.o tty.o xwin.o
-
- ### If you want to have -server tetrinet client option, comment the two lines
-@@ -24,10 +22,10 @@
- ########
-
- tetrinet: $(OBJS)
-- $(CC) -o $@ $(OBJS) -lncurses
-+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(shell ${PKG_CONFIG} --libs ncurses)
-
- tetrinet-server: server.c sockets.c tetrinet.c tetris.c server.h sockets.h tetrinet.h tetris.h
-- $(CC) $(CFLAGS) -o $@ -DSERVER_ONLY server.c sockets.c tetrinet.c tetris.c
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ -DSERVER_ONLY server.c sockets.c tetrinet.c tetris.c
-
- .c.o:
- $(CC) $(CFLAGS) -c $<
---- a/sockets.c
-+++ b/sockets.c
-@@ -66,7 +66,7 @@
- if (c == 0xFF)
- ptr--;
- *ptr = 0;
-- if (log) {
-+ if (logging) {
- if (!logfile)
- logfile = fopen(logname, "a");
- if (logfile) {
-@@ -89,7 +89,7 @@
- unsigned char c = 0xFF;
- int n = 0;
-
-- if (log) {
-+ if (logging) {
- if (!logfile)
- logfile = fopen(logname, "a");
- if (logfile) {
---- a/tetrinet.c
-+++ b/tetrinet.c
-@@ -21,7 +21,7 @@
- /*************************************************************************/
-
- int fancy = 0; /* Fancy TTY graphics? */
--int log = 0; /* Log network traffic to file? */
-+int logging = 0; /* Log network traffic to file? */
- char *logname; /* Log filename */
- int windows_mode = 0; /* Try to be just like the Windows version? */
- int noslide = 0; /* Disallow piece sliding? */
-@@ -82,8 +82,7 @@
- else
- winlist[i].team = 0;
- s++;
-- strncpy(winlist[i].name, s, sizeof(winlist[i].name)-1);
-- winlist[i].name[sizeof(winlist[i].name)] = 0;
-+ snprintf(winlist[i].name, sizeof(winlist[i].name), "%s", s);
- winlist[i].points = atoi(t);
- if ((t = strchr(t, ';')) != NULL)
- winlist[i].games = atoi(t+1);
-@@ -590,7 +589,7 @@
- if (strcmp(av[i], "-fancy") == 0) {
- fancy = 1;
- } else if (strcmp(av[i], "-log") == 0) {
-- log = 1;
-+ logging = 1;
- i++;
- if (i >= ac) {
- fprintf(stderr, "Option -log requires an argument\n");
---- a/tetrinet.h
-+++ b/tetrinet.h
-@@ -74,7 +74,7 @@
- /* Externs */
-
- extern int fancy;
--extern int log;
-+extern int logging;
- extern char *logname;
- extern int windows_mode;
- extern int noslide;
diff --git a/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch b/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch
deleted file mode 100644
index addfd9a0047c..000000000000
--- a/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/sockets.c
-+++ b/sockets.c
-@@ -188,7 +188,7 @@
- return -1;
- }
- if (ipbuf)
-- memcpy(retbuf, &sa.sin_addr, 4);
-+ memcpy(ipbuf, &sa.sin_addr, 4);
- #endif
-
- return sock;