summaryrefslogtreecommitdiff
path: root/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
commit590b9b7b03bf4651e099949e318755af7cfa81b8 (patch)
tree54c184b7d26c25f1922bfeaf19a1dd45a2e3b1eb /games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
parentf4fc10428424904caf2035cffc442195cb088b2c (diff)
gentoo resync : 01.08.2021
Diffstat (limited to 'games-puzzle/tanglet/tanglet-1.6.1.1.ebuild')
-rw-r--r--games-puzzle/tanglet/tanglet-1.6.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild b/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
new file mode 100644
index 000000000000..65f7fae82093
--- /dev/null
+++ b/games-puzzle/tanglet/tanglet-1.6.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Single player word finding game based on Boggle"
+HOMEPAGE="https://gottcode.org/tanglet/"
+SRC_URI="https://gottcode.org/tanglet/tanglet-1.6.1.1-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" tanglet.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}