summaryrefslogtreecommitdiff
path: root/games-puzzle/picpuz/files/picpuz-2.5-pthread-underlinking.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/picpuz/files/picpuz-2.5-pthread-underlinking.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/picpuz/files/picpuz-2.5-pthread-underlinking.patch')
-rw-r--r--games-puzzle/picpuz/files/picpuz-2.5-pthread-underlinking.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/games-puzzle/picpuz/files/picpuz-2.5-pthread-underlinking.patch b/games-puzzle/picpuz/files/picpuz-2.5-pthread-underlinking.patch
new file mode 100644
index 000000000000..652231f1d4ff
--- /dev/null
+++ b/games-puzzle/picpuz/files/picpuz-2.5-pthread-underlinking.patch
@@ -0,0 +1,18 @@
+Fix underlinking on recent binutils:
+
+> x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu picpuz.o zfuncs.o `pkg-config --libs gtk+-3.0` -o picpuz
+> /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: zfuncs.o: undefined reference to symbol 'pthread_create@@GLIBC_2.2.5'
+> /lib64/libpthread.so.0: error adding symbols: DSO missing from command line
+diff --git a/Makefile b/Makefile
+index 28638de..700b610 100644
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@ MANDIR = $(PREFIX)/share/man/man1
+ MENUFILE = $(PREFIX)/share/applications/kornelix-$(PROGRAM).desktop
+
+ CXXFLAGS += -c `pkg-config --cflags gtk+-3.0`
+-LIBS = `pkg-config --libs gtk+-3.0`
++LIBS = -pthread `pkg-config --libs gtk+-3.0`
+
+ $(PROGRAM): $(PROGRAM).o zfuncs.o
+ $(CXX) $(LDFLAGS) $(PROGRAM).o zfuncs.o $(LIBS) -o $(PROGRAM)