summaryrefslogtreecommitdiff
path: root/games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
commit7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (patch)
treebac2a67fb24ac0836147fe370d30e1610ae1845d /games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild
parent2f8db31405fac68eea6f7257d58529243815033b (diff)
gentoo resync : 02.05.2018
Diffstat (limited to 'games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild')
-rw-r--r--games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild b/games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild
new file mode 100644
index 000000000000..5f9eac856d8f
--- /dev/null
+++ b/games-puzzle/magiccube4d/magiccube4d-2.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+MY_PV="${PV/./_}"
+DESCRIPTION="Four-dimensional analog of Rubik's cube"
+HOMEPAGE="http://www.superliminal.com/cube/cube.htm"
+SRC_URI="http://www.superliminal.com/cube/mc4d-src-${MY_PV}.tgz
+ http://superliminal.com/cube/cube_transp.gif -> ${PN}.gif"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-src-${MY_PV}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-EventHandler.patch \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-64bit-ptr.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed -i \
+ -e "s:-Werror::" \
+ configure \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake DFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin magiccube4d
+ dodoc ChangeLog MagicCube4D-unix.txt readme-unix.txt Intro.txt
+ doicon "${DISTDIR}"/${PN}.gif
+ make_desktop_entry ${PN} "Magic Cube 4D" /usr/share/pixmaps/${PN}.gif
+}