summaryrefslogtreecommitdiff
path: root/games-puzzle/hexamine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
commit7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (patch)
treebac2a67fb24ac0836147fe370d30e1610ae1845d /games-puzzle/hexamine
parent2f8db31405fac68eea6f7257d58529243815033b (diff)
gentoo resync : 02.05.2018
Diffstat (limited to 'games-puzzle/hexamine')
-rw-r--r--games-puzzle/hexamine/Manifest2
-rw-r--r--games-puzzle/hexamine/hexamine-0.2.1-r1.ebuild (renamed from games-puzzle/hexamine/hexamine-0.2.1.ebuild)33
2 files changed, 17 insertions, 18 deletions
diff --git a/games-puzzle/hexamine/Manifest b/games-puzzle/hexamine/Manifest
index a9ec7a00ccf8..ac8b8fd309e6 100644
--- a/games-puzzle/hexamine/Manifest
+++ b/games-puzzle/hexamine/Manifest
@@ -1,3 +1,3 @@
DIST hexamine-0.2.1.tar.gz 130603 BLAKE2B e49b60e78346d59f5d0bf60f8aaa3f1230e87e6e76052c49197984df695cb4aacf947a2b5855f0388ed62f59fa04e47853f2c36583c38c9249100910eb5b5ff7 SHA512 eaf7c110f1c2434c2ea7bc01cc13266ed8e91cbbf0fff4ee8d8a78c549f9fd3f8d877210f574ba1cefad5a6ea230f376aab7d9ced6a4e2f477b6be776332a640
-EBUILD hexamine-0.2.1.ebuild 868 BLAKE2B 4e8a3f8676af16f19da1007df9a09b2f59a1ab1ead150354d41883e1b4d1ee3f6c4dcccb4c805cbd15a404a0a053bfb508ee3a59b7ceb6b4cd62ba9008759bc4 SHA512 a9cf88b36adcc4c56986e48b0a999147ce34c8ed8bf31ee1f5bc3ccf8963e509f55b5e5284111789503870db56a7866fe49198addc0104a222e9c6935258a425
+EBUILD hexamine-0.2.1-r1.ebuild 807 BLAKE2B 43c3d0be8faf714bd021d6505b020eb75d337753005c78865f381716795fbdaac28e73436834cab63a1981bb2311028cb0b3b4e28b83188fff84d2ea8790a57f SHA512 cdcc4a822d89da500a130542bb2582db91d15159a457bc55e158ec326e27367aa0f2eb6ce1762b2047e4587b7157660b43bae6175c2fcd1fad40361d70550c06
MISC metadata.xml 331 BLAKE2B f3ccbece9bcd1b9fe00383805f636401bb5b3bd10d2e1a2d5564182aebfe2a7e6614e3366ddf28e90ba5a62725d78dc08d1072c65c07ec3bc4ab5761bd2d2f39 SHA512 452f03abf92762a26c6492a3823b4fb3957abd627ec039daa73bb90c14079b71f0b79ce5af0548e3290c74275f5bf02ff264655cff6bb72a607e258a32e36bde
diff --git a/games-puzzle/hexamine/hexamine-0.2.1.ebuild b/games-puzzle/hexamine/hexamine-0.2.1-r1.ebuild
index 0551f1e713ad..67529d0521a4 100644
--- a/games-puzzle/hexamine/hexamine-0.2.1.ebuild
+++ b/games-puzzle/hexamine/hexamine-0.2.1-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit python-single-r1 games
+
+inherit desktop python-single-r1
DESCRIPTION="Hexagonal Minesweeper"
HOMEPAGE="https://sourceforge.net/projects/hexamine"
@@ -12,32 +13,30 @@ SRC_URI="mirror://sourceforge/hexamine/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-python/pygame
- ${PYTHON_DEPS}"
-DEPEND="${PYTHON_DEPS}"
+IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-S=${WORKDIR}/${PN}
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame
+"
+DEPEND=""
-pkg_setup() {
- python-single-r1_pkg_setup
- games_pkg_setup
-}
+S="${WORKDIR}/${PN}"
src_prepare() {
+ default
# Modify game data directory
sed -i \
- -e "s:\`dirname \$0\`:${GAMES_DATADIR}/${PN}:" \
+ -e "s:\`dirname \$0\`:/usr/share/${PN}:" \
-e "s:\./hexamine:exec ${EPYTHON} &:" \
hexamine || die
}
src_install() {
- dogamesbin hexamine
- insinto "${GAMES_DATADIR}/${PN}"
+ dobin hexamine
+ insinto "/usr/share/${PN}"
doins -r hexamine.* skins
- dodoc ABOUT README
- prepgamesdirs
+ einstalldocs
+ make_desktop_entry ${PN} "Hexamine"
}