summaryrefslogtreecommitdiff
path: root/games-puzzle/gfifteen/gfifteen-1.0.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /games-puzzle/gfifteen/gfifteen-1.0.3-r2.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'games-puzzle/gfifteen/gfifteen-1.0.3-r2.ebuild')
-rw-r--r--games-puzzle/gfifteen/gfifteen-1.0.3-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/gfifteen/gfifteen-1.0.3-r2.ebuild b/games-puzzle/gfifteen/gfifteen-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..d5c8a0497046
--- /dev/null
+++ b/games-puzzle/gfifteen/gfifteen-1.0.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Graphical implementation of the sliding puzzle game fifteen"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # allow using newer gtk+:3 (bug #536994)
+ sed -i 's/-DGTK_DISABLE_DEPRECATED=1 //' Makefile.in || die
+}
+
+src_configure() {
+ econf --disable-assembly
+}
+
+src_install() {
+ default
+
+ doicon ${PN}.svg
+ domenu gfifteen.desktop
+}