summaryrefslogtreecommitdiff
path: root/games-puzzle/galaxis/galaxis-1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-16 01:51:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-16 01:51:50 +0100
commit6144cd2e90f8e3623912112050c8d2025de44f0a (patch)
treebf6abe7c75cda0f602c2d522c905278a620a5cbf /games-puzzle/galaxis/galaxis-1.10.ebuild
parentca144cbf71b2faf598564847378fa40a0090d67c (diff)
gentoo auto-resync : 16:10:2022 - 01:51:50
Diffstat (limited to 'games-puzzle/galaxis/galaxis-1.10.ebuild')
-rw-r--r--games-puzzle/galaxis/galaxis-1.10.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/galaxis/galaxis-1.10.ebuild b/games-puzzle/galaxis/galaxis-1.10.ebuild
new file mode 100644
index 000000000000..d5baee4147e0
--- /dev/null
+++ b/games-puzzle/galaxis/galaxis-1.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic toolchain-funcs
+
+DESCRIPTION="Curses-based clone of the nifty little Macintosh freeware game Galaxis"
+HOMEPAGE="http://www.catb.org/~esr/galaxis/"
+SRC_URI="http://www.catb.org/~esr/galaxis/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-c2x.patch
+)
+
+src_compile() {
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags ncurses || die) -DNDEBUG
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses || die)
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" TERMLIB="${LIBS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.6
+ einstalldocs
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}