summaryrefslogtreecommitdiff
path: root/games-puzzle/construo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/construo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/construo')
-rw-r--r--games-puzzle/construo/Manifest5
-rw-r--r--games-puzzle/construo/construo-0.2.2-r1.ebuild38
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-gcc43.patch82
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-lGLU.patch18
-rw-r--r--games-puzzle/construo/metadata.xml8
5 files changed, 151 insertions, 0 deletions
diff --git a/games-puzzle/construo/Manifest b/games-puzzle/construo/Manifest
new file mode 100644
index 000000000000..da7032b36ddf
--- /dev/null
+++ b/games-puzzle/construo/Manifest
@@ -0,0 +1,5 @@
+AUX construo-0.2.2-gcc43.patch 1813 BLAKE2B 514c17651894fa7f991abe397696fae5de567579730635d6b115cfe18099bd98a575e7bb104f73607b0809be90b7e882d41a72875fc4d34801694ec4c6479c6d SHA512 5865311df15e510a4212778cf7bfc2cf82c60449841f3d9717b4d04a2a241977319296b7696567a39c95e16b1f94fe2959c9eb8775b3b56b0e804335c73159ed
+AUX construo-0.2.2-lGLU.patch 429 BLAKE2B da44fd32544394f66fd0ab5f5cda3cccf0cbe65646b73d38b672902cc639355ddb9bbbfe8f6255fc9253fe78444468593dfffc7d6bf9c6b69aa16dfa0027a314 SHA512 2fcba9fdc7f96bd802341a42bba33ca659152421d1ba7f6a1d56a5de75f5811ee08298831f1c3951e364600146364e64efdc9a67a45bb9f946ab19867bff27b2
+DIST construo-0.2.2.tar.gz 442626 BLAKE2B c6c9c566c8e4014aba1e06d12af2c3c3076d533a9f11513e903a6fff027ecbd3b492c1ca35a50b42dbd0aea5064614147529f2dcfd6b75af2376a7a410fdc470 SHA512 b73854a64aedcb9ddcd8f2c3e809f975ef3d2f63bdefd2e126c808a4154d7ff3d402457f9da5f866e6b9d74c6010ffc58d44b04277976fe1a9aeabc20ea786a9
+EBUILD construo-0.2.2-r1.ebuild 829 BLAKE2B 865546804f13c8a201789d3d13d6b60605d4b3ea14c5e7f4b40d67c0f807e5576cb042d18dc642d10befbb026edf0c322a449f2a739678de73edf01faf0986ba SHA512 268821a99a0f74fb7d33e3105a41cdcac1f430f0253ab1050f9b03c1ac49d5bd9f7c07a5f1f3de401ff710a2e2fdad3248446f8e02a46774ca0217f35224550b
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-puzzle/construo/construo-0.2.2-r1.ebuild b/games-puzzle/construo/construo-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..4370d583ab81
--- /dev/null
+++ b/games-puzzle/construo/construo-0.2.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="2d construction toy with objects that react on physical forces"
+HOMEPAGE="http://www.nongnu.org/construo/"
+SRC_URI="http://freesoftware.fsf.org/download/construo/construo.pkg/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ x11-libs/libXxf86vm
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-lGLU.patch
+ sed -i -e 's/^bindir=.*/bindir=@bindir@/' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ make_desktop_entry "${PN}.glut" "${PN}.glut"
+ make_desktop_entry "${PN}.x11" "${PN}.x11"
+}
diff --git a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
new file mode 100644
index 000000000000..48165ed21df0
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
@@ -0,0 +1,82 @@
+--- a/command_line.cxx
++++ b/command_line.cxx
+@@ -19,7 +19,9 @@
+
+ #include <config.h>
+ #include <iostream>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+ #include "settings.hxx"
+ #include "command_line.hxx"
+
+--- a/config.hxx
++++ b/config.hxx
+@@ -21,6 +21,7 @@
+ #define CONFIG_HH
+
+ #include <string>
++#include <cstdlib>
+
+ class Config
+ {
+--- a/lisp_reader.cxx
++++ b/lisp_reader.cxx
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <cstring>
+ #include "construo_error.hxx"
+ #include "lisp_reader.hxx"
+
+--- a/unix_system.cxx
++++ b/unix_system.cxx
+@@ -17,8 +17,9 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <stdio.h>
+-#include <assert.h>
++#include <cstdio>
++#include <cassert>
++#include <cstring>
+ #include <unistd.h>
+ #include <sys/time.h>
+ #include <time.h>
+--- a/vector.cxx
++++ b/vector.cxx
+@@ -16,8 +16,8 @@
+ totally replaced old CL_Vector with this code
+ */
+
+-#include <assert.h>
+-#include <math.h>
++#include <cassert>
++#include <cmath>
+ #include "vector.hxx"
+
+ CL_Vector::CL_Vector(float x, float y, float z, float w)
+--- a/world.cxx
++++ b/world.cxx
+@@ -17,7 +17,8 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <assert.h>
++#include <cassert>
++#include <cstring>
+ #include <algorithm>
+ #include "config.h"
+
+--- a/x11_display.cxx
++++ b/x11_display.cxx
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <iostream>
++#include <cstring>
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <X11/keysym.h>
diff --git a/games-puzzle/construo/files/construo-0.2.2-lGLU.patch b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
new file mode 100644
index 000000000000..be8e7b604d6f
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
@@ -0,0 +1,18 @@
+--- a/configure.ac.old 2009-11-24 18:27:48.000000000 +0100
++++ b/configure.ac 2009-11-24 18:28:29.000000000 +0100
+@@ -114,7 +114,7 @@
+ AC_CHECK_LIB(glut, glutMainLoop,
+ [
+ ConstruoTargets="$ConstruoTargets construo.glut"
+- AC_SUBST(glut_LIBS,"-lglut")
++ AC_SUBST(glut_LIBS,"-lglut -lGLU -lGL -lm")
+ ],
+ [])
+
+@@ -158,4 +158,4 @@
+ echo " Ingo Ruhnke <grumbel@gmx.de>"
+ echo ""
+
+-# EOF #
+\ No newline at end of file
++# EOF #
diff --git a/games-puzzle/construo/metadata.xml b/games-puzzle/construo/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-puzzle/construo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>