summaryrefslogtreecommitdiff
path: root/games-puzzle/construo/construo-0.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /games-puzzle/construo/construo-0.2.3.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'games-puzzle/construo/construo-0.2.3.ebuild')
-rw-r--r--games-puzzle/construo/construo-0.2.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-puzzle/construo/construo-0.2.3.ebuild b/games-puzzle/construo/construo-0.2.3.ebuild
new file mode 100644
index 000000000000..89c4de46b053
--- /dev/null
+++ b/games-puzzle/construo/construo-0.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop toolchain-funcs
+
+DESCRIPTION="2d construction toy with objects that react on physical forces"
+HOMEPAGE="http://www.nongnu.org/construo/"
+SRC_URI="http://download-mirror.savannah.gnu.org/releases/construo/construo.pkg/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/freeglut
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXxf86vm
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}/construo-0.2.3-clang.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e 's/^bindir=.*/bindir=@bindir@/' src/Makefile.am || die
+ eautoreconf
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+ make_desktop_entry "${PN}.glut" "${PN}.glut"
+ make_desktop_entry "${PN}.x11" "${PN}.x11"
+}