summaryrefslogtreecommitdiff
path: root/games-puzzle/colorcode/colorcode-0.8.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-puzzle/colorcode/colorcode-0.8.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-puzzle/colorcode/colorcode-0.8.5.ebuild')
-rw-r--r--games-puzzle/colorcode/colorcode-0.8.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/colorcode/colorcode-0.8.5.ebuild b/games-puzzle/colorcode/colorcode-0.8.5.ebuild
new file mode 100644
index 000000000000..bbe2bfc80290
--- /dev/null
+++ b/games-puzzle/colorcode/colorcode-0.8.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils qmake-utils
+
+MY_PN=ColorCode
+DESCRIPTION="A free advanced MasterMind clone"
+HOMEPAGE="http://colorcode.laebisch.com/"
+SRC_URI="http://${PN}.laebisch.com/download/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ default
+ sed -i -e '/FLAGS/d' ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dobin ${PN}
+ newicon img/cc64.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+}