summaryrefslogtreecommitdiff
path: root/games-puzzle/color-lines/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/color-lines/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/color-lines/files')
-rw-r--r--games-puzzle/color-lines/files/color-lines-0.6-Makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-puzzle/color-lines/files/color-lines-0.6-Makefile.patch b/games-puzzle/color-lines/files/color-lines-0.6-Makefile.patch
new file mode 100644
index 000000000000..bf1339b94a01
--- /dev/null
+++ b/games-puzzle/color-lines/files/color-lines-0.6-Makefile.patch
@@ -0,0 +1,35 @@
+--- a/Makefile.unix.orig 2013-04-12 13:56:42.131113000 +0400
++++ b/Makefile.unix 2013-04-12 13:57:26.595946027 +0400
+@@ -2,18 +2,18 @@
+ VERTITLE := lines-$(VERSION)
+ ARCHIVE := lines_$(VERSION).tar.gz
+
+-CFLAGS:=-Wall -O2 $(shell sdl-config --cflags)
++CFLAGS += $(shell sdl-config --cflags)
+ #-DMAEMO
+
+-LDFLAGS:=$(shell sdl-config --libs) -lSDL_image -lSDL_mixer
++LIBS := -lm $(shell sdl-config --libs) -lSDL_image -lSDL_mixer
+
+ SRC := board.c graphics.c main.c sound.c
+ OBJ := $(patsubst %.c, %.o, $(SRC))
+
+ all: color-lines
+-PREFIX:=/usr/local
++PREFIX:=/usr
+
+-BINDIR:=$(DESTDIR)/$(PREFIX)/games/
++BINDIR:=$(DESTDIR)$(PREFIX)/games/bin
+ GAMEDATADIR:=$(DESTDIR)/$(PREFIX)/share/games/color-lines/
+
+ svnclean:
+@@ -29,8 +29,7 @@
+
+ color-lines: $(OBJ)
+ cat color-lines.desktop.in | sed -e "s|@BINDIR|$(BINDIR)|g" > color-lines.desktop
+- $(CC) $(CFLAGS) $(LDFLAGS) $(^) -o $(@)
+- strip color-lines
++ $(CC) $(CFLAGS) $(LDFLAGS) $(^) -o $(@) $(LIBS)
+
+ clean:
+ rm -f *.o color-lines