summaryrefslogtreecommitdiff
path: root/games-puzzle/braincurses/braincurses-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /games-puzzle/braincurses/braincurses-1.1.0.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'games-puzzle/braincurses/braincurses-1.1.0.ebuild')
-rw-r--r--games-puzzle/braincurses/braincurses-1.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-puzzle/braincurses/braincurses-1.1.0.ebuild b/games-puzzle/braincurses/braincurses-1.1.0.ebuild
new file mode 100644
index 000000000000..94f0c4ab55b1
--- /dev/null
+++ b/games-puzzle/braincurses/braincurses-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A version of the classic game Mastermind"
+HOMEPAGE="https://github.com/bderrly/braincurses"
+SRC_URI="https://github.com/bderrly/braincurses/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ emake CXX=$(tc-getCXX) LDLIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+}
+
+src_install() {
+ dobin braincurses
+ einstalldocs
+}