summaryrefslogtreecommitdiff
path: root/games-puzzle/angrydd/angrydd-1.0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-puzzle/angrydd/angrydd-1.0.1-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-puzzle/angrydd/angrydd-1.0.1-r2.ebuild')
-rw-r--r--games-puzzle/angrydd/angrydd-1.0.1-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-puzzle/angrydd/angrydd-1.0.1-r2.ebuild b/games-puzzle/angrydd/angrydd-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..822cc2d5e973
--- /dev/null
+++ b/games-puzzle/angrydd/angrydd-1.0.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop python-single-r1
+
+DESCRIPTION="Angry, Drunken Dwarves, a falling blocks game similar to Puzzle Fighter"
+HOMEPAGE="https://www.sacredchao.net/~piman/angrydd/"
+SRC_URI="https://www.sacredchao.net/~piman/angrydd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="/usr/share/" \
+ TO="${PN}" \
+ install
+ rm -rf "${ED}/usr/share/games" "${ED}/usr/share/share" || die
+
+ python_optimize "${ED}/usr/share/${PN}"
+
+ dodir /usr/bin
+ dosym "${ED}/usr/share/${PN}/angrydd.py" "/usr/bin/${PN}"
+ doman angrydd.6
+ dodoc README TODO HACKING
+
+ doicon angrydd.png
+ make_desktop_entry angrydd "Angry, Drunken Dwarves"
+}