summaryrefslogtreecommitdiff
path: root/games-mud/lyntin/lyntin-4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-mud/lyntin/lyntin-4.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-mud/lyntin/lyntin-4.2-r1.ebuild')
-rw-r--r--games-mud/lyntin/lyntin-4.2-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-mud/lyntin/lyntin-4.2-r1.ebuild b/games-mud/lyntin/lyntin-4.2-r1.ebuild
new file mode 100644
index 000000000000..a8dbc53db947
--- /dev/null
+++ b/games-mud/lyntin/lyntin-4.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk?"
+
+inherit distutils-r1 games
+
+DESCRIPTION="tintin mud client clone implemented in Python"
+HOMEPAGE="http://lyntin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lyntin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="tk"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS=( COMMANDS PKG-INFO HACKING README )
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use tk ; then
+ elog "To start lyntin in GUI mode, create a config file"
+ elog "with this in it:"
+ elog
+ elog "[Lyntin]"
+ elog "ui: tk"
+ elog
+ elog "Then start lyntin like this:"
+ elog
+ elog "runlyntin -c /path/to/config_file\n"
+ fi
+}