summaryrefslogtreecommitdiff
path: root/games-misc/sdljoytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /games-misc/sdljoytest
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'games-misc/sdljoytest')
-rw-r--r--games-misc/sdljoytest/Manifest3
-rw-r--r--games-misc/sdljoytest/files/sdljoytest-11102003-no-common.patch11
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/games-misc/sdljoytest/Manifest b/games-misc/sdljoytest/Manifest
index 5a65deded699..47adb8b1eee3 100644
--- a/games-misc/sdljoytest/Manifest
+++ b/games-misc/sdljoytest/Manifest
@@ -1,3 +1,4 @@
+AUX sdljoytest-11102003-no-common.patch 238 BLAKE2B fecf305d2bc4534c515c5bc8e81d45489c1e14efc0afe34d5f20b06f40050efa0347b710c4c5e0d5b3e6606c95b5a093e9ecff7d193d3453eee067c1c0961ad7 SHA512 752feddb09c42775df2b5c8810d6d2b95dedb97d2e5c7812e044394bf05b2370f7e47c90eb36e62b7aed7c4d138f04ebf7e238d5ae2b9aafa546fbc522176d3a
DIST SDLJoytest-GL-11102003.tar.bz2 85997 BLAKE2B 23ae410c462d9501306d6e225d2523ef940dd3f3e6ab7c898313a25253f86c42d3c0c7d64385a0c6de06331ca68ddc49296cea572f0a1f42161a912e8ff3274d SHA512 4994e878eaacacb156d4d9988d1e7864ed4e5e3d4db6bc0be8a883d7edde87d56698eb22de5d39e2110be7f960e5bf080283a7563bb2bc3f17c390181e097c6a
-EBUILD sdljoytest-11102003.ebuild 872 BLAKE2B cc1368cb30bfc1f7c938a4df493d5819dace93a031cb5db50762cfac49f0d540d5e1059fd37af3da0331a4a7ea406a8e02cff458ab16bd8b8e7ddb5941347744 SHA512 4b16ec9ed12bc139dd4876459528fe8cb1c27c299315297c720015c008d9d3bcf68428b2acbb3856d13abfabb236b776247952266df682c231666274cd8322b9
+EBUILD sdljoytest-11102003.ebuild 924 BLAKE2B 76486a2d99dbeb4ff0e592080e2405f1de12a0c9d44310f029d3f11ce7132194bf739b829ca74f7683fbdc30e7d2c3b67d35ecfd3c3fd5051be2b1df7256d289 SHA512 b22c2f6c4d433a685f0a23551e1f751704c7a98f7a2fdcf20571b9c827210c752f0078393a7df37b713d6af745dd2d40b599088fe1219dd33b4fcb061605cef5
MISC metadata.xml 333 BLAKE2B 5eadf19507a2a63c03c3457ae2efec7cbc5a2b6abc8d323c7f38510f639b795e56d1e83e7ead78c1d3930317e712d6536cdc5453c84bc66573ea7c5963f63f58 SHA512 f3c36c935fc927fa6ccf4402f67ec8d213fd94c2bf5855b4f1e6852c3c2c32fa051998cda971050c7f2f3257dc4102369c0af8d5d386ecb2a1e4d2ab177217d9
diff --git a/games-misc/sdljoytest/files/sdljoytest-11102003-no-common.patch b/games-misc/sdljoytest/files/sdljoytest-11102003-no-common.patch
new file mode 100644
index 000000000000..6775c2b6655f
--- /dev/null
+++ b/games-misc/sdljoytest/files/sdljoytest-11102003-no-common.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/706448
+--- a/init_quit.h
++++ b/init_quit.h
+@@ -36,7 +36,6 @@ extern int joyXCenter;
+ extern int videoFlags;
+ extern int lightCol;
+ extern int lightRow;
+-int hello;
+ extern GLint textures[2];
+ extern GLuint base;
+
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
index 905eb1487338..335b1b27c354 100644
--- a/games-misc/sdljoytest/sdljoytest-11102003.ebuild
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
DESCRIPTION="SDL app to test joysticks and game controllers"
@@ -20,7 +20,10 @@ RDEPEND=${DEPEND}
S=${WORKDIR}/SDLJoytest-GL
+PATCHES=("${FILESDIR}"/${P}-no-common.patch)
+
src_prepare() {
+ default
emake clean
sed -i -e 's:/usr/local:/usr:' joytest.h || die
sed -i -e 's:SDL/::' *.c || die