summaryrefslogtreecommitdiff
path: root/games-misc/sdljoytest/sdljoytest-11102003.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/sdljoytest/sdljoytest-11102003.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/sdljoytest/sdljoytest-11102003.ebuild')
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
new file mode 100644
index 000000000000..905eb1487338
--- /dev/null
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="SDL app to test joysticks and game controllers"
+HOMEPAGE="http://sdljoytest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sdljoytest/SDLJoytest-GL-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[joystick,opengl,video]
+ virtual/opengl
+ media-libs/sdl-image"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/SDLJoytest-GL
+
+src_prepare() {
+ emake clean
+ sed -i -e 's:/usr/local:/usr:' joytest.h || die
+ sed -i -e 's:SDL/::' *.c || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="$(sdl-config --cflags) ${CFLAGS}" \
+ LDFLAGS="$(sdl-config --libs) -lGL ${LDFLAGS}"
+}
+
+src_install() {
+ dobin SDLJoytest-GL
+ insinto /usr/share/SDLJoytest-GL
+ doins *.bmp
+ doman SDLJoytest.1
+}