summaryrefslogtreecommitdiff
path: root/games-misc/ponysay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/ponysay
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/ponysay')
-rw-r--r--games-misc/ponysay/Manifest3
-rw-r--r--games-misc/ponysay/metadata.xml15
-rw-r--r--games-misc/ponysay/ponysay-3.0.2.ebuild60
3 files changed, 78 insertions, 0 deletions
diff --git a/games-misc/ponysay/Manifest b/games-misc/ponysay/Manifest
new file mode 100644
index 000000000000..613eaae338f2
--- /dev/null
+++ b/games-misc/ponysay/Manifest
@@ -0,0 +1,3 @@
+DIST ponysay-3.0.2.tar.gz 2110382 BLAKE2B eb547ca62315c1aff227bec5e71328b1e333ba6aa14061b262d1130997ec2de2d54665fd498c8c571eacce15757030ca84d29d82a40b9fc82675d63e62617118 SHA512 47d5c584b3b8c233567eff534b5109548c92075f69776703bc303929ba4278f67fd599987ef4a098aa871c2af0efd89186f96fa28565e73b4672abeb0c23fa45
+EBUILD ponysay-3.0.2.ebuild 1459 BLAKE2B 0253592c9606c3d0ddb8e459bb60d34f38449d81c2d2477e3811cb631aa7cc520f9fc15d43051d2afc9507685ed59603edd426f0a7567f5c1137e8bcdac9f00d SHA512 18abbfbd9ff75b7a101deb9e4a44ef11b5d67ab405bb5b8957ccbc5a576d58c6aacda1edf0ff538531f82bdc0b1ce2cba09ed59d5fd2c08cb4f7f049c357f636
+MISC metadata.xml 500 BLAKE2B a937b3dcb9fb8a11ceefa20731973096578f503d711731a22afd3fbaea75b25d37cb736af36fbe8696a0d01afca261a4156444ac6b26b9a87f30f29d785f7408 SHA512 612eee4d25e1f3e3ef18b08ac4fcf59fbee5ab179d1f4da5e6784909c1985aa816317eba1a4c1a0aae8b1dfc0bfcc63ea44ab844b1400e565a2ebfaf5d7f8d4c
diff --git a/games-misc/ponysay/metadata.xml b/games-misc/ponysay/metadata.xml
new file mode 100644
index 000000000000..288c0bcfb305
--- /dev/null
+++ b/games-misc/ponysay/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="fish-completion">Enable fish completion support</flag>
+ <flag name="non-free">Install non-free ponies (i.e. from the MLP franchise)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">erkin/ponysay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/ponysay/ponysay-3.0.2.ebuild b/games-misc/ponysay/ponysay-3.0.2.ebuild
new file mode 100644
index 000000000000..f71db68ff6b6
--- /dev/null
+++ b/games-misc/ponysay/ponysay-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="cowsay reimplemention for ponies"
+HOMEPAGE="https://github.com/erkin/ponysay"
+SRC_URI="https://github.com/erkin/ponysay/archive/3.0.2.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +non-free bash-completion fish-completion zsh-completion"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="${PYTHON_DEPS}
+ fish-completion? ( app-shells/fish )
+ zsh-completion? ( app-shells/zsh )"
+
+setup_py() {
+ "${PYTHON}" setup.py \
+ --prefix="${EPREFIX}"/usr \
+ --everything \
+ --without-info-compression \
+ --without-man-compression \
+ --without-pdf-compression \
+ --without-shared-cache \
+ --freedom=$(usex non-free no yes) \
+ $(use_with fish-completion) \
+ $(use_with zsh-completion) \
+ $(use_with doc info) \
+ $(use_with doc pdf "${EPREFIX}"/usr/share/doc/${PF}) \
+ "${@}" || die
+}
+
+src_compile() {
+ setup_py \
+ $(use_with bash-completion) \
+ build
+}
+
+src_install() {
+ setup_py \
+ --without-bash-completion \
+ --destdir="${D}" \
+ prebuilt
+
+ python_fix_shebang "${ED}"/usr/bin/${PN}
+
+ rm -rv "${ED}"/usr/share/licenses || die
+ dodoc CHANGELOG CONTRIBUTING CREDITS README.md
+
+ use bash-completion &&
+ newbashcomp completion/bash-completion.${PN}.install ${PN}
+}