summaryrefslogtreecommitdiff
path: root/games-misc/opengfx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /games-misc/opengfx
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'games-misc/opengfx')
-rw-r--r--games-misc/opengfx/Manifest3
-rw-r--r--games-misc/opengfx/files/opengfx-7.1-no-which.patch30
-rw-r--r--games-misc/opengfx/opengfx-7.1.ebuild6
3 files changed, 37 insertions, 2 deletions
diff --git a/games-misc/opengfx/Manifest b/games-misc/opengfx/Manifest
index 6821819cae08..af4551d4ec1f 100644
--- a/games-misc/opengfx/Manifest
+++ b/games-misc/opengfx/Manifest
@@ -1,3 +1,4 @@
+AUX opengfx-7.1-no-which.patch 997 BLAKE2B e0757dee3b729f7885b7b3bafdf5cc5a9f9588071c71bf2295d0287b879e7b2c5f76c76e5281ea2f4b6b2c9d06396341acc02f848c19fa5b64df5f6715aae371 SHA512 b5eff66bd5e656ef677a0749d90559c5d431a1a0a1c17adcd66a704a17563bce762a20843c61dabc24fbcf8046fc5e528f4db6f9855d0fee456f0619945fb106
DIST opengfx-7.1-source.tar.xz 9828168 BLAKE2B a1d8305744b76924400cad8503af1a20991551323adea6d0d60d9f6d5ac6311e52cb8f028eb614bbda41106823ab9b912f1fb8af02953758a2eb2912066a38e9 SHA512 55079babcd78d4a36279cb7610b6800308aca8409ed3b9fa33cd4993b0c1f988d7afe270b17930b97609c4fdf8cf4e362e17c11bd85d2ef136d042256c98483f
-EBUILD opengfx-7.1.ebuild 1111 BLAKE2B 16059ae53cd6c764f035bead7a11c98b888140a7bdd83aed9c2ee97b14f355055396fe8d69475eebce2f289fb8b1e87a1a060e3120ba784ce212c9b4f063928d SHA512 897d7586e9024322e29ea183d3f1ec299063dfd656588332284879e2b6299bb929aa26d6cb5f0af9d148c5e6adc50e8e191576fa434a446ce43b07a001516e3d
+EBUILD opengfx-7.1.ebuild 1164 BLAKE2B eb3ba282be3ebf547a9e0dc01a5c602a8aa62c5258b161169d29e45b648edd863cc1785813cda1549c160c858504e2c4227993b014993a3d5e7aecaba308f2b1 SHA512 441fe972e62a72f31af9c0d7a6bbe1ad02a168855038a048fb0685ee2c49d53a8f8ec503cb152f25da5f72675bd082225324ab9b759aa91ac4f9955930df4fdc
MISC metadata.xml 327 BLAKE2B c715ce68b2db10d38dd11434102f5345515dba779726012906aabc6169681605c615866328bf8d213ff80f77a7c7a4a7bbe7c3145c18b33abd8de553059e7e75 SHA512 c5f22f130e0506a7714b27dd2858f69d52a6f11854ebd82b4116d7045a57ef74b435dfe920bbb18c99eca7b139c276a56aef4b5e28396b376dad5ceba6686127
diff --git a/games-misc/opengfx/files/opengfx-7.1-no-which.patch b/games-misc/opengfx/files/opengfx-7.1-no-which.patch
new file mode 100644
index 000000000000..616d2af41078
--- /dev/null
+++ b/games-misc/opengfx/files/opengfx-7.1-no-which.patch
@@ -0,0 +1,30 @@
+https://github.com/OpenTTD/OpenGFX/pull/80
+--- a/Makefile
++++ b/Makefile
+@@ -97,7 +97,7 @@ GREP ?= grep
+ PYTHON ?= python
+
+ # Graphics processing
+-GIMP ?= $(shell which gimp)
++GIMP ?= $(shell command -v gimp)
+ GIMP_FLAGS ?= -n -i
+
+ # NML
+@@ -116,7 +116,7 @@ ifdef PNML_FILES
+ endif
+
+ # GRF tools
+-GRFID ?= $(shell which grfid)
++GRFID ?= $(shell command -v grfid)
+ GRFID_FLAGS ?= -m
+ MUSA ?= musa.py
+ # The license is set via bananas.ini, do not supply a "custom" license.
+@@ -606,7 +606,7 @@ endif
+ ifeq ($(shell echo "$(OSTYPE)" | cut -d_ -f1),MINGW32)
+ # If CC has been set to the default implicit value (cc), check if it can be used. Otherwise use a saner default.
+ ifeq "$(origin CC)" "default"
+- CC=$(shell which cc 2>/dev/null && echo "cc" || echo "gcc")
++ CC=$(shell command -v cc 2>/dev/null && echo "cc" || echo "gcc")
+ endif
+ WIN_VER = $(shell echo "$(OSTYPE)" | cut -d- -f2 | cut -d. -f1)
+ ifeq ($(WIN_VER),5)
diff --git a/games-misc/opengfx/opengfx-7.1.ebuild b/games-misc/opengfx/opengfx-7.1.ebuild
index 937e35cb1573..23ef30961b89 100644
--- a/games-misc/opengfx/opengfx-7.1.ebuild
+++ b/games-misc/opengfx/opengfx-7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,6 +24,10 @@ DEPEND="
DOCS=( "README.md" "changelog.txt" )
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.1-no-which.patch
+)
+
src_prepare() {
default