summaryrefslogtreecommitdiff
path: root/games-misc/gtklife/gtklife-5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /games-misc/gtklife/gtklife-5.2.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'games-misc/gtklife/gtklife-5.2.ebuild')
-rw-r--r--games-misc/gtklife/gtklife-5.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-misc/gtklife/gtklife-5.2.ebuild b/games-misc/gtklife/gtklife-5.2.ebuild
new file mode 100644
index 000000000000..07b83da645e7
--- /dev/null
+++ b/games-misc/gtklife/gtklife-5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="A Conway's Life simulator for Unix"
+HOMEPAGE="http://ironphoenix.org/tril/gtklife/"
+SRC_URI="http://ironphoenix.org/tril/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --with-gtk2 \
+ --with-docdir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r graphics patterns
+
+ newicon -s 48 icon_48x48.png ${PN}.png
+ make_desktop_entry ${PN} GtkLife
+
+ dodoc -r doc/*
+ dodoc AUTHORS README NEWS
+}