summaryrefslogtreecommitdiff
path: root/games-misc/games-envd/games-envd-0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-misc/games-envd/games-envd-0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-misc/games-envd/games-envd-0.ebuild')
-rw-r--r--games-misc/games-envd/games-envd-0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-misc/games-envd/games-envd-0.ebuild b/games-misc/games-envd/games-envd-0.ebuild
new file mode 100644
index 000000000000..4cf3739f060c
--- /dev/null
+++ b/games-misc/games-envd/games-envd-0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib games
+
+DESCRIPTION="Environment file for gentoo games"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Games"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa m68k ~mips ppc64 s390 sh x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_pkg_setup
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ if [[ -e "${EROOT%/}/etc/env.d/${GAMES_ENVD}" ]] ; then
+ einfo "removing ${EROOT%/}/etc/env.d/${GAMES_ENVD}"
+ rm "${EROOT%/}/etc/env.d/${GAMES_ENVD}" || die
+ fi
+ fi
+}
+
+src_prepare() {
+ local d libdirs
+
+ for d in $(get_all_libdirs) ; do
+ libdirs="${libdirs}:${GAMES_PREFIX}/${d}"
+ done
+
+ cat <<-EOF > ${GAMES_ENVD} || die
+ # if you don't want these added for non-games users
+ # see https://bugs.gentoo.org/show_bug.cgi?id=408615
+ LDPATH="${libdirs:1}"
+ PATH="${GAMES_BINDIR}"
+ EOF
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ doenvd ${GAMES_ENVD}
+ gamesowners "${ED%/}"/etc/env.d/${GAMES_ENVD}
+ gamesperms "${ED%/}"/etc/env.d/${GAMES_ENVD}
+}
+
+pkg_preinst() { :; }
+
+pkg_postinst() { :; }