summaryrefslogtreecommitdiff
path: root/games-misc/gBhed/gBhed-0.17-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
commit78754950ffa3aaba0f48b1ca1d505caa4a3dfbfa (patch)
tree285997f09f32d26633ba2beffd30c972a4ec87a2 /games-misc/gBhed/gBhed-0.17-r2.ebuild
parentbf99f8024d68382f76665735c70ae912331bc2ca (diff)
gentoo auto-resync : 04:10:2022 - 13:17:38
Diffstat (limited to 'games-misc/gBhed/gBhed-0.17-r2.ebuild')
-rw-r--r--games-misc/gBhed/gBhed-0.17-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-misc/gBhed/gBhed-0.17-r2.ebuild b/games-misc/gBhed/gBhed-0.17-r2.ebuild
new file mode 100644
index 000000000000..2ea96ea67eb6
--- /dev/null
+++ b/games-misc/gBhed/gBhed-0.17-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="An Al Bhed translator"
+HOMEPAGE="http://liquidchile.net/software/gbhed/"
+SRC_URI="http://liquidchile.net/software/gbhed/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+DEPEND="gui? ( x11-libs/gtk+:2 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/19/32/' src/gui/translation_fork.c || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir=/usr/share/${PN} \
+ $(use_enable gui gbhed)
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ doman doc/abtranslate.1
+
+ if use gui ; then
+ insinto /usr/share/${PN}/pixmaps
+ doins pixmaps/*.{jpg,png,xpm}
+
+ newicon pixmaps/gbhed48.png ${PN}.png
+
+ make_desktop_entry gbhed ${PN}
+ doman doc/gbhed.1
+ fi
+}