summaryrefslogtreecommitdiff
path: root/games-misc/fortune-mod/fortune-mod-1.99.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-07 12:24:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-07 12:24:47 +0100
commit5d8ffbc273ca664e15618d557ced3e02de1a884b (patch)
treebc22fbc6a07790fd70dc8b5148de3089a1c4db3e /games-misc/fortune-mod/fortune-mod-1.99.1-r3.ebuild
parent4187bba080530c5ca1c7dae9c233e88f3fc8f535 (diff)
gentoo auto-resync : 07:07:2024 - 12:24:46
Diffstat (limited to 'games-misc/fortune-mod/fortune-mod-1.99.1-r3.ebuild')
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.99.1-r3.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/games-misc/fortune-mod/fortune-mod-1.99.1-r3.ebuild b/games-misc/fortune-mod/fortune-mod-1.99.1-r3.ebuild
deleted file mode 100644
index 52c430fbdeae..000000000000
--- a/games-misc/fortune-mod/fortune-mod-1.99.1-r3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="The notorious fortune program"
-HOMEPAGE="https://www.shlomifish.org/open-source/projects/fortune-mod/"
-SRC_URI="http://www.redellipse.net/code/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~m68k ~mips ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="offensive"
-
-DEPEND="app-text/recode:0="
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/01_all_fortune_all-fix.patch
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e 's:/games::' \
- -e 's:/fortunes:/fortune:' \
- -e '/^FORTDIR=/s:=.*:=$(prefix)/usr/bin:' \
- -e '/^all:/s:$: fortune/fortune.man:' \
- -e "/^OFFENSIVE=/s:=.*:=`use offensive && echo 1 || echo 0`:" \
- Makefile || die "sed Makefile failed"
-
- if ! use elibc_glibc ; then
- [[ ${CHOST} == *-darwin* ]] && local reglibs="-lc"
- has_version "app-text/recode[nls]" && reglibs="${reglibs} -lintl"
- sed -i \
- -e "/^REGEXLIBS=/s:=.*:= ${reglibs}:" \
- Makefile \
- || die "sed REGEXLIBS failed"
- fi
-
- if [[ ${CHOST} == *-solaris* ]] ; then
- sed -i -e 's:u_int:uint:g' util/strfile.h || die "sed strfile.h failed"
- fi
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- sed -i -e 's/-DBSD_REGEX/-DPOSIX_REGEX/' Makefile || die "sed Makefile failed"
- fi
-}
-
-src_compile() {
- local myrex=
- emake prefix="${EPREFIX}" CC="$(tc-getCC)" ${myrex}
-}
-
-src_install() {
- emake prefix="${ED}" install
- dodoc ChangeLog INDEX Notes Offensive README TODO cookie-files
-}