summaryrefslogtreecommitdiff
path: root/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild')
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
new file mode 100644
index 000000000000..de59ad262af6
--- /dev/null
+++ b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The notorious fortune program"
+HOMEPAGE="http://www.redellipse.net/code/fortune"
+SRC_URI="http://www.redellipse.net/code/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa m68k ~mips ppc64 s390 sh x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive elibc_glibc"
+
+DEPEND="app-text/recode"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/01_all_fortune_all-fix.patch
+
+ sed -i \
+ -e 's:/games::' \
+ -e 's:/fortunes:/fortune:' \
+ -e '/^FORTDIR=/s:=.*:=$(prefix)/usr/bin:' \
+ -e '/^all:/s:$: fortune/fortune.man:' \
+ -e "/^OFFENSIVE=/s:=.*:=`use offensive && echo 1 || echo 0`:" \
+ Makefile || die "sed Makefile failed"
+
+ if ! use elibc_glibc ; then
+ [[ ${CHOST} == *-*bsd* ]] && local reglibs="-lcompat"
+ [[ ${CHOST} == *-darwin* ]] && local reglibs="-lc"
+ has_version "app-text/recode[nls]" && reglibs="${reglibs} -lintl"
+ sed -i \
+ -e "/^REGEXLIBS=/s:=.*:= ${reglibs}:" \
+ Makefile \
+ || die "sed REGEXLIBS failed"
+ fi
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's:u_int:uint:g' util/strfile.h || die "sed strfile.h failed"
+ fi
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/-DBSD_REGEX/-DPOSIX_REGEX/' Makefile || die "sed Makefile failed"
+ fi
+}
+
+src_compile() {
+ local myrex=
+ [[ ${CHOST} == *-interix* ]] && myrex="REGEXDEFS=-DNO_REGEX"
+ emake prefix="${EPREFIX}" CC="$(tc-getCC)" $myrex
+}
+
+src_install() {
+ emake prefix="${ED}" install
+ dodoc ChangeLog INDEX Notes Offensive README TODO cookie-files
+}