summaryrefslogtreecommitdiff
path: root/games-misc/cowsay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/cowsay
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/cowsay')
-rw-r--r--games-misc/cowsay/Manifest6
-rw-r--r--games-misc/cowsay/cowsay-3.03-r2.ebuild41
-rw-r--r--games-misc/cowsay/files/cowsay-3.03-mech.patch18
-rw-r--r--games-misc/cowsay/files/cowsay-3.03-tongue.patch10
-rw-r--r--games-misc/cowsay/files/cowsay-3.03-utf8.patch17
-rw-r--r--games-misc/cowsay/metadata.xml8
6 files changed, 100 insertions, 0 deletions
diff --git a/games-misc/cowsay/Manifest b/games-misc/cowsay/Manifest
new file mode 100644
index 000000000000..3a62a018a3a9
--- /dev/null
+++ b/games-misc/cowsay/Manifest
@@ -0,0 +1,6 @@
+AUX cowsay-3.03-mech.patch 490 BLAKE2B 28c4f7060f8be6e77bb1d1a598875ed28b0d3dabd3b0f84ae4f197c159d7f554cf35600e082d58684ee244a1d76e620c7c5505f9e054e5e2853edceab3bfea72 SHA512 abaa76dee0c896100bab79a68c25720bb8449af77990ced74d89d271e22fd8fa5cb1b4586ef79e4c12a21d7091164d8c19a1162e78636874864a3fafa3a8df1d
+AUX cowsay-3.03-tongue.patch 358 BLAKE2B 35dbba5ebd96a4d20b59ebdb8fba86d3169f6bdfad86d8e7dcd5f4f4e02bcbd54ae8f114a3ef5cac18de355e45a1c5a9b5306a5230676638732698048fea68ab SHA512 bce27566383debd01f00c40e867dff9d405304f70e72de9ca4c2611c6242da9919c5a74b6ac3d0632ad7c928ef578f8bb78d125ed6141a0adf3f7498731f8e6f
+AUX cowsay-3.03-utf8.patch 454 BLAKE2B 2274a604daf96638b11d7cedd1fae7ac3178d138e7c1110007cfff4aa19ca061099dac7423545688388d741f66fba9fcfff6f9a8983501b5eabfefaeaf75f005 SHA512 4519c799311b5e31b3299fc66285ad0f9bfd2148dbfb34411437d37cda37d7cea8e823c8f99b0a0ef3652bb839f09d05fd5c5c727db4b091c6ed86d335ed6ece
+DIST cowsay-3.03.tar.gz 15189 BLAKE2B de22c870c23612d1861d7de5e610a072833f1627897b11bb9a642464032051a35f6a146125a75c511e7b65df3f885cb7558988d0a535e093dcb3765969aef4d1 SHA512 8e91d0c929c2e0743106c08643029a943d0684343ff44ad8ff172636a8f47fd25ee8bc4d108ccfe308c756d2871b956cceef0c406800615ed0dc1e1e24648219
+EBUILD cowsay-3.03-r2.ebuild 1138 BLAKE2B 9229e8cf41710fe88dec162cfce7f63bc1dcb611f5682b0231dc55ae0533a4b0cd472d6c39487e08adfd639cebced1bb6d237a6e9edd9fad67bf2acd0572308a SHA512 a0a5ea45d203d9f9659f1b7c6b5cca6b5680dc8d8aba18448cded9f62e88bc053069da46ff2f9f4d7e0955c148415423f4bd4774532f25cda975a1441fe56a37
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-misc/cowsay/cowsay-3.03-r2.ebuild b/games-misc/cowsay/cowsay-3.03-r2.ebuild
new file mode 100644
index 000000000000..88e195c614d6
--- /dev/null
+++ b/games-misc/cowsay/cowsay-3.03-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="configurable talking ASCII cow (and other characters)"
+HOMEPAGE="http://www.nog.net/~tony/warez/cowsay.shtml"
+SRC_URI="http://www.nog.net/~tony/warez/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc64 ~x86 ~x86-fbsd ~x64-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5"
+
+src_prepare() {
+ sed -i \
+ -e "1 c\#!${EPREFIX}/usr/bin/perl"\
+ -e 's/\$version/\$VERSION/g'\
+ -e "s:%PREFIX%/share/cows:${EPREFIX}/usr/share/${P}/cows:" \
+ -e '/getopts/ i\$Getopt::Std::STANDARD_HELP_VERSION=1;' cowsay \
+ || die "sed cowsay failed"
+ sed -i \
+ -e "s|%PREFIX%/share/cows|${EPREFIX}/usr/share/${P}/cows|" cowsay.1 \
+ || die "sed cowsay.1 failed"
+ epatch \
+ "${FILESDIR}/${P}"-tongue.patch \
+ "${FILESDIR}/${P}"-mech.patch \
+ "${FILESDIR}/${P}"-utf8.patch
+}
+
+src_install() {
+ dobin cowsay
+ doman cowsay.1
+ dosym cowsay /usr/bin/cowthink
+ dosym cowsay.1 /usr/share/man/man1/cowthink.1
+ dodir /usr/share/${P}/cows
+ cp -r cows "${ED}"/usr/share/${P}/ || die "cp failed"
+}
diff --git a/games-misc/cowsay/files/cowsay-3.03-mech.patch b/games-misc/cowsay/files/cowsay-3.03-mech.patch
new file mode 100644
index 000000000000..10478ed6651d
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.03-mech.patch
@@ -0,0 +1,18 @@
+--- cows/mech-and-cow 2009-06-21 03:09:36.000000000 +0300
++++ cows/mech-and-cow.cow 2010-08-22 01:04:02.670000262 +0300
+@@ -1,3 +1,5 @@
++$the_cow = <<EOC;
++${thouts}
+ ,-----.
+ | |
+ ,--| |-.
+@@ -14,8 +16,4 @@
+ (__)\ )\/\ /' / | `i
+ ||----w | ___,;`----'.___L_,-'`\__
+ || || i_____;----\.____i""\____\
+-
+-
+-
+-
+-
++EOC
diff --git a/games-misc/cowsay/files/cowsay-3.03-tongue.patch b/games-misc/cowsay/files/cowsay-3.03-tongue.patch
new file mode 100644
index 000000000000..517e96709c23
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.03-tongue.patch
@@ -0,0 +1,10 @@
+--- cows/head-in.cow.old 2007-05-09 20:28:08.000000000 +0200
++++ cows/head-in.cow 2007-05-09 20:29:32.000000000 +0200
+@@ -7,6 +7,6 @@
+ ^__^ /
+ ($eyes)\\_______/ _________
+ (__)\\ )=( ____|_ \\_____
+- $tongue ||----w | \\ \\ \\_____ |
++ $tongue ||----w | \\ \\ \\_____ |
+ || || || ||
+ EOC
diff --git a/games-misc/cowsay/files/cowsay-3.03-utf8.patch b/games-misc/cowsay/files/cowsay-3.03-utf8.patch
new file mode 100644
index 000000000000..6aed9c149e3d
--- /dev/null
+++ b/games-misc/cowsay/files/cowsay-3.03-utf8.patch
@@ -0,0 +1,17 @@
+diff -Naur cowsay-3.03.orig//cowsay cowsay-3.03/cowsay
+--- cowsay-3.03.orig//cowsay 2011-04-21 16:36:03.581377699 +0200
++++ cowsay-3.03/cowsay 2011-04-21 16:37:07.968430100 +0200
+@@ -12,6 +12,13 @@
+ use Getopt::Std;
+ use Cwd;
+
++if (${^UTF8LOCALE}) {
++ binmode STDIN, ':utf8';
++ binmode STDOUT, ':utf8';
++ require Encode;
++ eval { $_ = Encode::decode_utf8($_,1) } for @ARGV;
++}
++
+ $VERSION = "3.03";
+ $progname = basename($0);
+ $eyes = "oo";
diff --git a/games-misc/cowsay/metadata.xml b/games-misc/cowsay/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-misc/cowsay/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>