summaryrefslogtreecommitdiff
path: root/games-misc/bsod/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/bsod/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/bsod/files')
-rw-r--r--games-misc/bsod/files/bsod-0.1-Makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/games-misc/bsod/files/bsod-0.1-Makefile.patch b/games-misc/bsod/files/bsod-0.1-Makefile.patch
new file mode 100644
index 000000000000..b7699c80403b
--- /dev/null
+++ b/games-misc/bsod/files/bsod-0.1-Makefile.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,15 +1,15 @@
+ VERSION=0.1
+
+ DEBUG=-g -pedantic #-pg #-fprofile-arcs
+-LDFLAGS=-lncurses $(DEBUG)
+-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
++LDLIBS=$(shell ${PKG_CONFIG} --libs ncurses)
++CFLAGS+=-Wall -DVERSION=\"$(VERSION)\"
+
+ OBJS=bsod.o
+
+ all: bsod
+
+ bsod: $(OBJS)
+- $(CC) -Wall $(OBJS) $(LDFLAGS) -o bsod
++ $(CC) $(LDFLAGS) $(CFLAGS) $(OBJS) $(LDLIBS) -o bsod
+
+ install: bsod
+ cp bsod $(DESTDIR)/usr/local/bin