summaryrefslogtreecommitdiff
path: root/games-kids/tuxtype/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-kids/tuxtype/files
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-kids/tuxtype/files')
-rw-r--r--games-kids/tuxtype/files/tuxtype-1.8.3-missing-text.patch15
-rw-r--r--games-kids/tuxtype/files/tuxtype-1.8.3-t4kcommon.patch20
2 files changed, 35 insertions, 0 deletions
diff --git a/games-kids/tuxtype/files/tuxtype-1.8.3-missing-text.patch b/games-kids/tuxtype/files/tuxtype-1.8.3-missing-text.patch
new file mode 100644
index 000000000000..9553cfa89843
--- /dev/null
+++ b/games-kids/tuxtype/files/tuxtype-1.8.3-missing-text.patch
@@ -0,0 +1,15 @@
+Fix some missing (transparent) text with libsdl-1.2.15_p20210224.
+Same issue as t4k-common-0.1.1 given tuxtype shares the same
+code and wasn't migrated to support the separate library yet.
+--- a/src/SDL_extras.c
++++ b/src/SDL_extras.c
+@@ -1297,3 +1297,3 @@
+ /* Use color key for eventual transparency: */
+- color_key = SDL_MapRGB(bg->format, 01, 01, 01);
++ color_key = SDL_MapRGBA(bg->format, 01, 01, 01, 0xff);
+ SDL_FillRect(bg, NULL, color_key);
+@@ -1344,3 +1344,3 @@
+ SDL_SetColorKey(bg, SDL_SRCCOLORKEY|SDL_RLEACCEL, color_key);
+- out = SDL_DisplayFormatAlpha(bg);
++ out = SDL_DisplayFormat(bg);
+ SDL_FreeSurface(bg);
diff --git a/games-kids/tuxtype/files/tuxtype-1.8.3-t4kcommon.patch b/games-kids/tuxtype/files/tuxtype-1.8.3-t4kcommon.patch
new file mode 100644
index 000000000000..14ded5619041
--- /dev/null
+++ b/games-kids/tuxtype/files/tuxtype-1.8.3-t4kcommon.patch
@@ -0,0 +1,20 @@
+This was added ahead of time (for next version), currently unused.
+--- a/configure.ac
++++ b/configure.ac
+@@ -249,16 +249,4 @@
+ dnl libt4kcommon is now required: --------------------------------------------
+
+-PKG_CHECK_MODULES([T4K_COMMON],
+- [t4k_common],
+- [],
+- [AC_MSG_NOTICE([t4k_common not located by pkg-config, checking with AC CHECK LIB:])
+- AC_CHECK_LIB([t4k_common],
+- [InitT4KCommon],
+- [],
+- [AC_MSG_ERROR([libt4k_common is required: git://git.debian.org/tux4kids/t4kcommon.git])])])
+-
+-AC_DEFINE([HAVE_LIBT4K_COMMON],[1],[Define to 1 if you have the `t4k_common` library])
+-CFLAGS="$CFLAGS $T4K_COMMON_CFLAGS"
+-LIBS="$LIBS $T4K_COMMON_LIBS"
+
+