summaryrefslogtreecommitdiff
path: root/games-fps/xonotic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-fps/xonotic
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-fps/xonotic')
-rw-r--r--games-fps/xonotic/Manifest3
-rw-r--r--games-fps/xonotic/files/xonotic-0.8.2-gcc-11.patch41
-rw-r--r--games-fps/xonotic/xonotic-0.8.2.ebuild4
3 files changed, 46 insertions, 2 deletions
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index e1ee5bac0717..f2b5ca55f83f 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1,3 +1,4 @@
+AUX xonotic-0.8.2-gcc-11.patch 1409 BLAKE2B 4c0ebe1dd7c9d6bd4a8cf57819203956d66095fa17335ff4747e994f1cc44e8dea6f8d4d693fa41e4e3b1c83571354611148b1824a003abe644ab9efbb1c6012 SHA512 981ac3b288a4921e80e3889500ea7d8e212608ba6af2c8f19f42000212265dfd6b15d5ccb1e31b5a251daf7cdf1cf049eb936a648f2f3056d30a1e27fe00e59e
DIST xonotic-0.8.2.zip 991045679 BLAKE2B 3005473da954492bb7387f9e0e13c2415e638877fa8b83e14872f3b04ed0fc21b82e18f51aa6c68e8bf02d09d4a73f290cbcaebdfa8c0a12ceb6582309baee8a SHA512 0787fcf326827ae0292e5917c7ff2c7fd79947209d4b62e7f83b8b828bec15b575da304e0631f9f163c9b0bd93bed13616e142398ff08cbdaaea890a939dfca5
-EBUILD xonotic-0.8.2.ebuild 2391 BLAKE2B 4efc6189bb1654a8a219050bc61bf2b0f0695425dd0594e9a6ed6b1a40dadedbe1e3556e7f009fa77d6af6b220ef1fc8cd0cdd326068c74613039b1bdf0b3fad SHA512 5eecf5415b7c55967b7fb6f80ed2fa5c0c21fc095788425d0ffb43bc9ac821ddced3df156cc2af1713fd344157b4212384d538dcb621433ee2ff4cae25914610
+EBUILD xonotic-0.8.2.ebuild 2434 BLAKE2B c485eae1cfe8edccf346d0e7093ef2eb4749ae7637026596e347d7bbbb28771f155102bb16e91b51b2b25c17860e7655f8a93f2e1792d2b3c004ce79174e9a2e SHA512 61335e7eabe368be03c8d43c3b3c0ae57600ecbeee5c3815148e08ef9cf277a124a41f4b3fd8cb4411cd3538a6d0a96ef6faaf10d32a67f6277577ffafede22f
MISC metadata.xml 351 BLAKE2B a5005814468014cf93d7f807b7f1c5d9252aecf20584267cdef61547d109727230f14c3f21297e202c4876e0534fac7d5ab86022c3741d582115c04b1bcf18f9 SHA512 14665ca256c368cbf80a08aaff18c005a25a4197eae82b559e934fbe6a3b17ef6f1fbd323621e38af5725f3e61ff750c72bb8fe650fb76eeed818070d411e3f6
diff --git a/games-fps/xonotic/files/xonotic-0.8.2-gcc-11.patch b/games-fps/xonotic/files/xonotic-0.8.2-gcc-11.patch
new file mode 100644
index 000000000000..f6a9569e0163
--- /dev/null
+++ b/games-fps/xonotic/files/xonotic-0.8.2-gcc-11.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/788616
+
+Attach alignment annotation to strict, not it's typedef alias.
+--- a/source/darkplaces/dpsoftrast.c
++++ b/source/darkplaces/dpsoftrast.c
+@@ -177,7 +177,7 @@ typedef ALIGN(struct DPSOFTRAST_State_Triangle_s
+ float w[3];
+ ALIGN(float attribs[DPSOFTRAST_ARRAY_TOTAL][3][4]);
+ }
+-DPSOFTRAST_State_Triangle);
++) DPSOFTRAST_State_Triangle;
+
+ #define DPSOFTRAST_CALCATTRIB(triangle, span, data, slope, arrayindex) { \
+ slope = _mm_load_ps((triangle)->attribs[arrayindex][0]); \
+@@ -209,7 +209,7 @@ typedef ALIGN(struct DPSOFTRAST_State_Span_s
+ int depthbase; // depthbuffer value at x (add depthslope*startx to get first pixel's depthbuffer value)
+ int depthslope; // depthbuffer value pixel delta
+ }
+-DPSOFTRAST_State_Span);
++) DPSOFTRAST_State_Span;
+
+ #define DPSOFTRAST_DRAW_MAXSPANS 1024
+ #define DPSOFTRAST_DRAW_MAXTRIANGLES 128
+@@ -300,7 +300,7 @@ typedef ALIGN(struct DPSOFTRAST_State_Thread_s
+ DPSOFTRAST_State_Triangle triangles[DPSOFTRAST_DRAW_MAXTRIANGLES];
+ unsigned char pixelmaskarray[DPSOFTRAST_DRAW_MAXSPANLENGTH+4]; // LordHavoc: padded to allow some termination bytes
+ }
+-DPSOFTRAST_State_Thread);
++) DPSOFTRAST_State_Thread;
+
+ typedef ALIGN(struct DPSOFTRAST_State_s
+ {
+@@ -358,7 +358,7 @@ typedef ALIGN(struct DPSOFTRAST_State_s
+
+ DPSOFTRAST_State_Command_Pool commandpool;
+ }
+-DPSOFTRAST_State);
++) DPSOFTRAST_State;
+
+ DPSOFTRAST_State dpsoftrast;
+
diff --git a/games-fps/xonotic/xonotic-0.8.2.ebuild b/games-fps/xonotic/xonotic-0.8.2.ebuild
index 41f326a13222..315c91ab3b4e 100644
--- a/games-fps/xonotic/xonotic-0.8.2.ebuild
+++ b/games-fps/xonotic/xonotic-0.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,6 +45,8 @@ DEPEND="${RDEPEND}
!dedicated? ( ${UIDEPEND} )"
BDEPEND="app-arch/unzip"
+PATCHES=("${FILESDIR}"/${P}-gcc-11.patch)
+
DOCS="Docs/*.txt"
CHECKREQS_DISK_BUILD="1200M"