summaryrefslogtreecommitdiff
path: root/games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild')
-rw-r--r--games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild b/games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild
new file mode 100644
index 000000000000..c14a79c5917f
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="UT2004 Community Bonus Pack 2 Volume 1 and 2"
+HOMEPAGE="https://liandri.beyondunreal.com/Unreal_Tournament_2004"
+SRC_URI="https://ut2004.ut-files.com/BonusPacks/cbp2-volume1_zip.zip
+ https://ut2004.ut-files.com/BonusPacks/cbp2-volume2_zip.zip"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="|| ( games-fps/ut2004 >=games-server/ut2004-ded-3369.3-r2 )
+ games-fps/ut2004-bonuspack-cbp1
+ games-fps/ut2004-bonuspack-mega"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # In ut2004-bonuspack-cbp1.
+ rm Music/Soeren.ogg || die
+
+ # In ut2004-bonuspack-mega.
+ rm Textures/Ty_RocketTextures.utx || die
+
+ # Useless file.
+ rm Help/Note.txt || die
+
+ cd Help || die
+ mv Readme.txt CBP2-Readme.txt || die
+ mv GERROIDREADME.txt DOM-CBP2-Gerroid.txt || die
+ mv Tydal.txt DM-CBP2-Tydal.txt || die
+}
+
+src_install() {
+ insinto /opt/ut2004
+ doins -r *
+}