summaryrefslogtreecommitdiff
path: root/games-fps/urbanterror
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /games-fps/urbanterror
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'games-fps/urbanterror')
-rw-r--r--games-fps/urbanterror/Manifest2
-rw-r--r--games-fps/urbanterror/urbanterror-4.3.2_p20180218.ebuild165
2 files changed, 167 insertions, 0 deletions
diff --git a/games-fps/urbanterror/Manifest b/games-fps/urbanterror/Manifest
index 093173b0addb..d443d44d6948 100644
--- a/games-fps/urbanterror/Manifest
+++ b/games-fps/urbanterror/Manifest
@@ -1,4 +1,6 @@
AUX urbanterror-4.3-fix-build_system.patch 1927 BLAKE2B 0a451f82e8ddfa8ca7c394dcce3af2d8e7952d3443820ace01f6754c78f4c0cd983a9b6cb31188d07c60d535cbb299a4e59b52ceabafed6516b679a2c0d96fa6 SHA512 a2ba20e40dc00d066d48399a00b53cfe2b23854f09be82fc5a986b93ca409559cda72bda50f7135ae6a01801cf8171784628d12a4b2440e63eaf68e4bfb3f1b2
DIST urbanterror-4.3.2_p20180216.tar.gz 10070633 BLAKE2B 38724030fc87e0800b9d6d1814efafc244584832e9fe78df060f2603040d72ee38602e300c3c765dfab4f803c9ae0e63116daf01601e571357a914509a6a8672 SHA512 88aa12a492f1d94e956ab4a8a1caeec259081043706b160d87fffe91b502399c0ddc34a4566463f336ae1b133cf250920ccd718647ac13d2eb48ddf9e6bb5517
+DIST urbanterror-4.3.2_p20180218.tar.gz 10069644 BLAKE2B ef711eee61f18cf2bc15974806d1b0b74c2a2094fbca5a07d70307289ae9eca53d2704b1cabc754c70984133761ff6daa55e00613668c0f0cc2b9a3ad5dac624 SHA512 e7f433b9971f5992efedee96123fe7c7665b6c7fa4a516df281e1f3635a9d56a653310e38f326a8e53640ed0a7d8e3bf6b44c08d70b8378d1ccdd75c05b31dc8
EBUILD urbanterror-4.3.2_p20180216.ebuild 4455 BLAKE2B ebe10bc58ea83cb2df524f70acc01fed7db0ad48fb787e80cecf229b074651c34651847b6b113f66ec1380f9e360b14c65f1829b360c46ed7a546176538993fe SHA512 ece81364bd7ef959236442d05741e648e4a9d1d7234e11abac6e4bad3a4bce27282bb94902048a2cd6a4d95626d34e3ed6737114f7b6db2a52face98d53f989c
+EBUILD urbanterror-4.3.2_p20180218.ebuild 4455 BLAKE2B b1b0a74c457fa0c0ec177924345f306967c9ab2162a1d04e10244b810b41946757ef96ac78d4f67619f616ceb0fa0bd0a9cb982231413b32300f08bd28a8ba0b SHA512 4fc61483c28dc7826678a747e1308615c2cc5555449b95ed099add2d6e704f7c8e4e8fd6918114aa5663b865b84beb37c8093cdf82476905a999aef7e7fc3951
MISC metadata.xml 1109 BLAKE2B 9e9f6a21667badafad0c007a2694a50ceaa467ce28fdc9b3f8838d58dd201f56b0b08c78d3285dfd53dd14db6c5ab26461cb400308abc920ce234048fdc48f8b SHA512 cb55a92c3c03065a17f71e5cfc8151a8c12acbc341389a14f96119960eb23c11613adaa8e9b552946d2db728121118a5130447c892d61a1a909b4dd8b94a5dcc
diff --git a/games-fps/urbanterror/urbanterror-4.3.2_p20180218.ebuild b/games-fps/urbanterror/urbanterror-4.3.2_p20180218.ebuild
new file mode 100644
index 000000000000..dddefea61118
--- /dev/null
+++ b/games-fps/urbanterror/urbanterror-4.3.2_p20180218.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eapi7-ver flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
+HOMEPAGE="http://urbanterror.info https://github.com/mickael9/ioq3"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mickael9/ioq3.git"
+ EGIT_BRANCH="urt"
+else
+ COMMIT_ID="d93f05de38a6cae60fbf0f073aace64b3adc7aaf"
+ SRC_URI="https://github.com/mickael9/ioq3/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ioq3-${COMMIT_ID}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+altgamma +client +curl debug mumble openal +opus server +skeetshootmod voip vorbis"
+REQUIRED_USE=" || ( client server )"
+
+DOCS=( ChangeLog README.md README.ioq3.md md4-readme.txt )
+PATCHES=( "${FILESDIR}"/${PN}-4.3-fix-build_system.patch )
+
+RDEPEND="
+ client? (
+ media-libs/libsdl2:=[X,sound,joystick,opengl,video]
+ mumble? ( media-sound/mumble:= )
+ openal? ( media-libs/openal:= )
+ opus? ( media-libs/opusfile:= )
+ vorbis? (
+ media-libs/libogg:=
+ media-libs/libvorbis:=
+ )
+ )
+ curl? ( net-misc/curl )
+ ~games-fps/urbanterror-data-4.3.2
+ sys-libs/zlib:=[minizip]
+ virtual/jpeg:0
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if use client; then
+ if ! use openal && ! use opus && ! use vorbis; then
+ ewarn
+ ewarn "No sound implementation selected. Enable 'openal', 'opus' or 'vorbis' USE flag to get sound!"
+ fi
+ fi
+}
+
+src_configure() {
+ default
+
+ tc-export CC
+}
+
+src_compile() {
+ # Workaround for used zlib macro, which got renamed in Gentoo
+ # wrt bug #449510
+ append-cppflags "-DOF=_Z_OF"
+
+ local my_arch=$(usex amd64 "x86_64" "i386")
+
+ emake \
+ ARCH=${my_arch} \
+ DEFAULT_BASEDIR="/usr/share/urbanterror" \
+ BUILD_CLIENT=$(usex "client" 1 0) \
+ BUILD_SERVER=$(usex "server" 1 0) \
+ BUILD_BASEGAME=1 \
+ BUILD_MISSIONPACK=0 \
+ BUILD_GAME_SO=0 \
+ BUILD_GAME_QVM=0 \
+ BUILD_STANDALONE=1 \
+ SERVERBIN="Quake3-UrT-Ded" \
+ CLIENTBIN="Quake3-UrT" \
+ USE_RENDERER_DLOPEN=0 \
+ USE_YACC=0 \
+ BASEGAME="q3ut4"\
+ BASEGAME_CFLAGS="${CFLAGS}" \
+ USE_OPENAL=$(usex "openal" 1 0) \
+ USE_OPENAL_DLOPEN=$(usex "openal" 1 0) \
+ USE_CURL=$(usex "curl" 1 0) \
+ USE_CURL_DLOPEN=$(usex "curl" 1 0) \
+ USE_CODEC_VORBIS=$(usex "vorbis" 1 0) \
+ USE_CODEC_OPUS=$(usex "opus" 1 0) \
+ USE_MUMBLE=$(usex "mumble" 1 0) \
+ USE_SKEETMOD=$(usex "skeetshootmod" 1 0) \
+ USE_VOIP=$(usex "mumble" 1 0) \
+ USE_INTERNAL_LIBS=0 \
+ USE_LOCAL_HEADERS=0 \
+ USE_ALTGAMMA=$(usex "altgamma" 1 0)
+}
+
+src_install() {
+ local my_arch=$(usex amd64 "x86_64" "i386")
+
+ if use client; then
+ newbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT.${my_arch} ${PN}
+ # Shooter as defined in https://specifications.freedesktop.org/menu-spec/latest/apas02.html
+ make_desktop_entry ${PN} "UrbanTerror" ${PN}
+ fi
+
+ if use server && ! use client; then
+ # dedicated server only
+ newbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT-Ded.${my_arch} ${PN}-ded
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use client && xdg_desktop_database_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # ^this is a new installation, so:
+ if use openal; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta s_useopenal \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for openal to work."
+ fi
+
+ if use altgamma; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta r_altgamma \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for altgamma to work."
+ elog "Be aware that altgamme works on a global scale, so external"
+ elog "applications like redshift can cause trouble. Disabling"
+ elog "these while playing is a usable workaround."
+ fi
+
+ if ! use altgamma; then
+ elog ""
+ elog "If you are using a modesetting graphics driver you might"
+ elog "consider setting USE=\"altgamma\"."
+ elog "For details take a look at:"
+ elog "https://bugs.freedesktop.org/show_bug.cgi?id=27222"
+ fi
+
+ if ! use client; then
+ elog ""
+ elog "You disabled client support. You won't be able to connect"
+ elog "to any servers and play. If you want to do so, enable"
+ elog "USE=\"client\"."
+ fi
+
+ if use skeetshootmod; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta sv_skeetshoot \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg to use the skeetshoot mod."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ use client && xdg_desktop_database_update
+}