summaryrefslogtreecommitdiff
path: root/games-fps/urbanterror
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /games-fps/urbanterror
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'games-fps/urbanterror')
-rw-r--r--games-fps/urbanterror/Manifest2
-rw-r--r--games-fps/urbanterror/urbanterror-4.3.2_p20180103.ebuild163
2 files changed, 165 insertions, 0 deletions
diff --git a/games-fps/urbanterror/Manifest b/games-fps/urbanterror/Manifest
index db89d323d5fe..cd133ef6b398 100644
--- a/games-fps/urbanterror/Manifest
+++ b/games-fps/urbanterror/Manifest
@@ -1,4 +1,6 @@
AUX urbanterror-4.3-fix-build_system.patch 1927 BLAKE2B 0a451f82e8ddfa8ca7c394dcce3af2d8e7952d3443820ace01f6754c78f4c0cd983a9b6cb31188d07c60d535cbb299a4e59b52ceabafed6516b679a2c0d96fa6 SHA512 a2ba20e40dc00d066d48399a00b53cfe2b23854f09be82fc5a986b93ca409559cda72bda50f7135ae6a01801cf8171784628d12a4b2440e63eaf68e4bfb3f1b2
DIST urbanterror-4.3.2_p20171208.tar.gz 10072373 BLAKE2B 9934317fb649e652628639f9ea35cdaa0466363b52ea7325198aaaa6360e07e41ec590342cd35fa1bb352ff35ba5994e9152caaf308aa0e0d8c3c2d94ea36a91 SHA512 1dd3affa8fe23f8cca4ee3c90a8d6fc86f5df2122e0121d57263be745d0af13f52cb47802636a22cb09b1bae8a100b491dc8cc0c81c413dd9cbb2ad29a69039a
+DIST urbanterror-4.3.2_p20180103.tar.gz 10071977 BLAKE2B c204b0f3eee19d4c426df60827a6e9651e93e71445cad73a5b0133e1ec794c752668df9c3412d7a9b1f1599f33923873afe6cb9b2472a14fea6adc52cb599bed SHA512 8bfba46580b16f89e6cea5ffbb1f81ad91ece63e1058928d84778e4ea2cee621d3fae7131801f5bb35e9267763e824521dfc0191f512d334d7f07a3b970be768
EBUILD urbanterror-4.3.2_p20171208.ebuild 4358 BLAKE2B ca6e357102f3fcb87bb9bf4d517803668e9126ec49831dfdfb940a07f1ccc8a40ad82332a99afe76887bbae06f1b4c66e64d959028c50c4dcf4da6b423f44b53 SHA512 59346dae8f074fc91ad2c52e1599ce6ece11f10021f6cea54eb18115608118483bc3e86d28f04e85ac76718169b1129f2ffb0146680f242996ce19a5ecc21045
+EBUILD urbanterror-4.3.2_p20180103.ebuild 4358 BLAKE2B b36abeed3e89d1caef488f3d52882fa4a741c08cbe3a4c1d58edaba55b4a9e03eaddc9d178822bc48e304399de7c4d304be91f92c8b403cbe40d28abc87fb86f SHA512 3d38e430329f2072362174dd6596d9c9e3596dee719db6e5f0d023c0c21f37959509e08aa3ff6efd2cb3f138b2f18158ccc83cc11806d0cfc75542055051c1de
MISC metadata.xml 1109 BLAKE2B 9e9f6a21667badafad0c007a2694a50ceaa467ce28fdc9b3f8838d58dd201f56b0b08c78d3285dfd53dd14db6c5ab26461cb400308abc920ce234048fdc48f8b SHA512 cb55a92c3c03065a17f71e5cfc8151a8c12acbc341389a14f96119960eb23c11613adaa8e9b552946d2db728121118a5130447c892d61a1a909b4dd8b94a5dcc
diff --git a/games-fps/urbanterror/urbanterror-4.3.2_p20180103.ebuild b/games-fps/urbanterror/urbanterror-4.3.2_p20180103.ebuild
new file mode 100644
index 000000000000..27cb31a404f2
--- /dev/null
+++ b/games-fps/urbanterror/urbanterror-4.3.2_p20180103.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eapi7-ver flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
+HOMEPAGE="http://urbanterror.info https://github.com/mickael9/ioq3"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mickael9/ioq3.git"
+ EGIT_BRANCH="urt"
+else
+ COMMIT_ID="36ac852bc7ecfb3b847b021305b14a363f7c7f9c"
+ SRC_URI="https://github.com/mickael9/ioq3/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ioq3-${COMMIT_ID}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+altgamma +client +curl debug mumble openal +opus server +skeetshootmod voip vorbis"
+REQUIRED_USE=" || ( client server )"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.3-fix-build_system.patch )
+RDEPEND="
+ client? (
+ media-libs/libsdl2:=[X,sound,joystick,opengl,video]
+ mumble? ( media-sound/mumble:= )
+ openal? ( media-libs/openal:= )
+ opus? ( media-libs/opusfile:= )
+ vorbis? (
+ media-libs/libogg:=
+ media-libs/libvorbis:=
+ )
+ )
+ curl? ( net-misc/curl )
+ ~games-fps/urbanterror-data-4.3.2
+ sys-libs/zlib:=[minizip]
+ virtual/jpeg:0
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if use client; then
+ if ! use openal && ! use opus && ! use vorbis; then
+ ewarn
+ ewarn "No sound implementation selected. Enable 'openal', 'opus' or 'vorbis' USE flag to get sound!"
+ fi
+ fi
+}
+
+src_configure() {
+ default
+
+ tc-export CC
+}
+
+src_compile() {
+ # Workaround for used zlib macro, which got renamed in Gentoo
+ # wrt bug #449510
+ append-cppflags "-DOF=_Z_OF"
+
+ local my_arch=$(usex amd64 "x86_64" "i386")
+
+ emake \
+ ARCH=${my_arch} \
+ DEFAULT_BASEDIR="/usr/share/urbanterror" \
+ BUILD_CLIENT=$(usex "client" 1 0) \
+ BUILD_SERVER=$(usex "server" 1 0) \
+ BUILD_BASEGAME=1 \
+ BUILD_MISSIONPACK=0 \
+ BUILD_GAME_SO=0 \
+ BUILD_GAME_QVM=0 \
+ BUILD_STANDALONE=1 \
+ SERVERBIN="Quake3-UrT-Ded" \
+ CLIENTBIN="Quake3-UrT" \
+ USE_RENDERER_DLOPEN=0 \
+ USE_YACC=0 \
+ BASEGAME="q3ut4"\
+ BASEGAME_CFLAGS="${CFLAGS}" \
+ USE_OPENAL=$(usex "openal" 1 0) \
+ USE_OPENAL_DLOPEN=$(usex "openal" 1 0) \
+ USE_CURL=$(usex "curl" 1 0) \
+ USE_CURL_DLOPEN=$(usex "curl" 1 0) \
+ USE_CODEC_VORBIS=$(usex "vorbis" 1 0) \
+ USE_CODEC_OPUS=$(usex "opus" 1 0) \
+ USE_MUMBLE=$(usex "mumble" 1 0) \
+ USE_SKEETMOD=$(usex "skeetshootmod" 1 0) \
+ USE_VOIP=$(usex "mumble" 1 0) \
+ USE_INTERNAL_LIBS=0 \
+ USE_LOCAL_HEADERS=0 \
+ USE_ALTGAMMA=$(usex "altgamma" 1 0)
+}
+
+src_install() {
+ local my_arch=$(usex amd64 "x86_64" "i386")
+ # docs from ioq3, not from UrbanTerror ZIP file
+ dodoc ChangeLog README.md README.ioq3.md md4-readme.txt
+
+ if use client; then
+ newbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT.${my_arch} ${PN}
+ # Shooter as defined in https://specifications.freedesktop.org/menu-spec/latest/apas02.html
+ make_desktop_entry ${PN} "UrbanTerror" ${PN}
+ fi
+
+ if use server && ! use client; then
+ # dedicated server only
+ newbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT-Ded.${my_arch} ${PN}-ded
+ fi
+}
+
+pkg_postinst() {
+ use client && xdg_desktop_database_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ if use openal; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta s_useopenal \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for openal to work."
+ fi
+
+ if use altgamma; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta r_altgamma \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for altgamma to work."
+ fi
+
+ if ! use altgamma; then
+ elog ""
+ elog "If you are using a modesetting graphics driver you might"
+ elog "consider setting USE=\"altgamma\"."
+ elog "For details take a look at:"
+ elog "https://bugs.freedesktop.org/show_bug.cgi?id=27222"
+ fi
+
+ if ! use client; then
+ elog ""
+ elog "You disabled client support. You won't be able to connect"
+ elog "to any servers and play. If you want to do so, enable"
+ elog "USE=\"client\"."
+ fi
+ fi
+
+ if ver_test -ge 4.3.2_p20171105; then
+ # Yippee, new features!
+ if use skeetshootmod; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta sv_skeetshoot \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg to use the skeetshoot mod."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ use client && xdg_desktop_database_update
+}