summaryrefslogtreecommitdiff
path: root/games-fps/urbanterror/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /games-fps/urbanterror/files
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'games-fps/urbanterror/files')
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch32
1 files changed, 29 insertions, 3 deletions
diff --git a/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch b/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch
index b7a24a1b6e94..e0c4eb27f539 100644
--- a/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch
+++ b/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch
@@ -4,8 +4,10 @@ Date: Fri Nov 17 20:30:00 2017 +0100
Respect CFLAGS, CPPFLAGS etc. This patch is inspired
by hasufell’s patch.
---- a/Makefile 2017-03-31 11:08:58.419210817 +0200
-+++ b/Makefile 2017-11-17 20:30:00.000000000 +0100
+Edit 2018-03-19: Now with server support!
+
+--- a/Makefile 2018-03-19 11:00:00.000000000 +0100
++++ b/Makefile 2018-03-19 11:00:00.000000001 +0100
@@ -223,7 +223,7 @@
ifndef USE_ALTGAMMA
# Clearskies - X11-based gamma for Linux
@@ -61,7 +63,7 @@ by hasufell’s patch.
HAVE_VM_COMPILED=true
endif
ifeq ($(ARCH),armv7l)
-@@ -1124,7 +1123,7 @@
+@@ -1130,12 +1129,12 @@
define DO_CC
$(echo_cmd) "CC $<"
@@ -70,4 +72,28 @@ by hasufell’s patch.
endef
define DO_REF_CC
+ $(echo_cmd) "REF_CC $<"
+-$(Q)$(CC) $(SHLIBCFLAGS) $(CFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
++$(Q)$(CC) $(SHLIBCFLAGS) $(CFLAGS) $(CPPFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
+ endef
+
+ define DO_REF_STR
+@@ -1148,7 +1147,7 @@
+
+ define DO_BOT_CC
+ $(echo_cmd) "BOT_CC $<"
+-$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(BOTCFLAGS) $(OPTIMIZE) -DBOTLIB -o $@ -c $<
++$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(CPPFLAGS) $(BOTCFLAGS) $(OPTIMIZE) -DBOTLIB -o $@ -c $<
+ endef
+
+ ifeq ($(GENERATE_DEPENDENCIES),1)
+@@ -1162,7 +1161,7 @@
+
+ define DO_DED_CC
+ $(echo_cmd) "DED_CC $<"
+-$(Q)$(CC) $(NOTSHLIBCFLAGS) -DDEDICATED $(CFLAGS) $(SERVER_CFLAGS) $(OPTIMIZE) -o $@ -c $<
++$(Q)$(CC) $(NOTSHLIBCFLAGS) -DDEDICATED $(CFLAGS) $(CPPFLAGS) $(SERVER_CFLAGS) $(OPTIMIZE) -o $@ -c $<
+ endef
+
+ define DO_WINDRES