summaryrefslogtreecommitdiff
path: root/games-fps/urbanterror/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/urbanterror/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/urbanterror/files')
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch99
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.3.3_p20180218-fix-loop.patch59
2 files changed, 158 insertions, 0 deletions
diff --git a/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch b/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch
new file mode 100644
index 000000000000..e0c4eb27f539
--- /dev/null
+++ b/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch
@@ -0,0 +1,99 @@
+Author: Nils Freydank <holgersson@posteo.de>
+Date: Fri Nov 17 20:30:00 2017 +0100
+
+Respect CFLAGS, CPPFLAGS etc. This patch is inspired
+by hasufell’s patch.
+
+Edit 2018-03-19: Now with server support!
+
+--- a/Makefile 2018-03-19 11:00:00.000000000 +0100
++++ b/Makefile 2018-03-19 11:00:00.000000001 +0100
+@@ -223,7 +223,7 @@
+ ifndef USE_ALTGAMMA
+ # Clearskies - X11-based gamma for Linux
+ USE_ALTGAMMA=1
+-endif
++ endif
+
+ ifndef USE_SKEETMOD
+ USE_SKEETMOD=0
+@@ -306,34 +306,33 @@
+ CLIENT_EXTRA_FILES=
+
+ ifneq (,$(findstring "$(PLATFORM)", "linux" "gnu_kfreebsd" "kfreebsd-gnu" "gnu"))
+- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
+- -pipe -DUSE_ICON -DARCH_STRING=\\\"$(ARCH)\\\"
++ BASE_CFLAGS = -DUSE_ICON -DARCH_STRING=\\\"$(ARCH)\\\"
+ CLIENT_CFLAGS += $(SDL_CFLAGS)
+
+- OPTIMIZEVM = -O3
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+
+ ifeq ($(ARCH),x86_64)
+- OPTIMIZEVM = -O3
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+ HAVE_VM_COMPILED = true
+ else
+ ifeq ($(ARCH),x86)
+- OPTIMIZEVM = -O3 -march=i586
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+ HAVE_VM_COMPILED=true
+ else
+ ifeq ($(ARCH),ppc)
+- BASE_CFLAGS += -maltivec
++ BASE_CFLAGS +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),ppc64)
+- BASE_CFLAGS += -maltivec
++ BASE_CFLAGS +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),sparc)
+- OPTIMIZE += -mtune=ultrasparc3 -mv8plus
+- OPTIMIZEVM += -mtune=ultrasparc3 -mv8plus
++ OPTIMIZE +=
++ OPTIMIZEVM +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),armv7l)
+@@ -1130,12 +1129,12 @@
+
+ define DO_CC
+ $(echo_cmd) "CC $<"
+-$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
++$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(CPPFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
+ endef
+
+ define DO_REF_CC
+ $(echo_cmd) "REF_CC $<"
+-$(Q)$(CC) $(SHLIBCFLAGS) $(CFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
++$(Q)$(CC) $(SHLIBCFLAGS) $(CFLAGS) $(CPPFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
+ endef
+
+ define DO_REF_STR
+@@ -1148,7 +1147,7 @@
+
+ define DO_BOT_CC
+ $(echo_cmd) "BOT_CC $<"
+-$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(BOTCFLAGS) $(OPTIMIZE) -DBOTLIB -o $@ -c $<
++$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(CPPFLAGS) $(BOTCFLAGS) $(OPTIMIZE) -DBOTLIB -o $@ -c $<
+ endef
+
+ ifeq ($(GENERATE_DEPENDENCIES),1)
+@@ -1162,7 +1161,7 @@
+
+ define DO_DED_CC
+ $(echo_cmd) "DED_CC $<"
+-$(Q)$(CC) $(NOTSHLIBCFLAGS) -DDEDICATED $(CFLAGS) $(SERVER_CFLAGS) $(OPTIMIZE) -o $@ -c $<
++$(Q)$(CC) $(NOTSHLIBCFLAGS) -DDEDICATED $(CFLAGS) $(CPPFLAGS) $(SERVER_CFLAGS) $(OPTIMIZE) -o $@ -c $<
+ endef
+
+ define DO_WINDRES
+
diff --git a/games-fps/urbanterror/files/urbanterror-4.3.3_p20180218-fix-loop.patch b/games-fps/urbanterror/files/urbanterror-4.3.3_p20180218-fix-loop.patch
new file mode 100644
index 000000000000..c34ebe84cedf
--- /dev/null
+++ b/games-fps/urbanterror/files/urbanterror-4.3.3_p20180218-fix-loop.patch
@@ -0,0 +1,59 @@
+Author: Nils Freydank <holgersson@posteo.de>
+Date: Wed Mar 14 21:00:00 2017 +0100
+
+Imported patch written by Tom Murphy via github.com:
+
+https://github.com/ioquake/ioq3/pull/356
+
+diff --git a/code/sys/con_tty.c b/code/sys/con_tty.c
+index 2c2b595cf..58f178ade 100644
+--- a/code/sys/con_tty.c
++++ b/code/sys/con_tty.c
+@@ -73,20 +73,6 @@ static int hist_current = -1, hist_count = 0;
+ #define TTY_CONSOLE_PROMPT "]"
+ #endif
+
+-/*
+-==================
+-CON_FlushIn
+-
+-Flush stdin, I suspect some terminals are sending a LOT of shit
+-FIXME relevant?
+-==================
+-*/
+-static void CON_FlushIn( void )
+-{
+- char key;
+- while (read(STDIN_FILENO, &key, 1)!=-1);
+-}
+-
+ /*
+ ==================
+ CON_Back
+@@ -441,7 +427,7 @@ char *CON_Input( void )
+ TTY_con = *history;
+ CON_Show();
+ }
+- CON_FlushIn();
++ tcflush(STDIN_FILENO, TCIFLUSH);
+ return NULL;
+ break;
+ case 'B':
+@@ -455,7 +441,7 @@ char *CON_Input( void )
+ Field_Clear(&TTY_con);
+ }
+ CON_Show();
+- CON_FlushIn();
++ tcflush(STDIN_FILENO, TCIFLUSH);
+ return NULL;
+ break;
+ case 'C':
+@@ -467,7 +453,7 @@ char *CON_Input( void )
+ }
+ }
+ Com_DPrintf("droping ISCTL sequence: %d, TTY_erase: %d\n", key, TTY_erase);
+- CON_FlushIn();
++ tcflush(STDIN_FILENO, TCIFLUSH);
+ return NULL;
+ }
+ if (TTY_con.cursor >= sizeof(text) - 1)