summaryrefslogtreecommitdiff
path: root/games-fps/urbanterror/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /games-fps/urbanterror/files
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'games-fps/urbanterror/files')
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.3.3_p20180218-fix-loop.patch59
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.3.4_p20180708-fix-build_system.patch (renamed from games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch)35
2 files changed, 15 insertions, 79 deletions
diff --git a/games-fps/urbanterror/files/urbanterror-4.3.3_p20180218-fix-loop.patch b/games-fps/urbanterror/files/urbanterror-4.3.3_p20180218-fix-loop.patch
deleted file mode 100644
index c34ebe84cedf..000000000000
--- a/games-fps/urbanterror/files/urbanterror-4.3.3_p20180218-fix-loop.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-Author: Nils Freydank <holgersson@posteo.de>
-Date: Wed Mar 14 21:00:00 2017 +0100
-
-Imported patch written by Tom Murphy via github.com:
-
-https://github.com/ioquake/ioq3/pull/356
-
-diff --git a/code/sys/con_tty.c b/code/sys/con_tty.c
-index 2c2b595cf..58f178ade 100644
---- a/code/sys/con_tty.c
-+++ b/code/sys/con_tty.c
-@@ -73,20 +73,6 @@ static int hist_current = -1, hist_count = 0;
- #define TTY_CONSOLE_PROMPT "]"
- #endif
-
--/*
--==================
--CON_FlushIn
--
--Flush stdin, I suspect some terminals are sending a LOT of shit
--FIXME relevant?
--==================
--*/
--static void CON_FlushIn( void )
--{
-- char key;
-- while (read(STDIN_FILENO, &key, 1)!=-1);
--}
--
- /*
- ==================
- CON_Back
-@@ -441,7 +427,7 @@ char *CON_Input( void )
- TTY_con = *history;
- CON_Show();
- }
-- CON_FlushIn();
-+ tcflush(STDIN_FILENO, TCIFLUSH);
- return NULL;
- break;
- case 'B':
-@@ -455,7 +441,7 @@ char *CON_Input( void )
- Field_Clear(&TTY_con);
- }
- CON_Show();
-- CON_FlushIn();
-+ tcflush(STDIN_FILENO, TCIFLUSH);
- return NULL;
- break;
- case 'C':
-@@ -467,7 +453,7 @@ char *CON_Input( void )
- }
- }
- Com_DPrintf("droping ISCTL sequence: %d, TTY_erase: %d\n", key, TTY_erase);
-- CON_FlushIn();
-+ tcflush(STDIN_FILENO, TCIFLUSH);
- return NULL;
- }
- if (TTY_con.cursor >= sizeof(text) - 1)
diff --git a/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch b/games-fps/urbanterror/files/urbanterror-4.3.4_p20180708-fix-build_system.patch
index e0c4eb27f539..fddd8df5bf37 100644
--- a/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch
+++ b/games-fps/urbanterror/files/urbanterror-4.3.4_p20180708-fix-build_system.patch
@@ -5,19 +5,11 @@ Respect CFLAGS, CPPFLAGS etc. This patch is inspired
by hasufell’s patch.
Edit 2018-03-19: Now with server support!
+Edit 2018-09-01: Update to take Makefile changes into account.
---- a/Makefile 2018-03-19 11:00:00.000000000 +0100
-+++ b/Makefile 2018-03-19 11:00:00.000000001 +0100
-@@ -223,7 +223,7 @@
- ifndef USE_ALTGAMMA
- # Clearskies - X11-based gamma for Linux
- USE_ALTGAMMA=1
--endif
-+ endif
-
- ifndef USE_SKEETMOD
- USE_SKEETMOD=0
-@@ -306,34 +306,33 @@
+--- a/Makefile 2018-07-08 11:00:00.000000000 +0200
++++ b/Makefile 2018-09-01 11:00:00.000000001 +0200
+@@ -308,34 +308,33 @@
CLIENT_EXTRA_FILES=
ifneq (,$(findstring "$(PLATFORM)", "linux" "gnu_kfreebsd" "kfreebsd-gnu" "gnu"))
@@ -46,13 +38,13 @@ Edit 2018-03-19: Now with server support!
HAVE_VM_COMPILED=true
else
ifeq ($(ARCH),ppc)
-- BASE_CFLAGS += -maltivec
-+ BASE_CFLAGS +=
+- ALTIVEC_CFLAGS = -maltivec
++ ALTIVEC_CFLAGS =
HAVE_VM_COMPILED=true
endif
ifeq ($(ARCH),ppc64)
-- BASE_CFLAGS += -maltivec
-+ BASE_CFLAGS +=
+- ALTIVEC_CFLAGS = -maltivec
++ ALTIVEC_CFLAGS =
HAVE_VM_COMPILED=true
endif
ifeq ($(ARCH),sparc)
@@ -63,7 +55,7 @@ Edit 2018-03-19: Now with server support!
HAVE_VM_COMPILED=true
endif
ifeq ($(ARCH),armv7l)
-@@ -1130,12 +1129,12 @@
+@@ -1143,7 +1142,7 @@
define DO_CC
$(echo_cmd) "CC $<"
@@ -71,14 +63,17 @@ Edit 2018-03-19: Now with server support!
+$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(CPPFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
endef
+ define DO_CC_ALTIVEC
+@@ -1153,7 +1152,7 @@
+
define DO_REF_CC
$(echo_cmd) "REF_CC $<"
-$(Q)$(CC) $(SHLIBCFLAGS) $(CFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
+$(Q)$(CC) $(SHLIBCFLAGS) $(CFLAGS) $(CPPFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
endef
- define DO_REF_STR
-@@ -1148,7 +1147,7 @@
+ define DO_REF_CC_ALTIVEC
+@@ -1171,7 +1170,7 @@
define DO_BOT_CC
$(echo_cmd) "BOT_CC $<"
@@ -87,7 +82,7 @@ Edit 2018-03-19: Now with server support!
endef
ifeq ($(GENERATE_DEPENDENCIES),1)
-@@ -1162,7 +1161,7 @@
+@@ -1185,7 +1184,7 @@
define DO_DED_CC
$(echo_cmd) "DED_CC $<"