summaryrefslogtreecommitdiff
path: root/games-fps/unreal-tournament
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/unreal-tournament
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/unreal-tournament')
-rw-r--r--games-fps/unreal-tournament/Manifest4
-rw-r--r--games-fps/unreal-tournament/metadata.xml33
-rw-r--r--games-fps/unreal-tournament/unreal-tournament-451.ebuild120
3 files changed, 157 insertions, 0 deletions
diff --git a/games-fps/unreal-tournament/Manifest b/games-fps/unreal-tournament/Manifest
new file mode 100644
index 000000000000..3fe2e03eef82
--- /dev/null
+++ b/games-fps/unreal-tournament/Manifest
@@ -0,0 +1,4 @@
+DIST UTPGPatch451.tar.bz2 3064473 BLAKE2B 43fd1573f714b59d7069b8fbd30bd822024971277dd863793a3f2c05d1a973904fd9ef6f22f8efcec0389cdb36ec6abb6c8f3eb5b700eba29aa6b5284d433cb4 SHA512 d11ecb3e60e8bba0288be0a4860acb563c277e75ce30a749de04673219d484b7a8c7e6207bc582872df33db684658dc1a15235b9d79ceb98fcd2ad1410982423
+DIST ut-install-436.run 6225010 BLAKE2B 107a4991db59e1ff800bf2a1e002f0e56f5415b14a936ced149ace57c5359f10b75d0c2506e5fe40dfb2ca28b068cf225b35dda5fae0af84864df4edb560e05a SHA512 cfdeb9f345daef4b81acadfa24d711477ba208dffd50716087d034df2dc1eb0ac5bb03570f4f1701b3c4d46b8f954e6d23dde36fc20dafdc114e68730a1fc932
+EBUILD unreal-tournament-451.ebuild 3677 BLAKE2B dce626054b14a503f585366d9190d955c2c9f9c128c9f884b58516ce14dbd924697bdac516f4557d8995d37ed75737e08525d325fb1976e9a28f93459b85f35a SHA512 c359b3a8219463a984a534b0458ab27cb0f81ba4d27819c8a71f0bacea81b9b3bf566a718f7b0feefb8ab159b9f5a3b0e979e54bfb8158b2ae6ce6e1063a9cb8
+MISC metadata.xml 1596 BLAKE2B a6b8460fe469bfef5c7a56526d5387532de532da41eb57c06b20b6319bdf4c5c28596f86c151f27a8f9bcb76a7d74019371b8be2d26f0b7802c92bdd4f575953 SHA512 d9250b157b97a1f21aa905fae2ef62e2b06573e7cb168835ae904278e41e7103166d817a2ce266b8969b912c156685c1b6e6e0b976a7c933f6811e8b9ec20270
diff --git a/games-fps/unreal-tournament/metadata.xml b/games-fps/unreal-tournament/metadata.xml
new file mode 100644
index 000000000000..d6fc95339e12
--- /dev/null
+++ b/games-fps/unreal-tournament/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+In the single player mode, the player squares off
+against computer controlled Bots in all the game modes
+through a tournament ladder with increasing difficulty.
+Thanks to Epic's unmatched AI coding wizardry, Unreal
+Tournament's Bots are more life like than any
+computer-controlled characters to date. They understand
+each game's unique rules. They have a firm handle on all
+the different weapons at their disposal and how best to
+use them. They can swim, use elevators, climb stairs,
+and put on Toxin suits if they have to. If they're on
+the player's team, they can take orders to attack,
+defend or freelance.
+
+Unreal Tournament's bread and butter is the online multiplayer
+mode. Squaring off against other combatants from around the world, or on
+the other end of a LAN connection, provides some of the most thrilling and
+tense battles seen on a PC. Unreal Tournament's unparalleled networking
+code makes it as easy to play the game against anyone, anytime. If the
+host server has unique content -- like custom skins or maps -- UT
+will automatically download and install that content in REAL TIME, as the
+game is connecting. And thanks to Epic Games' amazing work on Unreal
+Tournament's network play, you can be sure that even a 33.6K modem can get
+a silky smooth connection to the server.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/unreal-tournament/unreal-tournament-451.ebuild b/games-fps/unreal-tournament/unreal-tournament-451.ebuild
new file mode 100644
index 000000000000..d5b0e7f88342
--- /dev/null
+++ b/games-fps/unreal-tournament/unreal-tournament-451.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils unpacker cdrom games
+
+DESCRIPTION="Futuristic FPS"
+HOMEPAGE="http://www.oldunreal.com/"
+SRC_URI="http://www.ut-files.com/Patches/ut-install-436.run
+ http://www.ut-files.com/Patches/utpgpatch${PV}.tar.bz2 -> UTPGPatch${PV}.tar.bz2"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="3dfx opengl"
+RESTRICT="mirror bindist"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ opengl? ( virtual/opengl[abi_x86_32(-)] )
+"
+DEPEND="${RDEPEND}
+ !games-fps/unreal-tournament-goty
+"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cdrom_get_cds System/
+ unpack_makeself ut-install-436.run
+ mkdir UTPG && cd UTPG
+ unpack UTPGPatch${PV}.tar.bz2
+ rm checkfiles.sh patch.md5
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local Ddir=${D}/${dir}
+ dodir "${dir}"
+
+ # Help, Logs, Music, Textures, Web
+ cp -rf "${CDROM_ROOT}"/{Help,Logs,Music,Textures,Web} "${Ddir}/" || die "copy Help, Logs, Music, Textures, Web"
+ tar -zxf Credits.tar.gz -C "${Ddir}" || die "extract credits texture"
+ # NetGamesUSA.com
+ tar -zxf NetGamesUSA.com.tar.gz -C "${Ddir}/" || die "extract NetGamesUSA.com"
+ # Sounds
+ dodir "${dir}"/Sounds
+ cp -rf "${CDROM_ROOT}"/Sounds/*.uax "${Ddir}"/Sounds/ || die "copy Sounds"
+
+ # System
+ if use 3dfx ; then
+ tar -zxf Glide.ini.tar.gz -C "${Ddir}" || die "install Glide ini"
+ else
+ tar -zxf OpenGL.ini.tar.gz -C "${Ddir}" || die "install OpenGL ini"
+ fi
+ tar -zxf data.tar.gz -C "${Ddir}" || die "extract System data"
+ cp "${CDROM_ROOT}"/System/*.u "${Ddir}"/System/ || die "copy System data"
+
+ # the most important things, ucc & ut :)
+ exeinto "${dir}"
+ doexe bin/x86/{ucc,ut} || die "install ucc/ut"
+ sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
+
+ # install a few random files
+ insinto "${dir}"
+ doins README icon.{bmp,xpm} || die "installing random files"
+
+ # install a menu item (closes bug #27542)
+ newicon icon.xpm ut.xpm
+ make_desktop_entry ut "Unreal Tournament" ut
+
+ # first apply any patch remaints loki has for us
+ cd setup.data
+ ./bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null
+ cd "${S}"
+
+ # finally, unleash the UTPG patch
+ cp -rf UTPG/* "${Ddir}/"
+ # fix a small bug until next official release
+ sed -i -e "/^LoadClassMismatch/s:%s.%s:%s:" "${ED}/${dir}"/System/Core.int || die
+
+ # now we uncompress the maps (GOTY edition installs maps as .uz)
+ einfo "Uncompressing Maps ... this may take some time"
+ dodir "${dir}"/Maps
+ cd "${Ddir}"
+ export HOME=${T}
+ export UT_DATA_PATH=${Ddir}/System
+ for f in $(find "${CDROM_ROOT}"/Maps/ -name '*.uz' -printf '%f ') ; do
+ ./ucc decompress "${CDROM_ROOT}"/Maps/"${f}" -nohomedir || die "uncompressing map ${f}"
+ mv "System/${f:0:${#f}-3}" Maps/ || die "copy map ${f}"
+ done
+ cp -rf "${CDROM_ROOT}"/Maps/*.unr "${Ddir}"/Maps/ # some cd's have uncompressed maps ??
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find "${Ddir}" -exec touch '{}' +
+
+ # export some symlinks so ppl can run
+ dodir "${GAMES_BINDIR}"
+ dosym "${dir}/ut" "${GAMES_BINDIR}/ut"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "You might want to install the bonus packs too."
+ elog "Many servers on the internet use them, and the"
+ elog "majority of players do too."
+ elog
+ elog "Just run: emerge unreal-tournament-bonuspacks"
+ echo
+}