summaryrefslogtreecommitdiff
path: root/games-fps/unreal-tournament-bonuspacks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/unreal-tournament-bonuspacks
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/unreal-tournament-bonuspacks')
-rw-r--r--games-fps/unreal-tournament-bonuspacks/Manifest3
-rw-r--r--games-fps/unreal-tournament-bonuspacks/metadata.xml8
-rw-r--r--games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild46
3 files changed, 57 insertions, 0 deletions
diff --git a/games-fps/unreal-tournament-bonuspacks/Manifest b/games-fps/unreal-tournament-bonuspacks/Manifest
new file mode 100644
index 000000000000..685d43ddf105
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/Manifest
@@ -0,0 +1,3 @@
+DIST UTBonusPack4.zip 14916708 BLAKE2B da4b2db40e2a360fe90c8a67d58304639d072cbc9f857488b25b3710c84689ea753fb5e7d2a178e825515d687c0bf7821842056fa15110f902651acd42584cd1 SHA512 4abc29b108926aebce872a0c8257f97604265cdc837b2e46443ee8cf98adfcba69b6b7ab2bd2379723c11301ef2bf60298ab075a6befe5eeed6d8526f3f653b0
+EBUILD unreal-tournament-bonuspacks-436.ebuild 1135 BLAKE2B d86ddb0fad98b433f7167c088ff6c66b60985e358daaaa04d82f3164dc2bf05153ca4e7a04bc3e50fbe41581eeb323633bdb3da82ae90a49616fb3043e28e1c5 SHA512 8a85c38456b6298bb5d19a21247c1c15b3caf4b09bbf892612f688d2e7e48b3ef5c802386507300e6b78101d81178aece8610fc9df37e5aa3d3416038fa291b7
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/unreal-tournament-bonuspacks/metadata.xml b/games-fps/unreal-tournament-bonuspacks/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
new file mode 100644
index 000000000000..bbc8edb8a3fe
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Futuristic FPS (bonus packs)"
+HOMEPAGE="http://www.oldunreal.com/"
+# UT has 4 official bonus packs ...
+# [UTBonusPack] -> loki put into games-fps/unreal-tournament
+# [UTBonusPack2] -> loki put into games-fps/unreal-tournament
+# [UTiNoxxPack] -> loki put into games-fps/unreal-tournament
+# [UTBonusPack4] -> none of this is in games-fps/unreal-tournament
+SRC_URI="http://www.ut-files.com/Patches/utbonuspack4.zip -> UTBonusPack4.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+RDEPEND="|| (
+ games-fps/unreal-tournament
+ games-fps/unreal-tournament-goty )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ games-util/umodpack"
+
+S=${WORKDIR}
+
+src_install() {
+ # unpack the UTBonusPack4 umod
+ umod -v -b "$(pwd)" -x UTBonusPack4.umod || die
+
+ # move stuff around
+ rm UTBonusPack4.umod
+ mv system System
+ mv textures Textures
+
+ # install it all
+ local dir=${GAMES_PREFIX_OPT}/unreal-tournament
+ dodir "${dir}"
+ mv * "${D}/${dir}/"
+
+ prepgamesdirs
+}