summaryrefslogtreecommitdiff
path: root/games-fps/tribes2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-fps/tribes2
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-fps/tribes2')
-rw-r--r--games-fps/tribes2/Manifest2
-rw-r--r--games-fps/tribes2/tribes2-25034.ebuild35
2 files changed, 18 insertions, 19 deletions
diff --git a/games-fps/tribes2/Manifest b/games-fps/tribes2/Manifest
index d5227e8a275a..1b0649d6204c 100644
--- a/games-fps/tribes2/Manifest
+++ b/games-fps/tribes2/Manifest
@@ -1,3 +1,3 @@
DIST tribes2-25034-cdrom-x86.run 95560158 BLAKE2B a4516fddde83a8623348557983b3b5592c24108805da521d1b24bee21c06f8300ca812db8533855b70d924c59cf2bf417a771daa417c7f9b79e39f34a3611f98 SHA512 a3d2800af06d8659193ed1da4b9042af0924e1a0ade8a410aec31d66591efa2d2773aa12b33f7234975efee083974a77434bb1c0124bd57bfcc3be4898c46ad8
-EBUILD tribes2-25034.ebuild 2083 BLAKE2B c842073958db1bad6b5dcb6fc5eca20976f4f3c97e254c5dad16c60da53ef5a9accdb704628da9577901fde71f9b43a3ee8010cfc659e56c8b11a340ce76e853 SHA512 d7f3caf76e99cf64984d731f71c242d55323b276b9c3f56e547f2495e273d04a74f7efff72ed5e0c39ea04ec6d4b6235919fdab70f55d16587d99e975202dc60
+EBUILD tribes2-25034.ebuild 2030 BLAKE2B 1e760c46cd969e59376fd87ad3c036083f44dbd20632fe082f75517604f734c67beb34721f6a3448ce5fb6c9df7ca129c36111ebe4df6311e47c54a011009e24 SHA512 5ef2e89cfeccb357c282b5fb8e86c5d77f9358f07aefdf1d646cb4817a6e6824015d17bfea83746dd44fc75635332917fa392a1c957cdb7b93d5ffb40a8ed95c
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/tribes2/tribes2-25034.ebuild b/games-fps/tribes2/tribes2-25034.ebuild
index b6863191127a..225678114969 100644
--- a/games-fps/tribes2/tribes2-25034.ebuild
+++ b/games-fps/tribes2/tribes2-25034.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils unpacker cdrom games
+EAPI=7
+
+inherit cdrom desktop unpacker wrapper
DESCRIPTION="Tribes 2 - Team Combat on an Epic Scale"
HOMEPAGE="http://www.lokigames.com/products/tribes2/"
SRC_URI="http://www.libsdl.org/projects/${PN}/release/${P}-cdrom-x86.run"
+S="${WORKDIR}"
LICENSE="LOKI-EULA"
SLOT="0"
@@ -14,21 +16,21 @@ SLOT="0"
# time to try to figure it out but this definitely needs to stay -amd64 until
# someone does fix the patching.
KEYWORDS="-amd64 ~x86"
-IUSE=""
RESTRICT="mirror bindist strip"
-DEPEND="sys-libs/glibc
- games-util/loki_patch"
-RDEPEND="${DEPEND}
- virtual/opengl"
-
-S=${WORKDIR}
+DEPEND="
+ sys-libs/glibc
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/opengl
+"
+BDEPEND="games-util/loki_patch"
-dir=${GAMES_PREFIX_OPT}/${PN}
-Ddir=${D}/${dir}
+dir=opt/${PN}
+Ddir="${ED}"/${dir}
pkg_setup() {
- games_pkg_setup
ewarn "The installed game takes about 507MB of space!"
}
@@ -59,17 +61,14 @@ src_install() {
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find "${Ddir}" -exec touch '{}' +
+ find "${Ddir}" -exec touch '{}' + || die
newicon "${CDROM_ROOT}"/icon.xpm tribes2.xpm
- games_make_wrapper t2launch ./t2launch "${dir}" "${dir}"
+ make_wrapper t2launch ./t2launch "${dir}" "${dir}"
make_desktop_entry t2launch "Tribes 2" tribes2
-
- prepgamesdirs
}
pkg_postinst() {
- games_pkg_postinst
elog "To play the game run:"
elog " t2launch"
}