summaryrefslogtreecommitdiff
path: root/games-fps/qudos/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
commitc92d0cd2b34d17bce6d5bb4e3a4fc00af4193c99 (patch)
tree517559f918260cf91e7bdd4e484aa6fe9085cb9f /games-fps/qudos/files
parenta59ffccce3bf214fae9932cc42400eeeaec25c6c (diff)
gentoo auto-resync : 24:11:2022 - 13:10:39
Diffstat (limited to 'games-fps/qudos/files')
-rw-r--r--games-fps/qudos/files/qudos-0.40.1-gnusource.patch12
-rw-r--r--games-fps/qudos/files/qudos-0.40.1-libjpeg-clash.patch25
-rw-r--r--games-fps/qudos/files/qudos-0.40.1-libpng.patch30
-rw-r--r--games-fps/qudos/files/qudos-0.40.1-no-bits-nan.patch12
-rw-r--r--games-fps/qudos/files/qudos-0.40.1-respect-cc.patch15
-rw-r--r--games-fps/qudos/files/qudos-0.40.1-respect-libdir.patch53
-rw-r--r--games-fps/qudos/files/qudos-0.40.1-use-pkg-config.patch30
-rw-r--r--games-fps/qudos/files/qudos-0.40.1-zlib-build.patch12
8 files changed, 0 insertions, 189 deletions
diff --git a/games-fps/qudos/files/qudos-0.40.1-gnusource.patch b/games-fps/qudos/files/qudos-0.40.1-gnusource.patch
deleted file mode 100644
index b82a276b012c..000000000000
--- a/games-fps/qudos/files/qudos-0.40.1-gnusource.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/unix/qsh_unix.c
-+++ b/src/unix/qsh_unix.c
-@@ -17,6 +17,9 @@
- * Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- *
- */
-+#if !defined(_GNU_SOURCE)
-+ #define _GNU_SOURCE
-+#endif
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <sys/time.h>
diff --git a/games-fps/qudos/files/qudos-0.40.1-libjpeg-clash.patch b/games-fps/qudos/files/qudos-0.40.1-libjpeg-clash.patch
deleted file mode 100644
index 944c1aff856c..000000000000
--- a/games-fps/qudos/files/qudos-0.40.1-libjpeg-clash.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From c657cd54baee3bdfe7a92c9b91536bb5c3ddcdd8 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Mon, 24 Oct 2022 17:50:17 +0100
-Subject: [PATCH 2/5] Fix clash with libjpeg
-
---- a/src/ref_gl/gl_image.c
-+++ b/src/ref_gl/gl_image.c
-@@ -912,7 +912,7 @@ jpg_skip_input_data(j_decompress_ptr cinfo, long num_bytes)
- }
-
- void
--jpeg_mem_src(j_decompress_ptr cinfo, byte * mem, int len)
-+qudos_jpeg_mem_src(j_decompress_ptr cinfo, byte * mem, int len)
- {
- cinfo->src = (struct jpeg_source_mgr *)(*cinfo->mem->alloc_small) ((j_common_ptr) cinfo, JPOOL_PERMANENT, sizeof(struct jpeg_source_mgr));
- cinfo->src->init_source = jpg_null;
-@@ -956,7 +956,7 @@ LoadJPG(char *filename, byte ** pic, int *width, int *height)
- jpeg_create_decompress(&cinfo);
-
- /* Feed JPEG memory into the libJpeg Object */
-- jpeg_mem_src(&cinfo, rawdata, rawsize);
-+ qudos_jpeg_mem_src(&cinfo, rawdata, rawsize);
-
- /* Process JPEG header */
- jpeg_read_header(&cinfo, true);
diff --git a/games-fps/qudos/files/qudos-0.40.1-libpng.patch b/games-fps/qudos/files/qudos-0.40.1-libpng.patch
deleted file mode 100644
index 78fb4cdb7bd5..000000000000
--- a/games-fps/qudos/files/qudos-0.40.1-libpng.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/src/ref_gl/gl_local.h
-+++ b/src/ref_gl/gl_local.h
-@@ -29,6 +29,7 @@
- #include <GL/glu.h>
- #include <GL/glext.h>
-
-+#include <zlib.h> /* Z_DEFAULT_COMPRESSION */
- #include <png.h>
- #include <jpeglib.h>
-
-Subject: [PATCH] Fix build with libpng 1.4.0
-
-From the 1.4.0 release notes:
-```
- m. The function png_set_gray_1_2_4_to_8() was removed. It has been
- deprecated since libpng-1.0.18 and 1.2.9, when it was replaced with
- png_set_expand_gray_1_2_4_to_8() because the former function also
- expanded palette images.
-```
---- a/src/ref_gl/gl_image.c
-+++ b/src/ref_gl/gl_image.c
-@@ -1186,7 +1186,7 @@ LoadPNG(char *filename, byte ** pic, int *width, int *height)
- if (my_png->ColorType == PNG_COLOR_TYPE_PALETTE)
- png_set_palette_to_rgb(png);
- if (my_png->ColorType == PNG_COLOR_TYPE_GRAY && my_png->BitDepth < 8)
-- png_set_gray_1_2_4_to_8(png);
-+ png_set_expand_gray_1_2_4_to_8(png);
-
- /* Add alpha channel if present */
- if (png_get_valid(png, pnginfo, PNG_INFO_tRNS))
diff --git a/games-fps/qudos/files/qudos-0.40.1-no-bits-nan.patch b/games-fps/qudos/files/qudos-0.40.1-no-bits-nan.patch
deleted file mode 100644
index adcffef23c40..000000000000
--- a/games-fps/qudos/files/qudos-0.40.1-no-bits-nan.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/mods/rogue/g_local.h
-+++ b/src/mods/rogue/g_local.h
-@@ -26,9 +26,6 @@
- //==================================================================
-
- #ifndef _WIN32
--#ifdef __linux__
--#include <bits/nan.h>
--#endif
- #define min(a,b) ((a) < (b) ? (a) : (b))
- #define max(a,b) ((a) > (b) ? (a) : (b))
- #ifdef __sun__
diff --git a/games-fps/qudos/files/qudos-0.40.1-respect-cc.patch b/games-fps/qudos/files/qudos-0.40.1-respect-cc.patch
deleted file mode 100644
index 92c7028e1890..000000000000
--- a/games-fps/qudos/files/qudos-0.40.1-respect-cc.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-From 76aef29111d0b8c5e5fffe80833d0c227cca1127 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Mon, 24 Oct 2022 17:54:38 +0100
-Subject: [PATCH 4/5] Respect CC
-
---- a/Makefile
-+++ b/Makefile
-@@ -60,7 +60,6 @@ PREFIX?= $(LOCALBASE)
- DATADIR?= $(LOCALBASE)/share/quake2
- LIBDIR?= $(LOCALBASE)/lib/QuDos
-
--CC?= gcc
- TYPE?= release
-
- OGG_LDFLAGS= -lvorbisfile -lvorbis -logg
diff --git a/games-fps/qudos/files/qudos-0.40.1-respect-libdir.patch b/games-fps/qudos/files/qudos-0.40.1-respect-libdir.patch
deleted file mode 100644
index b3e0cdc5a2f7..000000000000
--- a/games-fps/qudos/files/qudos-0.40.1-respect-libdir.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 1dc6681ee4eea2d1b6e7edd04cf84fd10c407d28 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Mon, 24 Oct 2022 17:54:12 +0100
-Subject: [PATCH 3/5] Respect libdir
-
---- a/Makefile
-+++ b/Makefile
-@@ -55,7 +55,6 @@ WITH_XMMS?=YES # Enable XMMS support (thanks AprQ2).
-
- # General variables.
- LOCALBASE?= /usr/local
--X11BASE?= /usr/X11R6
- PREFIX?= $(LOCALBASE)
-
- DATADIR?= $(LOCALBASE)/share/quake2
-@@ -98,34 +97,19 @@ GAME_NAME= game$(ARCH).$(SHLIB_EXT)
- endif
-
- # Compilation flags.
--CFLAGS+= -I/usr/include -I$(LOCALBASE)/include -I$(X11BASE)/include \
-+CFLAGS+= -I/usr/include -I$(LOCALBASE)/include \
- -DGAME_NAME='"$(GAME_NAME)"' -DQUDOS_VERSION='"$(VERSION)"'
-
- WARNS= -Wshadow -Wpointer-arith -Wcast-align -Waggregate-return -Wstrict-prototypes -Wredundant-decls -Wnested-externs
-
--ifeq ($(TYPE),debug)
--CFLAGS+= -Wall -Werror -g -ggdb -DDEBUGGING # $(WARNS)
--else
-- ifeq ($(TYPE),profile)
--CFLAGS+= -pg
-- else
--CFLAGS+= -O3 -ffast-math -funroll-loops -fomit-frame-pointer \
-- -fexpensive-optimizations
-- ifeq ($(ARCH),i386)
--CFLAGS+= -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
-- -fno-strict-aliasing
-- endif
-- endif
--endif
--
- # Linker flags.
--LDFLAGS+= -L/usr/lib -L$(LOCALBASE)/lib -L$(X11BASE)/lib -lm
-+LDFLAGS+= -lm
-
- ifeq ($(OSTYPE),Linux)
- LDFLAGS+= -ldl
- endif
-
--REF_LDFLAGS= -L/usr/X11R6/lib -lX11 -lXext -lXxf86vm -lGLU -ljpeg -lpng
-+REF_LDFLAGS= -lX11 -lXext -lXxf86vm -lGLU -ljpeg -lpng
-
- ifeq ($(strip $(WITH_DGA_MOUSE)),YES)
- REF_LDFLAGS+= -lXxf86dga
diff --git a/games-fps/qudos/files/qudos-0.40.1-use-pkg-config.patch b/games-fps/qudos/files/qudos-0.40.1-use-pkg-config.patch
deleted file mode 100644
index c2aae64e2b32..000000000000
--- a/games-fps/qudos/files/qudos-0.40.1-use-pkg-config.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 372cfdd9c81043667451fc46bcb8daaa5a5e3620 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Mon, 24 Oct 2022 17:56:14 +0100
-Subject: [PATCH 5/5] Use pkg-config
-
---- a/Makefile
-+++ b/Makefile
-@@ -64,9 +64,9 @@ TYPE?= release
-
- OGG_LDFLAGS= -lvorbisfile -lvorbis -logg
-
--SDL_CONFIG?= sdl-config
--SDL_CFLAGS= $(shell $(SDL_CONFIG) --cflags)
--SDL_LDFLAGS= $(shell $(SDL_CONFIG) --libs)
-+PKG_CONFIG?= pkg-config
-+SDL_CFLAGS= $(shell ${PKG_CONFIG} --cflags sdl)
-+SDL_LDFLAGS= $(shell ${PKG_CONFIG} --libs sdl)
-
- ifeq ($(OSTYPE),Linux)
- ALSA_LDFLAGS= -lasound
-@@ -96,8 +95,7 @@ GAME_NAME= game$(ARCH).$(SHLIB_EXT)
- endif
-
- # Compilation flags.
--CFLAGS+= -I/usr/include -I$(LOCALBASE)/include \
-- -DGAME_NAME='"$(GAME_NAME)"' -DQUDOS_VERSION='"$(VERSION)"'
-+CFLAGS+= -DGAME_NAME='"$(GAME_NAME)"' -DQUDOS_VERSION='"$(VERSION)"'
-
- WARNS= -Wshadow -Wpointer-arith -Wcast-align -Waggregate-return -Wstrict-prototypes -Wredundant-decls -Wnested-externs
-
diff --git a/games-fps/qudos/files/qudos-0.40.1-zlib-build.patch b/games-fps/qudos/files/qudos-0.40.1-zlib-build.patch
deleted file mode 100644
index d2e1474f2d7b..000000000000
--- a/games-fps/qudos/files/qudos-0.40.1-zlib-build.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-From bdd75315feed9fbaaf9dcf87f9a7e5eb18ca0b8b Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Mon, 24 Oct 2022 17:50:02 +0100
-Subject: [PATCH 1/5] Fix zlib build
-
---- a/src/qcommon/unzip/ioapi.h
-+++ b/src/qcommon/unzip/ioapi.h
-@@ -1,3 +1,4 @@
-+#define OF(x) x
- /*
- * ioapi.h -- IO base function header for compress/uncompress .zip files
- * using zlib + zip or unzip API