summaryrefslogtreecommitdiff
path: root/games-fps/quake4-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/quake4-data
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/quake4-data')
-rw-r--r--games-fps/quake4-data/Manifest2
-rw-r--r--games-fps/quake4-data/metadata.xml8
-rw-r--r--games-fps/quake4-data/quake4-data-1.0.2147.12.ebuild56
3 files changed, 66 insertions, 0 deletions
diff --git a/games-fps/quake4-data/Manifest b/games-fps/quake4-data/Manifest
new file mode 100644
index 000000000000..6a9f21e4f4c4
--- /dev/null
+++ b/games-fps/quake4-data/Manifest
@@ -0,0 +1,2 @@
+EBUILD quake4-data-1.0.2147.12.ebuild 1361 BLAKE2B a0de8eaff617a7d141522bee966d0d99bc199f46acefcf1a9eed83eb867d4ca0ef08314799f1690f600ff1848ed03237cab8088e549b13881633b3494328eeee SHA512 cd704c1ee316a4388582743f5b04efd3114f65acd11692654f9657616b2ad380668c83f1e7b01ba70dfb9718f237750074ec10d9cc25e686b3365ef32f38563e
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/quake4-data/metadata.xml b/games-fps/quake4-data/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/quake4-data/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/quake4-data/quake4-data-1.0.2147.12.ebuild b/games-fps/quake4-data/quake4-data-1.0.2147.12.ebuild
new file mode 100644
index 000000000000..a4675a6b575f
--- /dev/null
+++ b/games-fps/quake4-data/quake4-data-1.0.2147.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils cdrom games
+
+DESCRIPTION="sequel to Quake 2, an id 3D first-person shooter"
+HOMEPAGE="http://www.quake4game.com/"
+SRC_URI=""
+
+LICENSE="QUAKE4"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="app-arch/bzip2
+ app-arch/tar"
+RDEPEND=""
+PDEPEND="games-fps/quake4-bin"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/quake4
+Ddir=${D}/${dir}
+
+src_install() {
+ cdrom_get_cds Setup/Data/q4base/pak012.pk4 \
+ Setup/Data/q4base/pak001.pk4 \
+ Setup/Data/q4base/pak004.pk4 \
+ Setup/Data/q4base/pak007.pk4
+ insinto "${dir}"/q4base
+ einfo "Copying files from Disk 1..."
+ doins "${CDROM_ROOT}"/Setup/Data/q4base/pak01{0,1,2}.pk4 \
+ "${CDROM_ROOT}"/Setup/Data/q4base/zpak*.pk4
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 2..."
+ doins "${CDROM_ROOT}"/Setup/Data/q4base/pak00{1,2,3}.pk4
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 3..."
+ doins "${CDROM_ROOT}"/Setup/Data/q4base/pak00{4,5,6}.pk4
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 4..."
+ doins "${CDROM_ROOT}"/Setup/Data/q4base/pak00{7,8,9}.pk4
+
+ find "${Ddir}" -exec touch '{}' +
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "This is just the data portion of the game. You need to merge"
+ elog "games-fps/quake4-bin to play."
+ echo
+}