summaryrefslogtreecommitdiff
path: root/games-fps/quake4-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-fps/quake4-data
reinit the tree, so we can have metadata
Diffstat (limited to 'games-fps/quake4-data')
-rw-r--r--games-fps/quake4-data/Manifest4
-rw-r--r--games-fps/quake4-data/metadata.xml8
-rw-r--r--games-fps/quake4-data/quake4-data-1.0.2147.12.ebuild56
3 files changed, 68 insertions, 0 deletions
diff --git a/games-fps/quake4-data/Manifest b/games-fps/quake4-data/Manifest
new file mode 100644
index 000000000000..cd545ef1dd19
--- /dev/null
+++ b/games-fps/quake4-data/Manifest
@@ -0,0 +1,4 @@
+EBUILD quake4-data-1.0.2147.12.ebuild 1359 SHA256 67e2d968429b048fa5a1c0259e7be8a6ca756eeec2c68e672585fda034fa7e61 SHA512 d0ea5733dbc6c695ccde764f9d5765f397af538b1792eff5edd742483704c3e8791cef5468ff772001bf9fb227235aaaf3d3dea1d47420669e54b75f242f7216 WHIRLPOOL 3f4da930786c42972224fb0e48d5c68767f88c0b50bd44e353ca56780d199b16d90a25373e72dede33b451c256258f06a5025a0d29f4f4db14a0351329aed53f
+MISC ChangeLog 2586 SHA256 c3668dd855b537cbf9860b05a2907851beafcb3e43353a113e9805af4c417510 SHA512 a0361dafb47b650659d16ed921c8ba2504b8143a7f190bcb159c310038da7d46b9e0ca723518c89999431717c174cb9bad0e07dd1627afad78b2e9bebe5529de WHIRLPOOL 9d4a52c79e97c12646c5d8cfe95b78d655e94b6366870571eb6916b890b51040e6f28f764dceb7aee6bf2d8bc32011366bdcdb26756855589dc3e1c4749a3366
+MISC ChangeLog-2015 2259 SHA256 fba801f2735bc85e51fd493e4c52cb692ae2a689b3c99f6d719da2c9476cacf7 SHA512 bcbc829644cd3b35018668081ae02d61e212baa7b4d00ea823247e15f449f17b264b028716d95043ce46afe9c4520067ca7558c4e23ce99e9ef67d31898ebfa9 WHIRLPOOL 559f6a1cd28dee6720f1dc4cfbb9024bb0d7ca83a36d644a28798e5c902d967e1246ad4c9fe98fdfd384d2ec9742bf509535de7b2999461e8eadbabeeff6c461
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-fps/quake4-data/metadata.xml b/games-fps/quake4-data/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/quake4-data/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/quake4-data/quake4-data-1.0.2147.12.ebuild b/games-fps/quake4-data/quake4-data-1.0.2147.12.ebuild
new file mode 100644
index 000000000000..62cfd11dd1de
--- /dev/null
+++ b/games-fps/quake4-data/quake4-data-1.0.2147.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils cdrom games
+
+DESCRIPTION="sequel to Quake 2, an id 3D first-person shooter"
+HOMEPAGE="http://www.quake4game.com/"
+SRC_URI=""
+
+LICENSE="QUAKE4"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="app-arch/bzip2
+ app-arch/tar"
+RDEPEND=""
+PDEPEND="games-fps/quake4-bin"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/quake4
+Ddir=${D}/${dir}
+
+src_install() {
+ cdrom_get_cds Setup/Data/q4base/pak012.pk4 \
+ Setup/Data/q4base/pak001.pk4 \
+ Setup/Data/q4base/pak004.pk4 \
+ Setup/Data/q4base/pak007.pk4
+ insinto "${dir}"/q4base
+ einfo "Copying files from Disk 1..."
+ doins "${CDROM_ROOT}"/Setup/Data/q4base/pak01{0,1,2}.pk4 \
+ "${CDROM_ROOT}"/Setup/Data/q4base/zpak*.pk4
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 2..."
+ doins "${CDROM_ROOT}"/Setup/Data/q4base/pak00{1,2,3}.pk4
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 3..."
+ doins "${CDROM_ROOT}"/Setup/Data/q4base/pak00{4,5,6}.pk4
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 4..."
+ doins "${CDROM_ROOT}"/Setup/Data/q4base/pak00{7,8,9}.pk4
+
+ find "${Ddir}" -exec touch '{}' +
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "This is just the data portion of the game. You need to merge"
+ elog "games-fps/quake4-bin to play."
+ echo
+}